aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-18 22:08:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-18 22:08:16 +0000
commitdd8636b8e25d98ddb06ce94a41f1e85ff1905a19 (patch)
treee7f8cea2af8a6e042f413929cc9f58704ffd230b /graphics
parent0a76875e59580223dc5e810baf26fe68de1aa40b (diff)
downloadports-dd8636b8e25d98ddb06ce94a41f1e85ff1905a19.tar.gz
ports-dd8636b8e25d98ddb06ce94a41f1e85ff1905a19.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sswf/Makefile28
-rw-r--r--graphics/sswf/distinfo6
-rw-r--r--graphics/sswf/pkg-descr4
-rw-r--r--graphics/sswf/pkg-plist51
4 files changed, 68 insertions, 21 deletions
diff --git a/graphics/sswf/Makefile b/graphics/sswf/Makefile
index 57e1e97185a1..924b1d3d4384 100644
--- a/graphics/sswf/Makefile
+++ b/graphics/sswf/Makefile
@@ -6,12 +6,10 @@
#
PORTNAME= sswf
-PORTVERSION= 1.7.4
-PORTREVISION= 1
+PORTVERSION= 1.8.3
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= sswf
-DISTNAME= sswf-${PORTVERSION}-src
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= A library and script language tool to create Flash movies
@@ -19,13 +17,23 @@ COMMENT= A library and script language tool to create Flash movies
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
freetype.9:${PORTSDIR}/print/freetype2
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_GNOME= gnometarget pkgconfig
USE_BISON= build
-USE_AUTOTOOLS= libtool:15
-WRKSRC= ${WRKDIR}/sswf-${PORTVERSION}
USE_ICONV= yes
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.if !defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --disable-debug --disable-yydebug
+.endif
.include <bsd.port.mk>
diff --git a/graphics/sswf/distinfo b/graphics/sswf/distinfo
index 66a2685f31d6..5daa4e6613cc 100644
--- a/graphics/sswf/distinfo
+++ b/graphics/sswf/distinfo
@@ -1,3 +1,3 @@
-MD5 (sswf-1.7.4-src.tar.gz) = 7a82b62b058ed764991af716e8f9a629
-SHA256 (sswf-1.7.4-src.tar.gz) = 109dbd7462699017c872efaef3a7586fb618cf974fea58a7150cd04bd2c72786
-SIZE (sswf-1.7.4-src.tar.gz) = 3106758
+MD5 (sswf-1.8.3-src.tar.gz) = 4cb8b41583e62aba322677304f02a6b6
+SHA256 (sswf-1.8.3-src.tar.gz) = f5e3aae8a121323116ef134b5543eadcd911dab5bccc967d5ed846aa8d5f5b08
+SIZE (sswf-1.8.3-src.tar.gz) = 3450029
diff --git a/graphics/sswf/pkg-descr b/graphics/sswf/pkg-descr
index 902cd62c172d..14a11be310fb 100644
--- a/graphics/sswf/pkg-descr
+++ b/graphics/sswf/pkg-descr
@@ -1,5 +1,5 @@
A C++ Library and a script language tool to create Flash (SWF) movies up to
-version 7. Supports nearly all the Macromedia Flash tags. Includes detailled
+version 9. Supports nearly all the Macromedia Flash tags. Includes detailled
docs and a tool to convert your system fonts to a Flash movie.
-WWW: http://sourceforge.net/projects/sswf
+WWW: http://www.m2osw.com/sswf
diff --git a/graphics/sswf/pkg-plist b/graphics/sswf/pkg-plist
index 1dd1c7af478e..2ce395cdd459 100644
--- a/graphics/sswf/pkg-plist
+++ b/graphics/sswf/pkg-plist
@@ -8,20 +8,31 @@ include/sswf/libsswf-version.h
include/sswf/libsswf.h
include/sswf/libsswf_as.h
include/sswf/libsswf_asas.h
-lib/libsswf-1.7.4.so
+include/sswf/libsswf_c.h
+lib/libsswf-%%VERSION%%.so
+lib/libsswf-%%VERSION%%.so.3
lib/libsswf.a
lib/libsswf.la
lib/libsswf.so
-lib/libsswf_as-1.7.4.so
+lib/libsswf_as-%%VERSION%%.so
+lib/libsswf_as-%%VERSION%%.so.1
lib/libsswf_as.a
lib/libsswf_as.la
lib/libsswf_as.so
-lib/libsswf_asas-1.7.4.so
+lib/libsswf_asas-%%VERSION%%.so
+lib/libsswf_asas-%%VERSION%%.so.1
lib/libsswf_asas.a
lib/libsswf_asas.la
lib/libsswf_asas.so
-@comment For non-standard prefixes
-@unexec rm -f %D/libdata/ldconfig/sswf 2>/dev/null || true
+lib/libsswf_c-%%VERSION%%.so
+lib/libsswf_c-%%VERSION%%.so.2
+lib/libsswf_c.a
+lib/libsswf_c.la
+lib/libsswf_c.so
+libdata/pkgconfig/libsswf.pc
+libdata/pkgconfig/libsswf_as.pc
+libdata/pkgconfig/libsswf_asas.pc
+libdata/pkgconfig/libsswf_c.pc
%%DATADIR%%/ASC-TODO.txt
%%DATADIR%%/AUTHORS.txt
%%DATADIR%%/CHANGES.txt
@@ -31,6 +42,7 @@ lib/libsswf_asas.so
%%DATADIR%%/INSTALL-RPM.txt
%%DATADIR%%/INSTALL-SLACKWARE.txt
%%DATADIR%%/INSTALL-SRC.txt
+%%DATADIR%%/INSTALL-ZSERIES.txt
%%DATADIR%%/INSTALL.txt
%%DATADIR%%/LICENSE.txt
%%DATADIR%%/LINKS.txt
@@ -48,14 +60,33 @@ lib/libsswf_asas.so
%%DATADIR%%/samples/asc_logo/run
%%DATADIR%%/samples/asc_logo/run.bat
%%DATADIR%%/samples/asc_logo/swf_dump-tables.jpg
+%%DATADIR%%/samples/c-samples/makefile
+%%DATADIR%%/samples/c-samples/simple.c
+%%DATADIR%%/samples/c-samples/simple.html
%%DATADIR%%/samples/check_version/makefile
%%DATADIR%%/samples/check_version/version.c++
+%%DATADIR%%/samples/clock/clock.html
+%%DATADIR%%/samples/clock/clock.sswf
+%%DATADIR%%/samples/clock/roman_complex.sswf
+%%DATADIR%%/samples/clock/run
+%%DATADIR%%/samples/clock/run.bat
%%DATADIR%%/samples/dyn-button/button.html
%%DATADIR%%/samples/dyn-button/button.sswf
%%DATADIR%%/samples/dyn-button/clicked.html
%%DATADIR%%/samples/dyn-button/run
%%DATADIR%%/samples/dyn-button/run.bat
%%DATADIR%%/samples/functions/find-sswf.sh
+%%DATADIR%%/samples/gradients/gradients.html
+%%DATADIR%%/samples/gradients/gradients.sswf
+%%DATADIR%%/samples/gradients/run
+%%DATADIR%%/samples/gradients/run.bat
+%%DATADIR%%/samples/grid-button/corner.tga
+%%DATADIR%%/samples/grid-button/grid-button.html
+%%DATADIR%%/samples/grid-button/grid-button.sswf
+%%DATADIR%%/samples/grid-button/run
+%%DATADIR%%/samples/grid-button/run.bat
+%%DATADIR%%/samples/grid-button/side.tga
+%%DATADIR%%/samples/grid-button/text.tga
%%DATADIR%%/samples/lanuit-mp3/README.txt
%%DATADIR%%/samples/lanuit-mp3/lanuit.html
%%DATADIR%%/samples/lanuit-mp3/lanuit.mp3
@@ -90,6 +121,10 @@ lib/libsswf_asas.so
%%DATADIR%%/samples/libya/tokra_icon.tga
%%DATADIR%%/samples/libya/tripoli.html
%%DATADIR%%/samples/libya/tripoli_icon.tga
+%%DATADIR%%/samples/line-styles/line-styles.html
+%%DATADIR%%/samples/line-styles/line-styles.sswf
+%%DATADIR%%/samples/line-styles/run
+%%DATADIR%%/samples/line-styles/run.bat
%%DATADIR%%/samples/logo/logo.html
%%DATADIR%%/samples/logo/logo.png
%%DATADIR%%/samples/logo/logo.sswf
@@ -120,7 +155,6 @@ lib/libsswf_asas.so
%%DATADIR%%/samples/news-samples/simple.html
%%DATADIR%%/samples/news-samples/sprite.c++
%%DATADIR%%/samples/news-samples/sprite.html
-%%DATADIR%%/samples/news-samples/typescript
%%DATADIR%%/samples/scroller/run
%%DATADIR%%/samples/scroller/run.bat
%%DATADIR%%/samples/scroller/scroller.html
@@ -207,11 +241,16 @@ lib/libsswf_asas.so
@dirrm %%DATADIR%%/samples/new-anim
@dirrm %%DATADIR%%/samples/morph
@dirrm %%DATADIR%%/samples/logo
+@dirrm %%DATADIR%%/samples/line-styles
@dirrm %%DATADIR%%/samples/libya
@dirrm %%DATADIR%%/samples/lanuit-mp3
+@dirrm %%DATADIR%%/samples/grid-button
+@dirrm %%DATADIR%%/samples/gradients
@dirrm %%DATADIR%%/samples/functions
@dirrm %%DATADIR%%/samples/dyn-button
+@dirrm %%DATADIR%%/samples/clock
@dirrm %%DATADIR%%/samples/check_version
+@dirrm %%DATADIR%%/samples/c-samples
@dirrm %%DATADIR%%/samples/asc_logo
@dirrm %%DATADIR%%/samples
@dirrm %%DATADIR%%/misc