aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2015-02-07 08:58:20 +0000
committerMarcus von Appen <mva@FreeBSD.org>2015-02-07 08:58:20 +0000
commite1b4d7d9849367084c9c9ad50b05e3311cf7765a (patch)
treee1a5f01092ca21d5ebbc4df83ae5b62741709c01 /graphics
parentbe96c81884689d5666f6e6eccfff21e94aa566ab (diff)
downloadports-e1b4d7d9849367084c9c9ad50b05e3311cf7765a.tar.gz
ports-e1b4d7d9849367084c9c9ad50b05e3311cf7765a.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sdl_ttf/Makefile2
-rw-r--r--graphics/sdl_ttf/files/patch-bug143319
2 files changed, 20 insertions, 1 deletions
diff --git a/graphics/sdl_ttf/Makefile b/graphics/sdl_ttf/Makefile
index 8582b04e5c3d..29443d7d48d5 100644
--- a/graphics/sdl_ttf/Makefile
+++ b/graphics/sdl_ttf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sdl_ttf
PORTVERSION= 2.0.11
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_ttf/release/
DISTNAME= SDL_ttf-${PORTVERSION}
diff --git a/graphics/sdl_ttf/files/patch-bug1433 b/graphics/sdl_ttf/files/patch-bug1433
new file mode 100644
index 000000000000..e24c9da15531
--- /dev/null
+++ b/graphics/sdl_ttf/files/patch-bug1433
@@ -0,0 +1,19 @@
+Description: Fix bug report "TTF_RenderGlyph_Shaded is broken"
+ Introduced in 2.0.11-2 (Sat, 03 Mar 2012).
+Author: Unknown
+Last-Update: 2012-03-03
+Bug-Debian: http://bugs.debian.org/661987
+Bug-Upstream: https://bugzilla.libsdl.org/show_bug.cgi?id=1433
+
+--- SDL_ttf.c
++++ SDL_ttf.c
+@@ -1752,7 +1752,7 @@
+ /* Copy the character from the pixmap */
+ src = glyph->pixmap.buffer;
+ dst = (Uint8*) textbuf->pixels;
+- for ( row = 0; row < glyph->bitmap.rows; ++row ) {
++ for ( row = 0; row < glyph->pixmap.rows; ++row ) {
+ memcpy( dst, src, glyph->pixmap.width );
+ src += glyph->pixmap.pitch;
+ dst += textbuf->pitch;
+