aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2018-10-03 16:41:35 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2018-10-03 16:41:35 +0000
commitf9f781293fe4f1f33db9b17f4051c6e1a52f1d91 (patch)
tree9e01257648296a3d0c5ff6838ebd4ea516c0b447 /graphics
parentdc8d48b842dccba7f8cc866e483d6d3d0b1a73ca (diff)
downloadports-f9f781293fe4f1f33db9b17f4051c6e1a52f1d91.tar.gz
ports-f9f781293fe4f1f33db9b17f4051c6e1a52f1d91.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sam2p/Makefile5
-rw-r--r--graphics/sam2p/distinfo6
-rw-r--r--graphics/sam2p/files/patch-configure16
-rw-r--r--graphics/sam2p/files/patch-gensh.hpp11
-rw-r--r--graphics/sam2p/files/patch-gensio.cpp18
-rw-r--r--graphics/sam2p/files/patch-in__ps.cpp20
-rw-r--r--graphics/sam2p/files/patch-minips.cpp32
-rw-r--r--graphics/sam2p/files/patch-ps__tiny.c27
8 files changed, 16 insertions, 119 deletions
diff --git a/graphics/sam2p/Makefile b/graphics/sam2p/Makefile
index 53ac5ff6151e..a1c467640214 100644
--- a/graphics/sam2p/Makefile
+++ b/graphics/sam2p/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sam2p
-PORTVERSION= 0.49.3
+PORTVERSION= 0.49.4
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/releases/download/v${PORTVERSION}/
@@ -22,8 +22,9 @@ GH_ACCOUNT= pts
USES= ghostscript:run gmake jpeg:run perl5
USE_PERL5= build
GNU_CONFIGURE= yes
-CONFIGURE_ENV= ac_cv_path_pts_bash="${SH}"
+CONFIGURE_ENV= MAKE=gmake ac_cv_path_pts_bash="${SH}"
CONFIGURE_ARGS= --enable-gif
+MAKE_ENV= MAKE=gmake
ALL_TARGET= ${PORTNAME}
PORTDOCS= *
diff --git a/graphics/sam2p/distinfo b/graphics/sam2p/distinfo
index ef95b23def18..d8cb2d70496a 100644
--- a/graphics/sam2p/distinfo
+++ b/graphics/sam2p/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1476179820
-SHA256 (sam2p-0.49.3.tar.gz) = 33b1bf018a19b19c30d41defcb8b20c7cdcbc7ddd7703040c3a54d9cb1fcaaea
-SIZE (sam2p-0.49.3.tar.gz) = 564098
+TIMESTAMP = 1538584194
+SHA256 (sam2p-0.49.4.tar.gz) = 5bc5b5a526bc798315da23b02564d6a1bfea51b364b8b03f76695a833f6d2bed
+SIZE (sam2p-0.49.4.tar.gz) = 497193
diff --git a/graphics/sam2p/files/patch-configure b/graphics/sam2p/files/patch-configure
index a766340360a6..8c90209ced1e 100644
--- a/graphics/sam2p/files/patch-configure
+++ b/graphics/sam2p/files/patch-configure
@@ -1,11 +1,15 @@
---- configure.orig 2014-01-19 19:50:35 UTC
+--- configure.orig 2017-09-13 12:09:54 UTC
+++ configure
-@@ -7520,7 +7520,7 @@ rm -f Makedep
+@@ -7518,9 +7518,9 @@ fi
+
+ rm -f Makedep
ac_n="${ac_n:-$ECHO_N}"
- echo $ac_n "running make Makedep""... $ac_c" 1>&6
- echo "configure:7504: running make Makedep" >&5
--if >&5 2>&5 make Makedep; then :
-+if >&5 2>&5 gmake Makedep; then :
+-echo $ac_n "running make Makedep.force""... $ac_c" 1>&6
+-echo "configure:7504: running make Makedep.force" >&5
+-if >&5 2>&5 make Makedep.force; then :
++echo $ac_n "running ${MAKE:-make} Makedep.force""... $ac_c" 1>&6
++echo "configure:7504: running ${MAKE:-make} Makedep.force" >&5
++if >&5 2>&5 ${MAKE:-make} Makedep.force; then :
echo "$as_me:$LINENO: result: ok" >&5
echo "${ECHO_T}ok" >&6
diff --git a/graphics/sam2p/files/patch-gensh.hpp b/graphics/sam2p/files/patch-gensh.hpp
deleted file mode 100644
index 86d04ae69457..000000000000
--- a/graphics/sam2p/files/patch-gensh.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- gensi.hpp.orig 2008-05-27 03:58:43.000000000 +0900
-+++ gensi.hpp 2010-03-19 05:53:15.000000000 +0900
-@@ -252,7 +252,7 @@
- if (len!=0) block(beg,len,data);
- block(0,0,data);
- }
-- inline virtual void first_sub(Sub &sub) const { sub.beg=beg; sub.len=len; };
-+ inline virtual void first_sub(Sub &sub) const { sub.beg=beg; sub.len=len; }
- inline virtual void next_sub(Sub &sub) const { sub.len=0; }
- inline char const*getCString() const { return beg; }
- inline char const*operator()() const { return beg; }
diff --git a/graphics/sam2p/files/patch-gensio.cpp b/graphics/sam2p/files/patch-gensio.cpp
index b62924454534..b0605da72f08 100644
--- a/graphics/sam2p/files/patch-gensio.cpp
+++ b/graphics/sam2p/files/patch-gensio.cpp
@@ -1,23 +1,5 @@
--- gensio.cpp.orig 2014-01-19 19:50:35 UTC
+++ gensio.cpp
-@@ -494,7 +494,7 @@ Filter::PipeE::PipeE(GenBuffer::Writable
-
- #if HAVE_PTS_POPEN
- if (!tmpsname) {
-- if (NULLP==(p=popen(redir_cmd(), "w"CFG_PTS_POPEN_B))) Error::sev(Error::EERROR) << "Filter::PipeE" << ": popen() failed: " << (SimBuffer::B().appendDumpC(redir_cmd)) << (Error*)0;
-+ if (NULLP==(p=popen(redir_cmd(), "w" CFG_PTS_POPEN_B))) Error::sev(Error::EERROR) << "Filter::PipeE" << ": popen() failed: " << (SimBuffer::B().appendDumpC(redir_cmd)) << (Error*)0;
- signal(SIGPIPE, SIG_IGN); /* Don't abort process with SIGPIPE signals if child cannot read our data */
- } else {
- #else
-@@ -622,7 +622,7 @@ slen_t Filter::PipeD::vi_read(char *tobu
- if (state==0) { /* Read the whole stream from `in', write it to `tmpsname' */
- #if HAVE_PTS_POPEN
- if (!tmpsname) {
-- if (NULLP==(p=popen(redir_cmd(), "w"CFG_PTS_POPEN_B))) Error::sev(Error::EERROR) << "Filter::PipeD" << ": popen() failed: " << (SimBuffer::B().appendDumpC(redir_cmd)) << (Error*)0;
-+ if (NULLP==(p=popen(redir_cmd(), "w" CFG_PTS_POPEN_B))) Error::sev(Error::EERROR) << "Filter::PipeD" << ": popen() failed: " << (SimBuffer::B().appendDumpC(redir_cmd)) << (Error*)0;
- signal(SIGPIPE, SIG_IGN); /* Don't abort process with SIGPIPE signals if child cannot read our data */
- vi_precopy();
- in.vi_read(0,0);
@@ -731,11 +731,7 @@ slen_t Filter::FlatD::vi_read(char *to_b
/* --- */
diff --git a/graphics/sam2p/files/patch-in__ps.cpp b/graphics/sam2p/files/patch-in__ps.cpp
deleted file mode 100644
index 6a1af8b31578..000000000000
--- a/graphics/sam2p/files/patch-in__ps.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- in_ps.cpp.orig 2014-01-19 19:50:35 UTC
-+++ in_ps.cpp
-@@ -137,7 +137,7 @@ static Image::Sampled *in_eps_reader(Ima
- // fprintf(stderr, "bbox=[%"PTS_CFG_PRINTFGLEN"g %"PTS_CFG_PRINTFGLEN"g %"PTS_CFG_PRINTFGLEN"g %"PTS_CFG_PRINTFGLEN"g]\n", llx, lly, urx, ury);
- /* Dat: we must call translate _after_ setpagedevice (so it will take effect), at least with ESP Ghostscript 7.05.6 (2003-02-05); BUGFIX at Fri Aug 12 22:49:07 CEST 2005 */
- sprintf(bboxline,
-- "<</PageSize[%"PTS_CFG_PRINTFGLEN"g %"PTS_CFG_PRINTFGLEN"g]>>setpagedevice\n"
-+ "<</PageSize[%" PTS_CFG_PRINTFGLEN "g %" PTS_CFG_PRINTFGLEN "g]>>setpagedevice\n"
- /* removing /PageSize also cancels /a4, /a5 etc. */
- /* we need `currentmatrix ... setpagedevice setmatrix' because
- * setpagedevice cancels the current transformation matrix so our
-@@ -147,7 +147,7 @@ static Image::Sampled *in_eps_reader(Ima
- "/setpagedevice{matrix currentmatrix exch "
- "dup length dict copy dup /PageSize undef setpagedevice "
- "setmatrix}bind def\n"
-- "%"PTS_CFG_PRINTFGLEN"g %"PTS_CFG_PRINTFGLEN"g translate\n"
-+ "%" PTS_CFG_PRINTFGLEN "g %" PTS_CFG_PRINTFGLEN "g translate\n"
- , urx-llx, ury-lly, -llx, -lly);
- } else {
- Error::sev(Error::WARNING) << "in_eps_reader: missing EPS bbox" << (Error*)0;
diff --git a/graphics/sam2p/files/patch-minips.cpp b/graphics/sam2p/files/patch-minips.cpp
deleted file mode 100644
index a9382922786e..000000000000
--- a/graphics/sam2p/files/patch-minips.cpp
+++ /dev/null
@@ -1,32 +0,0 @@
---- minips.cpp.orig 2014-01-19 19:50:35 UTC
-+++ minips.cpp
-@@ -292,9 +292,9 @@ MiniPS::Real::Real(double d_, char const
- void MiniPS::Real::dump(GenBuffer::Writable &out_, bool dumpPS_force) {
- char buf[64]; /* Imp: should be enough?? */
- if (metric!=0 && (dumpPS_force || dumpPS)) {
-- sprintf(buf, "%"PTS_CFG_PRINTFGLEN"g%s", d, me_psfactor[metric]);
-+ sprintf(buf, "%" PTS_CFG_PRINTFGLEN "g%s", d, me_psfactor[metric]);
- } else {
-- sprintf(buf, "%"PTS_CFG_PRINTFGLEN"g", d*me_factor[metric]);
-+ sprintf(buf, "%" PTS_CFG_PRINTFGLEN "g", d*me_factor[metric]);
- }
- out_ << buf;
- }
-@@ -1044,7 +1044,7 @@ void MiniPS::dumpScale(GenBuffer::Writab
- } else {
- d = d < 0 ? 72.0 / -d : d / 72.0;
- char buf[64]; /* Dat: enough */
-- sprintf(buf, "%"PTS_CFG_PRINTFGLEN"g", d);
-+ sprintf(buf, "%" PTS_CFG_PRINTFGLEN "g", d);
- out << buf;
- }
- }
-@@ -1093,7 +1093,7 @@ void MiniPS::dumpAdd3(GenBuffer::Writabl
- out << (rounding>=2 && ll<0 ? 0 : ll);
- } else {
- char buf[64]; /* Dat: enough */
-- sprintf(buf, "%"PTS_CFG_PRINTFGLEN"g", d);
-+ sprintf(buf, "%" PTS_CFG_PRINTFGLEN "g", d);
- out << buf;
- }
- }
diff --git a/graphics/sam2p/files/patch-ps__tiny.c b/graphics/sam2p/files/patch-ps__tiny.c
index eb03c4185d3a..7aaddafb9f9f 100644
--- a/graphics/sam2p/files/patch-ps__tiny.c
+++ b/graphics/sam2p/files/patch-ps__tiny.c
@@ -11,30 +11,3 @@
/* ps_tiny.c -- read .pin files, write short PostScript code
* by pts@fazekas.hu at Sat Aug 24 12:46:14 CEST 2002
* -- Sat Aug 24 18:23:08 CEST 2002
-@@ -151,7 +144,7 @@ static void ungetcc(int c) {
- }
-
- static void erri(char const*msg1, char const*msg2) {
-- fprintf(stderr, "%s: error at %"SLEN_P"u.%"SLEN_P"u.%"SLEN_P"u: %s%s\n",
-+ fprintf(stderr, "%s: error at %" SLEN_P "u.%" SLEN_P "u.%" SLEN_P "u: %s%s\n",
- PROGNAME, curline, curofs-leftofs+1, curofs, msg1, msg2?msg2:"");
- exit(3);
- }
-@@ -230,7 +223,7 @@ static sbool is_wordx(char const *s) {
- /** @param b: assume null-terminated @return true on error */
- static /*inline*/ sbool toInteger(char *s, psint_t *ret) {
- int n=0; /* BUGFIX?? found by __CHECKER__ */
-- return sscanf(s, "%"SLEN_P"i%n", ret, &n)<1 || s[n]!='\0';
-+ return sscanf(s, "%" SLEN_P "i%n", ret, &n)<1 || s[n]!='\0';
- }
-
- /** @param b: assume null-terminated @return true on error */
-@@ -700,7 +693,7 @@ int main(int argc, char**argv) {
- getotag("Abbr");
- getkey("acount"); acount=getuintval();
- getkey("xcount"); xcount=getuintval();
-- sprintf(tmp,"%"SLEN_P"u dict%%</I>", acount+xcount);
-+ sprintf(tmp,"%" SLEN_P "u dict%%</I>", acount+xcount);
- setifmt(tmp,0); copy("I"); noifmt();
- gettagbeg();
-