aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-04-27 20:56:38 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-04-27 20:56:38 +0000
commit05d2886d27cb71e18dd917003926e7a165f40fa1 (patch)
treef41470c54496d3f979b6727ed30042270de45c74 /graphics
parentf52d0a56a81ecf2c86d06a719ee9cb91b7d5d005 (diff)
downloadports-05d2886d27cb71e18dd917003926e7a165f40fa1.tar.gz
ports-05d2886d27cb71e18dd917003926e7a165f40fa1.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile9
-rw-r--r--graphics/gstreamer-plugins-gdkpixbuf/Makefile9
-rw-r--r--graphics/gstreamer-plugins-libvisual/Makefile8
-rw-r--r--graphics/gstreamer1-plugins-aalib/Makefile13
-rw-r--r--graphics/gstreamer1-plugins-cairo/Makefile13
-rw-r--r--graphics/gstreamer1-plugins-gdkpixbuf/Makefile14
-rw-r--r--graphics/gstreamer1-plugins-jpeg/Makefile13
-rw-r--r--graphics/gstreamer1-plugins-libcaca/Makefile13
-rw-r--r--graphics/gstreamer1-plugins-libvisual/Makefile13
-rw-r--r--graphics/gstreamer1-plugins-opencv/Makefile13
-rw-r--r--graphics/gstreamer1-plugins-png/Makefile14
-rw-r--r--graphics/gstreamer1-plugins-zbar/Makefile13
12 files changed, 133 insertions, 12 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 536809995446..60bcc4643aa0 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -336,6 +336,15 @@
SUBDIR += gstreamer-plugins-libpng
SUBDIR += gstreamer-plugins-libvisual
SUBDIR += gstreamer-plugins-opencv
+ SUBDIR += gstreamer1-plugins-aalib
+ SUBDIR += gstreamer1-plugins-cairo
+ SUBDIR += gstreamer1-plugins-gdkpixbuf
+ SUBDIR += gstreamer1-plugins-jpeg
+ SUBDIR += gstreamer1-plugins-libcaca
+ SUBDIR += gstreamer1-plugins-libvisual
+ SUBDIR += gstreamer1-plugins-opencv
+ SUBDIR += gstreamer1-plugins-png
+ SUBDIR += gstreamer1-plugins-zbar
SUBDIR += gthumb
SUBDIR += gtimelapse
SUBDIR += gtk-update-icon-cache
diff --git a/graphics/gstreamer-plugins-gdkpixbuf/Makefile b/graphics/gstreamer-plugins-gdkpixbuf/Makefile
index f124f1982f4d..282970bcfd39 100644
--- a/graphics/gstreamer-plugins-gdkpixbuf/Makefile
+++ b/graphics/gstreamer-plugins-gdkpixbuf/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: gstreamer-plugins-gdkpixbuf
-# Date created: 3 Oct 2004
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/graphics/gstreamer-plugins-gdkpixbuf/Makefile,v 1.5 2008/03/19 14:05:34 ahze Exp $
-#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics
+PKGNAMESUFFIX= -plugins-gdkpixbuf
COMMENT= Gstreamer image decoder plugin
diff --git a/graphics/gstreamer-plugins-libvisual/Makefile b/graphics/gstreamer-plugins-libvisual/Makefile
index dc416c7007b2..7137b84847a0 100644
--- a/graphics/gstreamer-plugins-libvisual/Makefile
+++ b/graphics/gstreamer-plugins-libvisual/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: gstreamer-plugins-libvisual
-# Date created: 4 Dec 2004
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/graphics/gstreamer-plugins-libvisual/Makefile,v 1.6 2008/03/21 04:01:32 ahze Exp $
-#
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics
COMMENT= Gstreamer libvisual plugin
diff --git a/graphics/gstreamer1-plugins-aalib/Makefile b/graphics/gstreamer1-plugins-aalib/Makefile
new file mode 100644
index 000000000000..e997dd6bbbd2
--- /dev/null
+++ b/graphics/gstreamer1-plugins-aalib/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+
+COMMENT= Gstreamer ASCII art plugin
+
+GST_PLUGIN= aalib
+DIST= good
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-cairo/Makefile b/graphics/gstreamer1-plugins-cairo/Makefile
new file mode 100644
index 000000000000..9fd5a125d029
--- /dev/null
+++ b/graphics/gstreamer1-plugins-cairo/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+
+COMMENT= Gstreamer vector graphics plugin
+
+GST_PLUGIN= cairo
+DIST= good
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-gdkpixbuf/Makefile b/graphics/gstreamer1-plugins-gdkpixbuf/Makefile
new file mode 100644
index 000000000000..db433bc32bc8
--- /dev/null
+++ b/graphics/gstreamer1-plugins-gdkpixbuf/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+PKGNAMESUFFIX= 1-plugins-gdkpixbuf
+
+COMMENT= Gstreamer image decoder plugin
+
+GST_PLUGIN= gdk_pixbuf
+DIST= good
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-jpeg/Makefile b/graphics/gstreamer1-plugins-jpeg/Makefile
new file mode 100644
index 000000000000..96a1fc8b912e
--- /dev/null
+++ b/graphics/gstreamer1-plugins-jpeg/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+
+COMMENT= Gstreamer jpeg encoder/decoder plugin
+
+GST_PLUGIN= jpeg
+DIST= good
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-libcaca/Makefile b/graphics/gstreamer1-plugins-libcaca/Makefile
new file mode 100644
index 000000000000..779a0e869f5d
--- /dev/null
+++ b/graphics/gstreamer1-plugins-libcaca/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+
+COMMENT= Gstreamer color ASCII art plugin
+
+GST_PLUGIN= libcaca
+DIST= good
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-libvisual/Makefile b/graphics/gstreamer1-plugins-libvisual/Makefile
new file mode 100644
index 000000000000..27fce809821c
--- /dev/null
+++ b/graphics/gstreamer1-plugins-libvisual/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+
+COMMENT= Gstreamer libvisual plugin
+
+GST_PLUGIN= libvisual
+DIST= base
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-opencv/Makefile b/graphics/gstreamer1-plugins-opencv/Makefile
new file mode 100644
index 000000000000..6887f7bfc3d0
--- /dev/null
+++ b/graphics/gstreamer1-plugins-opencv/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+
+COMMENT= Gstreamer opencv real time computer vision plugin
+
+GST_PLUGIN= opencv
+DIST= bad
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-png/Makefile b/graphics/gstreamer1-plugins-png/Makefile
new file mode 100644
index 000000000000..668a1f8aabb8
--- /dev/null
+++ b/graphics/gstreamer1-plugins-png/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+PKGNAMESUFFIX= 1-plugins-png
+
+COMMENT= Gstreamer png plugin
+
+GST_PLUGIN= libpng
+DIST= good
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-zbar/Makefile b/graphics/gstreamer1-plugins-zbar/Makefile
new file mode 100644
index 000000000000..59da68f189f5
--- /dev/null
+++ b/graphics/gstreamer1-plugins-zbar/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+
+COMMENT= Gstreamer ZBar barcode detector plugin
+
+GST_PLUGIN= zbar
+DIST= bad
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"