aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2007-08-04 11:41:30 +0000
commit42542fb07642b8336e808272918f3ae46aa67e0b (patch)
tree98ff235c33c6493aa26457284f122652c38935f7 /graphics
parent4c9cd257fd4e6eca46807a43e128d298429ee3cd (diff)
downloadports-42542fb07642b8336e808272918f3ae46aa67e0b.tar.gz
ports-42542fb07642b8336e808272918f3ae46aa67e0b.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile2
-rw-r--r--graphics/jave6/Makefile2
-rw-r--r--graphics/p5-PGPLOT/Makefile2
-rw-r--r--graphics/pgperl/Makefile2
-rw-r--r--graphics/py-imaging/Makefile4
-rw-r--r--graphics/springgraph/Makefile2
-rw-r--r--graphics/tcm/Makefile2
-rw-r--r--graphics/xfig/files/patch-Imakefile2
8 files changed, 9 insertions, 9 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 0104d95edb81..060223c40ef6 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -78,7 +78,7 @@ IGNORE= requires newer version of ghostscript
CONFIGURE_ARGS+= --with-perl=${PERL5}
PLIST_SUB+= WITH_PERL=''
MAN3= Image::Magick.3
-MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.else
CONFIGURE_ARGS+= --without-perl
PLIST_SUB+= WITH_PERL='@comment '
diff --git a/graphics/jave6/Makefile b/graphics/jave6/Makefile
index 06c12922a2e0..2f3121e4db94 100644
--- a/graphics/jave6/Makefile
+++ b/graphics/jave6/Makefile
@@ -21,7 +21,7 @@ USE_ZIP= YES
JAVA_VERSION= 1.3+
NO_BUILD= YES
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
-LNKTARGET= ${TARGETDIR}/bin/jave6
+LNKTARGET= ${PREFIX}/bin/jave6
HLPSKRIPT= jave6
PLIST_SUB+=DATADIR=%%JAVASHAREDIR%%/${PORTNAME}
diff --git a/graphics/p5-PGPLOT/Makefile b/graphics/p5-PGPLOT/Makefile
index da2ba2371dac..fcd3a9612114 100644
--- a/graphics/p5-PGPLOT/Makefile
+++ b/graphics/p5-PGPLOT/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= pgplot.5:${PORTSDIR}/graphics/pgplot
BUILD_DEPENDS= ${SITE_PERL}/ExtUtils/F77.pm:${PORTSDIR}/lang/p5-F77
MAN3= PGPLOT.3
-MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
WANT_FORTRAN= yes
USE_PERL5= yes
diff --git a/graphics/pgperl/Makefile b/graphics/pgperl/Makefile
index da2ba2371dac..fcd3a9612114 100644
--- a/graphics/pgperl/Makefile
+++ b/graphics/pgperl/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= pgplot.5:${PORTSDIR}/graphics/pgplot
BUILD_DEPENDS= ${SITE_PERL}/ExtUtils/F77.pm:${PORTSDIR}/lang/p5-F77
MAN3= PGPLOT.3
-MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
WANT_FORTRAN= yes
USE_PERL5= yes
diff --git a/graphics/py-imaging/Makefile b/graphics/py-imaging/Makefile
index 1d5e52d4e6b1..44527a078350 100644
--- a/graphics/py-imaging/Makefile
+++ b/graphics/py-imaging/Makefile
@@ -30,8 +30,8 @@ PYDISTUTILS_EGGINFODIR= ${PYTHON_SITELIBDIR}/PIL
PORTDOCS= *
-DOCSDIR= ${TARGETDIR}/share/doc/py-${PORTNAME}
-EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
OPTIONS= TKINTER "Build with tkinter for X support" on
diff --git a/graphics/springgraph/Makefile b/graphics/springgraph/Makefile
index 29e72415f08f..28da15d4fbc7 100644
--- a/graphics/springgraph/Makefile
+++ b/graphics/springgraph/Makefile
@@ -31,6 +31,6 @@ post-patch:
@${PERL} -pi -e "s|/usr/bin/perl|${PERL}|g" ${WRKSRC}/springgraph.pl
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/springgraph.pl ${TARGETDIR}/bin/springgraph
+ ${INSTALL_SCRIPT} ${WRKSRC}/springgraph.pl ${PREFIX}/bin/springgraph
.include <bsd.port.mk>
diff --git a/graphics/tcm/Makefile b/graphics/tcm/Makefile
index 42376a6004db..a96bed015481 100644
--- a/graphics/tcm/Makefile
+++ b/graphics/tcm/Makefile
@@ -29,7 +29,7 @@ USE_MOTIF= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SUB_FILES+= pkg-message
-MANPREFIX= ${TARGETDIR}/tcm
+MANPREFIX= ${PREFIX}/tcm
MAN1= psf.1 tatd.1 tcbd.1 tcm.1 tcmd.1 tcmdv.1 tcmt.1 tcpd.1 tcrd.1 \
tdfd.1 tdpd.1 tefd.1 terd.1 tesd.1 text2ps.1 tfet.1 tfrt.1 \
tgd.1 tgt.1 tgtt.1 tpsd.1 trpg.1 tscd.1 tsnd.1 tssd.1 tstd.1 \
diff --git a/graphics/xfig/files/patch-Imakefile b/graphics/xfig/files/patch-Imakefile
index 8b4cd3539985..ac0d2078f502 100644
--- a/graphics/xfig/files/patch-Imakefile
+++ b/graphics/xfig/files/patch-Imakefile
@@ -5,7 +5,7 @@
XCOMM for it relative to the BINDIR variable.
XCOMM
-BINDIR = /usr/bin
-+BINDIR = $(TARGETDIR)/bin
++BINDIR = $(PREFIX)/bin
XCOMM MKDIRHIER = /bin/sh /usr/bin/X11/mkdirhier -p
-MKDIRHIER = mkdirhier
+MKDIRHIER = ${X11BASE}/bin/mkdirhier