aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-09-26 14:36:23 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-09-26 14:36:23 +0000
commit7b97259096b0df72f16568f5b49a9a33cf1b4958 (patch)
tree6e57fabcf96c9308178f83f5236aab5d8f1b0127 /graphics
parent79947ef8956812db831bc1ed9541b5dcbb27a3ad (diff)
downloadports-7b97259096b0df72f16568f5b49a9a33cf1b4958.tar.gz
ports-7b97259096b0df72f16568f5b49a9a33cf1b4958.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gstreamer1-plugins-gl/Makefile2
-rw-r--r--graphics/gstreamer1-plugins-gl/pkg-plist13
-rw-r--r--graphics/gstreamer1-plugins-opencv/Makefile5
-rw-r--r--graphics/gstreamer1-plugins-png/Makefile2
-rw-r--r--graphics/gstreamer1-plugins-rsvg/Makefile13
6 files changed, 32 insertions, 4 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 7d61b3ea80c1..3ef2cc6c2674 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -318,6 +318,7 @@
SUBDIR += gstreamer1-plugins-opencv
SUBDIR += gstreamer1-plugins-openjpeg
SUBDIR += gstreamer1-plugins-png
+ SUBDIR += gstreamer1-plugins-rsvg
SUBDIR += gstreamer1-plugins-webp
SUBDIR += gstreamer1-plugins-zbar
SUBDIR += gthumb
diff --git a/graphics/gstreamer1-plugins-gl/Makefile b/graphics/gstreamer1-plugins-gl/Makefile
index ffe566b011a6..ea592ca723d1 100644
--- a/graphics/gstreamer1-plugins-gl/Makefile
+++ b/graphics/gstreamer1-plugins-gl/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= graphics
COMMENT= Gstreamer GL graphics plugin
diff --git a/graphics/gstreamer1-plugins-gl/pkg-plist b/graphics/gstreamer1-plugins-gl/pkg-plist
index 9a56ab88fed4..174a9aab2fc5 100644
--- a/graphics/gstreamer1-plugins-gl/pkg-plist
+++ b/graphics/gstreamer1-plugins-gl/pkg-plist
@@ -1,9 +1,12 @@
include/gstreamer-%%VERSION%%/gst/gl/egl/gsteglimagememory.h
+include/gstreamer-%%VERSION%%/gst/gl/egl/gstglcontext_egl.h
include/gstreamer-%%VERSION%%/gst/gl/egl/gstgldisplay_egl.h
include/gstreamer-%%VERSION%%/gst/gl/gl.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/all_functions.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/base.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/blending.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/buffers.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/debug.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/eglimage.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/fbo.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/fixedfunction.h
@@ -12,11 +15,14 @@ include/gstreamer-%%VERSION%%/gst/gl/glprototypes/gstgl_compat.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/gstgl_gles2compat.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/opengl.h
include/gstreamer-%%VERSION%%/gst/gl/glprototypes/shaders.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/sync.h
+include/gstreamer-%%VERSION%%/gst/gl/glprototypes/vao.h
include/gstreamer-%%VERSION%%/gst/gl/gstgl_fwd.h
include/gstreamer-%%VERSION%%/gst/gl/gstglapi.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglbasebuffer.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglbasefilter.h
include/gstreamer-%%VERSION%%/gst/gl/gstglbufferpool.h
include/gstreamer-%%VERSION%%/gst/gl/gstglcolorconvert.h
-include/gstreamer-%%VERSION%%/gst/gl/gstglconfig.h
include/gstreamer-%%VERSION%%/gst/gl/gstglcontext.h
include/gstreamer-%%VERSION%%/gst/gl/gstgldisplay.h
include/gstreamer-%%VERSION%%/gst/gl/gstgldownload.h
@@ -26,12 +32,17 @@ include/gstreamer-%%VERSION%%/gst/gl/gstglframebuffer.h
include/gstreamer-%%VERSION%%/gst/gl/gstglmemory.h
include/gstreamer-%%VERSION%%/gst/gl/gstglshader.h
include/gstreamer-%%VERSION%%/gst/gl/gstglshadervariables.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglsyncmeta.h
include/gstreamer-%%VERSION%%/gst/gl/gstglupload.h
include/gstreamer-%%VERSION%%/gst/gl/gstgluploadmeta.h
include/gstreamer-%%VERSION%%/gst/gl/gstglutils.h
+include/gstreamer-%%VERSION%%/gst/gl/gstglviewconvert.h
include/gstreamer-%%VERSION%%/gst/gl/gstglwindow.h
include/gstreamer-%%VERSION%%/gst/gl/x11/gstgldisplay_x11.h
+lib/girepository-%%VERSION%%/GstGL-%%VERSION%%.typelib
+lib/gstreamer-%%VERSION%%/include/gst/gl/gstglconfig.h
lib/gstreamer-%%VERSION%%/libgstopengl.so
lib/libgstgl-%%VERSION%%.so
lib/libgstgl-%%VERSION%%.so.0
lib/libgstgl-%%VERSION%%.so.%%SOVERSION%%
+share/gir-%%VERSION%%/GstGL-%%VERSION%%.gir
diff --git a/graphics/gstreamer1-plugins-opencv/Makefile b/graphics/gstreamer1-plugins-opencv/Makefile
index 9cb4c45a27fd..9df917c33a11 100644
--- a/graphics/gstreamer1-plugins-opencv/Makefile
+++ b/graphics/gstreamer1-plugins-opencv/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= graphics
COMMENT= Gstreamer opencv real time computer vision plugin
@@ -10,4 +10,7 @@ DIST= bad
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+# Clang has issues with Overloaded stuff inside OpenCV
+CXXFLAGS+= -Wno-overloaded-virtual
+
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-png/Makefile b/graphics/gstreamer1-plugins-png/Makefile
index d7d8e262523a..668a1f8aabb8 100644
--- a/graphics/gstreamer1-plugins-png/Makefile
+++ b/graphics/gstreamer1-plugins-png/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= graphics
PKGNAMESUFFIX= 1-plugins-png
diff --git a/graphics/gstreamer1-plugins-rsvg/Makefile b/graphics/gstreamer1-plugins-rsvg/Makefile
new file mode 100644
index 000000000000..047acfbd603f
--- /dev/null
+++ b/graphics/gstreamer1-plugins-rsvg/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= graphics
+
+COMMENT= GStreamer SVG plugin
+
+GST_PLUGIN= rsvg
+DIST= bad
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"