aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-10-10 17:35:53 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-10-10 17:35:53 +0000
commit86c33d74b29c303dfca4062931624f518ea9c9ba (patch)
tree93c2f0dfb47e6c262fc6ff53d84e9f2fee1f3db3 /graphics
parentdd8eb182e2d950896e5bed02904e4436f115854b (diff)
downloadports-86c33d74b29c303dfca4062931624f518ea9c9ba.tar.gz
ports-86c33d74b29c303dfca4062931624f518ea9c9ba.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ogre312/Makefile8
-rw-r--r--graphics/ogre3d/Makefile8
-rw-r--r--graphics/ogre3d12/Makefile8
3 files changed, 18 insertions, 6 deletions
diff --git a/graphics/ogre312/Makefile b/graphics/ogre312/Makefile
index 218c5bc23778..ddaed421207f 100644
--- a/graphics/ogre312/Makefile
+++ b/graphics/ogre312/Makefile
@@ -31,7 +31,6 @@ USE_X_PREFIX= YES
USE_GNOME= gnomehack
USE_SDL= sdl
USE_GMAKE= YES
-NOT_FOR_ARCHS= alpha
post-patch:
@${REINPLACE_CMD} -e '\
@@ -48,11 +47,13 @@ post-patch:
${WRKSRC}/Tools/*/src/Makefile.in
@${REINPLACE_CMD} -e '\
s|\(-L$$(top_builddir)/OgreMain/src\)\([$$ ]*\)|\1/.libs\2|' \
+ ${WRKSRC}/PlatformManagers/SDL/src/Makefile.in \
${WRKSRC}/PlugIns/BSPSceneManager/src/Makefile.in \
${WRKSRC}/PlugIns/CgProgramManager/src/Makefile.in \
${WRKSRC}/PlugIns/EXRCodec/src/Makefile.in \
${WRKSRC}/PlugIns/OctreeSceneManager/src/Makefile.in \
- ${WRKSRC}/PlugIns/ParticleFX/src/Makefile.in
+ ${WRKSRC}/PlugIns/ParticleFX/src/Makefile.in \
+ ${WRKSRC}/RenderSystems/GL/src/Makefile.in
@${REINPLACE_CMD} -e 's|-L$$(top_builddir)/Samples/Common/CEGUIRenderer/src|&/.libs|' \
${WRKSRC}/Samples/Gui/src/Makefile.in
@${REINPLACE_CMD} -e 's|<CEGUI/|<|g' \
@@ -65,6 +66,9 @@ post-patch:
${WRKSRC}/Samples/Common/CEGUIRenderer/src/OgreCEGUITexture.cpp
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Samples/Terrain/src/Makefile.in
+ @${REINPLACE_CMD} -e '\
+ s,defined(__x86_64__),& || defined(__powerpc__) || defined(__ia64__) || defined(__sparc64__) || defined(__alpha__) || defined(__amd64__),' \
+ ${WRKSRC}/OgreMain/include/OgrePlatform.h
post-install:
.if !defined(NOPORTDOCS)
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index 218c5bc23778..ddaed421207f 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -31,7 +31,6 @@ USE_X_PREFIX= YES
USE_GNOME= gnomehack
USE_SDL= sdl
USE_GMAKE= YES
-NOT_FOR_ARCHS= alpha
post-patch:
@${REINPLACE_CMD} -e '\
@@ -48,11 +47,13 @@ post-patch:
${WRKSRC}/Tools/*/src/Makefile.in
@${REINPLACE_CMD} -e '\
s|\(-L$$(top_builddir)/OgreMain/src\)\([$$ ]*\)|\1/.libs\2|' \
+ ${WRKSRC}/PlatformManagers/SDL/src/Makefile.in \
${WRKSRC}/PlugIns/BSPSceneManager/src/Makefile.in \
${WRKSRC}/PlugIns/CgProgramManager/src/Makefile.in \
${WRKSRC}/PlugIns/EXRCodec/src/Makefile.in \
${WRKSRC}/PlugIns/OctreeSceneManager/src/Makefile.in \
- ${WRKSRC}/PlugIns/ParticleFX/src/Makefile.in
+ ${WRKSRC}/PlugIns/ParticleFX/src/Makefile.in \
+ ${WRKSRC}/RenderSystems/GL/src/Makefile.in
@${REINPLACE_CMD} -e 's|-L$$(top_builddir)/Samples/Common/CEGUIRenderer/src|&/.libs|' \
${WRKSRC}/Samples/Gui/src/Makefile.in
@${REINPLACE_CMD} -e 's|<CEGUI/|<|g' \
@@ -65,6 +66,9 @@ post-patch:
${WRKSRC}/Samples/Common/CEGUIRenderer/src/OgreCEGUITexture.cpp
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Samples/Terrain/src/Makefile.in
+ @${REINPLACE_CMD} -e '\
+ s,defined(__x86_64__),& || defined(__powerpc__) || defined(__ia64__) || defined(__sparc64__) || defined(__alpha__) || defined(__amd64__),' \
+ ${WRKSRC}/OgreMain/include/OgrePlatform.h
post-install:
.if !defined(NOPORTDOCS)
diff --git a/graphics/ogre3d12/Makefile b/graphics/ogre3d12/Makefile
index 218c5bc23778..ddaed421207f 100644
--- a/graphics/ogre3d12/Makefile
+++ b/graphics/ogre3d12/Makefile
@@ -31,7 +31,6 @@ USE_X_PREFIX= YES
USE_GNOME= gnomehack
USE_SDL= sdl
USE_GMAKE= YES
-NOT_FOR_ARCHS= alpha
post-patch:
@${REINPLACE_CMD} -e '\
@@ -48,11 +47,13 @@ post-patch:
${WRKSRC}/Tools/*/src/Makefile.in
@${REINPLACE_CMD} -e '\
s|\(-L$$(top_builddir)/OgreMain/src\)\([$$ ]*\)|\1/.libs\2|' \
+ ${WRKSRC}/PlatformManagers/SDL/src/Makefile.in \
${WRKSRC}/PlugIns/BSPSceneManager/src/Makefile.in \
${WRKSRC}/PlugIns/CgProgramManager/src/Makefile.in \
${WRKSRC}/PlugIns/EXRCodec/src/Makefile.in \
${WRKSRC}/PlugIns/OctreeSceneManager/src/Makefile.in \
- ${WRKSRC}/PlugIns/ParticleFX/src/Makefile.in
+ ${WRKSRC}/PlugIns/ParticleFX/src/Makefile.in \
+ ${WRKSRC}/RenderSystems/GL/src/Makefile.in
@${REINPLACE_CMD} -e 's|-L$$(top_builddir)/Samples/Common/CEGUIRenderer/src|&/.libs|' \
${WRKSRC}/Samples/Gui/src/Makefile.in
@${REINPLACE_CMD} -e 's|<CEGUI/|<|g' \
@@ -65,6 +66,9 @@ post-patch:
${WRKSRC}/Samples/Common/CEGUIRenderer/src/OgreCEGUITexture.cpp
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Samples/Terrain/src/Makefile.in
+ @${REINPLACE_CMD} -e '\
+ s,defined(__x86_64__),& || defined(__powerpc__) || defined(__ia64__) || defined(__sparc64__) || defined(__alpha__) || defined(__amd64__),' \
+ ${WRKSRC}/OgreMain/include/OgrePlatform.h
post-install:
.if !defined(NOPORTDOCS)