aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
commit9346b215f04cc84bbb7125ff2fcf03978f859a21 (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /graphics
parent49ac3accb4fc378c681317849f4ae94655a61423 (diff)
downloadports-9346b215f04cc84bbb7125ff2fcf03978f859a21.tar.gz
ports-9346b215f04cc84bbb7125ff2fcf03978f859a21.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile3
-rw-r--r--graphics/agg/Makefile2
-rw-r--r--graphics/djview4/Makefile2
-rw-r--r--graphics/fv/Makefile2
-rw-r--r--graphics/gexiv2/Makefile4
-rw-r--r--graphics/giblib/Makefile3
-rw-r--r--graphics/grafx2/Makefile2
-rw-r--r--graphics/gsnapshot/Makefile3
-rw-r--r--graphics/libvisual/Makefile3
-rw-r--r--graphics/pngwriter/Makefile3
-rw-r--r--graphics/pstoedit/Makefile2
-rw-r--r--graphics/rawtherapee/Makefile2
-rw-r--r--graphics/sswf/Makefile2
-rw-r--r--graphics/swftools/Makefile2
-rw-r--r--graphics/tif22pnm/Makefile3
15 files changed, 18 insertions, 20 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index c1a30134385e..ab997a3bfcb1 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -16,10 +16,9 @@ MASTER_SITES= ftp://ftp.imagemagick.org/pub/ImageMagick/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Image processing tools
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
USE_XZ= yes
USE_PERL5= yes
+USE_PKGCONFIF= yes
USE_GNOME= gnomehack
USE_AUTOTOOLS= libltdl
# For some reason, using our libtool breaks the build into pieces:
diff --git a/graphics/agg/Makefile b/graphics/agg/Makefile
index f5c529d230cf..2b58e515962a 100644
--- a/graphics/agg/Makefile
+++ b/graphics/agg/Makefile
@@ -17,13 +17,13 @@ COMMENT= A High Quality Rendering Engine for C++
LICENSE= GPLv2
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_XORG= x11
USE_GNOME= gnomehack
USE_SDL= sdl
USE_GMAKE= yes
+USE_PKGCONFIG= yes
USE_AUTOTOOLS= aclocal autoheader autoconf libtoolize automake
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --foreign --add-missing --ignore-deps
diff --git a/graphics/djview4/Makefile b/graphics/djview4/Makefile
index cbbdb8931fe9..c9c90958c517 100644
--- a/graphics/djview4/Makefile
+++ b/graphics/djview4/Makefile
@@ -16,11 +16,11 @@ COMMENT= Standalone Djvu viewer and plugin based on Qt4 toolkit
LICENSE= GPLv2
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= djvulibre:${PORTSDIR}/graphics/djvulibre
GNU_CONFIGURE= yes
USE_QT4= gui network rcc_build uic_build moc_build qmake_build
+USE_PKGCONFIG= yes
QT_NONSTANDARD= yes
CONFIGURE_ARGS= --x-includes="${LOCALBASE}/include" \
--x-libraries="${LOCALBASE}/lib"
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
index 8de82e1cb7e5..ce5835e2a0b6 100644
--- a/graphics/fv/Makefile
+++ b/graphics/fv/Makefile
@@ -17,12 +17,12 @@ COMMENT= A viewer of hdr/pfm images
LICENSE= GPLv2
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_ZIP= yes
USE_GL= glut
USE_GMAKE= yes
+USE_PKGCONFIG= yes
ALL_TARGET= ${PORTNAME}
MAKE_JOBS_SAFE= yes
diff --git a/graphics/gexiv2/Makefile b/graphics/gexiv2/Makefile
index cd1cf78b0782..66ba62cd86ab 100644
--- a/graphics/gexiv2/Makefile
+++ b/graphics/gexiv2/Makefile
@@ -16,14 +16,14 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= GObject-based wrapper around the Exiv2 library
BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool \
- gm4:${PORTSDIR}/devel/m4 \
- pkg-config:${PORTSDIR}/devel/pkg-config
+ gm4:${PORTSDIR}/devel/m4
LIB_DEPENDS= exiv2.10:${PORTSDIR}/graphics/exiv2
USE_BZIP2= yes
USE_GNOME= glib20
USE_GMAKE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
post-patch:
@${REINPLACE_CMD} -E \
diff --git a/graphics/giblib/Makefile b/graphics/giblib/Makefile
index 2a545fe24d8f..b9a1ae2f64c8 100644
--- a/graphics/giblib/Makefile
+++ b/graphics/giblib/Makefile
@@ -14,13 +14,12 @@ MASTER_SITES= http://linuxbrit.co.uk/downloads/
MAINTAINER= ports@FreeBSD.org
COMMENT= A utility library that includes a wrapper for imlib2
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
USE_AUTOTOOLS= libtool
USE_GNOME= gnomehack
USE_EFL= imlib2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|: install-docsDATA|:|g' ${WRKSRC}/Makefile.in
diff --git a/graphics/grafx2/Makefile b/graphics/grafx2/Makefile
index 366c281961cd..175da9254066 100644
--- a/graphics/grafx2/Makefile
+++ b/graphics/grafx2/Makefile
@@ -38,7 +38,7 @@ USE_SDL+= ttf
.endif
.if defined(WITH_LUA)
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
+USE_PKGCONFIG= yes
USE_LUA= 5.1
.else
MAKE_ARGS+= NOLUA=1
diff --git a/graphics/gsnapshot/Makefile b/graphics/gsnapshot/Makefile
index 61ee84f08bf1..401d3eddb6d9 100644
--- a/graphics/gsnapshot/Makefile
+++ b/graphics/gsnapshot/Makefile
@@ -14,11 +14,10 @@ MASTER_SITES= SF/gould/${PORTNAME}/release%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A gtk+ based screen capture
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
USE_AUTOTOOLS= aclocal autoheader automake autoconf libtool
USE_GNOME= gtk20 libwnck libxml2
USE_XORG= x11 xmu
+USE_PKGCONFIG= yes
CFLAGS+= -fPIC -I${LOCALBASE}/include/libxml2
diff --git a/graphics/libvisual/Makefile b/graphics/libvisual/Makefile
index e665734bf6b5..2f860e1ef043 100644
--- a/graphics/libvisual/Makefile
+++ b/graphics/libvisual/Makefile
@@ -17,11 +17,10 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Abstraction library that sits between apps and visual plugin
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
USE_GNOME= gnomehack
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
diff --git a/graphics/pngwriter/Makefile b/graphics/pngwriter/Makefile
index 6443e203daae..ae630d2e4344 100644
--- a/graphics/pngwriter/Makefile
+++ b/graphics/pngwriter/Makefile
@@ -15,10 +15,11 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ library for creating PNG images
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2
+USE_PKGCONFIG= yes
+
BUILD_WRKSRC= ${WRKDIR}/${DISTNAME}/src
CXXFLAGS+= `pkg-config --cflags freetype2 libpng15` -I${LOCALBASE}/include
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index 292028a4e61a..add2c9f20d82 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -16,7 +16,6 @@ COMMENT= Convert PostScript to other vector graphic formats
LICENSE= GPLv2
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
OPTIONS_DEFINE= MAGICK EMF MING PLOTUTILS DOCS EXAMPLES
@@ -26,6 +25,7 @@ MING_DESC= Enable swf interface
PLOTUTILS_DESC= Enable libplot interface
USE_GNOME= gnomehack
+USE_PKGCONFIG= yes
USE_GHOSTSCRIPT= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 2ee8ee37a67d..f8f79d3b164b 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -16,7 +16,6 @@ COMMENT= A powerful RAW image processing application
LICENSE= GPLv3
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
iptcdata.3:${PORTSDIR}/graphics/libiptcdata \
jpeg.11:${PORTSDIR}/graphics/jpeg \
@@ -30,6 +29,7 @@ MAKE_JOBS_SAFE= yes
USE_XZ= yes
USE_GNOME= gtk20 glib20
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
CXXFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
diff --git a/graphics/sswf/Makefile b/graphics/sswf/Makefile
index 1b8933fd9cd7..acd1337ca6a6 100644
--- a/graphics/sswf/Makefile
+++ b/graphics/sswf/Makefile
@@ -15,7 +15,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= A library and script language tool to create Flash movies
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
freetype.9:${PORTSDIR}/print/freetype2
@@ -23,6 +22,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_BISON= build
USE_ICONV= yes
+USE_PKGCONFIG= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
USE_LDCONFIG= yes
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index f61170ddc736..f4dccbc0102d 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -17,7 +17,6 @@ COMMENT= SWF manipulation and generation utilities
LICENSE= GPLv2
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
jpeg.11:${PORTSDIR}/graphics/jpeg \
gif.5:${PORTSDIR}/graphics/giflib \
@@ -29,6 +28,7 @@ OPTIONS_DEFINE= LAME PDF
USE_GL= glut
USE_GMAKE= yes
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_lib_zzip_zzip_file_open=no
diff --git a/graphics/tif22pnm/Makefile b/graphics/tif22pnm/Makefile
index ffdbb8153474..33a4aeb103e1 100644
--- a/graphics/tif22pnm/Makefile
+++ b/graphics/tif22pnm/Makefile
@@ -18,7 +18,8 @@ COMMENT= Converts TIFF- sampled images to PNM image
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
+
+USE_PKGCONFIG= yes
PROJECTHOST= sam2p
LICENSE= GPLv2