aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-18 23:38:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-18 23:38:20 +0000
commitcec9874c225fcd0f0d3b4ebb5032a75a32c88af2 (patch)
tree510232d5cea660eee1ba9e0b6086b40605916566 /graphics
parent86ab39eda5107a81a643eb88759035dbd5a1dea4 (diff)
downloadports-cec9874c225fcd0f0d3b4ebb5032a75a32c88af2.tar.gz
ports-cec9874c225fcd0f0d3b4ebb5032a75a32c88af2.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/glpng/Makefile43
-rw-r--r--graphics/glpng/distinfo3
-rw-r--r--graphics/glpng/pkg-descr5
-rw-r--r--graphics/glpng/pkg-plist4
5 files changed, 56 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 2b35361e645a..3b2278d96a89 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -171,6 +171,7 @@
SUBDIR += glide3
SUBDIR += glitz
SUBDIR += gliv
+ SUBDIR += glpng
SUBDIR += gltk
SUBDIR += gltt
SUBDIR += gmt
diff --git a/graphics/glpng/Makefile b/graphics/glpng/Makefile
new file mode 100644
index 000000000000..8b51122106ab
--- /dev/null
+++ b/graphics/glpng/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: glpng
+# Date created: 06 Mar 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glpng
+PORTVERSION= 1.45
+CATEGORIES= graphics
+MASTER_SITES= http://www.wyatt100.freeserve.co.uk/
+DISTNAME= glpng
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Library to easily load PNG files as an OpenGL textures
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_GL= yes
+USE_ZIP= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+
+AR?= /usr/bin/ar
+
+WRKSRC= ${WRKDIR}/src
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|png/|libpng/|' ${WRKSRC}/glpng.c
+
+do-build:
+ ${CC} ${CFLAGS} -fPIC -I${X11BASE}/include -I${LOCALBASE}/include -I${WRKDIR}/include -c -o ${WRKSRC}/libglpng.o ${WRKSRC}/glpng.c
+ ${CC} ${CFLAGS} -fPIC -L${X11BASE}/lib -L${LOCALBASE}/lib -shared -lGL -lpng -lz -lm -o ${WRKSRC}/libglpng.so.1 ${WRKSRC}/libglpng.o
+ ${AR} cqs ${WRKSRC}/libglpng.a ${WRKSRC}/libglpng.o
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libglpng.so.1 ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libglpng.a ${PREFIX}/lib
+ ${LN} -sf libglpng.so.1 ${PREFIX}/lib/libglpng.so
+ ${MKDIR} ${PREFIX}/include/GL/
+ ${INSTALL_DATA} ${WRKDIR}/include/GL/glpng.h ${PREFIX}/include/GL/
+
+.include <bsd.port.mk>
diff --git a/graphics/glpng/distinfo b/graphics/glpng/distinfo
new file mode 100644
index 000000000000..f6b1c4265684
--- /dev/null
+++ b/graphics/glpng/distinfo
@@ -0,0 +1,3 @@
+MD5 (glpng.zip) = bed59efb699a51e6de7434580df41395
+SHA256 (glpng.zip) = 5f7c785acb00de6f7bcf53b1c2c94ddc07de3ef1b1f85c5bfc6483e89fa22223
+SIZE (glpng.zip) = 309337
diff --git a/graphics/glpng/pkg-descr b/graphics/glpng/pkg-descr
new file mode 100644
index 000000000000..be8a5322b36c
--- /dev/null
+++ b/graphics/glpng/pkg-descr
@@ -0,0 +1,5 @@
+This is a library for OpenGL to load PNG graphics files as an
+OpenGL texture as easily as possible. It also has a number of
+options for generating the alpha channel and mipmaps.
+
+WWW: http://www.wyatt100.freeserve.co.uk/download.htm
diff --git a/graphics/glpng/pkg-plist b/graphics/glpng/pkg-plist
new file mode 100644
index 000000000000..b9a84d788e6e
--- /dev/null
+++ b/graphics/glpng/pkg-plist
@@ -0,0 +1,4 @@
+include/GL/glpng.h
+lib/libglpng.a
+lib/libglpng.so
+lib/libglpng.so.1