aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2013-05-16 18:35:00 +0000
committerThierry Thomas <thierry@FreeBSD.org>2013-05-16 18:35:00 +0000
commitd15f82fea9d36452ee041792360cad95df4ec184 (patch)
tree5b70657b3c9159aba2bd334db3485cd6008062f5 /graphics
parente87506e0f00205f7371b1b558d08d8777b796f16 (diff)
downloadports-d15f82fea9d36452ee041792360cad95df4ec184.tar.gz
ports-d15f82fea9d36452ee041792360cad95df4ec184.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cimg/Makefile20
-rw-r--r--graphics/cimg/distinfo4
-rw-r--r--graphics/cimg/files/patch-examples::Makefile48
-rw-r--r--graphics/cimg/files/patch-examples_gmic.cpp20
-rw-r--r--graphics/cimg/pkg-descr2
-rw-r--r--graphics/cimg/pkg-plist56
6 files changed, 95 insertions, 55 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 5730ea895018..7c14b4bd6a42 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: CImg
-# Date created: 11 September 2004
-# Whom: thierry@pompo.net
-#
+# Created by: thierry@pompo.net
# $FreeBSD$
-#
PORTNAME= cimg
-PORTVERSION= 1.5.2
-PORTREVISION= 3
+PORTVERSION= 1.5.5
PORTEPOCH= 3
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME} \
@@ -68,11 +63,18 @@ WITHOUT_LAPACK= yes
RUN_DEPENDS+= medcon:${PORTSDIR}/graphics/xmedcon
. endif
. if !defined(WITHOUT_FFMPEG)
-LIB_DEPENDS+= avformat.1:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= avformat1:${PORTSDIR}/multimedia/ffmpeg1
. endif
DOCBASE= README.txt
-PROGS= CImg_demo gmic use_jpeg_buffer
+PROGS= CImg_demo captcha curve_editor2d dtmri_view3d \
+ edge_explorer2d fade_images gaussian_fit1d generate_loop_macros gmic \
+ hough_transform2d image2ascii image_registration2d image_surface3d \
+ jawbreaker mcf_levelsets2d mcf_levelsets3d odykill \
+ pde_TschumperleDeriche2d pde_heatflow2d plotter1d radon_transform2d \
+ scene3d spherical_function3d tetris tron tutorial use_RGBclass \
+ use_chlpca use_draw_gradient use_jpeg_buffer use_nlmeans use_skeleton \
+ wavelet_atrous
.else
NO_BUILD= yes
.endif
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index 6b8d4fa529f4..5a639ec9f8f9 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cimg-1.5.2/CImg-1.5.2.zip) = 4c6939d7d3c57752bb347362eca26eafb497571246d0d4c5f22d49721f8bc63f
-SIZE (cimg-1.5.2/CImg-1.5.2.zip) = 12824193
+SHA256 (cimg-1.5.5/CImg-1.5.5.zip) = bdad2e062fa35611dfe517b3e204dcb7f526a455fb05ca543144ea6bbfd851a7
+SIZE (cimg-1.5.5/CImg-1.5.5.zip) = 12947668
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index d38bd8abea3d..1d53b74a65f1 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,17 +1,17 @@
---- examples/Makefile.orig 2012-10-15 17:30:59.000000000 +0200
-+++ examples/Makefile 2012-11-04 22:25:42.000000000 +0100
-@@ -85,8 +85,8 @@
+--- examples/Makefile.orig 2013-05-15 22:14:38.000000000 +0200
++++ examples/Makefile 2013-05-16 19:28:54.000000000 +0200
+@@ -86,8 +86,8 @@
# Set correct variables and paths
#---------------------------------
- CIMG_VERSION = 1.5.2
+ CIMG_VERSION = 1.5.5
-X11PATH = /usr/X11R6
-CC = g++
-+#X11PATH = /usr/X11R6
++#X11PATH = $(X11PATH)
+CC = $(CXX)
EXEPFX =
CCVER = $(CC)
ifeq ($(CC),g++)
-@@ -126,7 +126,7 @@
+@@ -127,7 +127,7 @@
ifeq ($(CC),icc)
CIMG_OPT_CFLAGS = -O3 -ipo -no-prec-div
else
@@ -20,7 +20,7 @@
endif
# Flags to enable OpenMP support.
-@@ -137,7 +137,7 @@
+@@ -138,7 +138,7 @@
endif
# Flags to enable OpenCV support.
@@ -29,7 +29,7 @@
CIMG_OPENCV_LDFLAGS = -lcv -lhighgui
# Flags used to disable display capablities of CImg
-@@ -147,7 +147,7 @@
+@@ -148,7 +148,7 @@
# (X11 is used by CImg to handle display windows)
# !!! For 64bits systems : replace -L$(X11PATH)/lib by -L$(X11PATH)/lib64 !!!
CIMG_X11_CFLAGS = -I$(X11PATH)/include
@@ -38,7 +38,7 @@
# Flags to enable fast image display, using the XSHM library (when using X11).
# !!! Seems to randomly crash when used on MacOSX and 64bits systems, so use it only when necessary !!!
-@@ -186,12 +186,12 @@
+@@ -187,13 +187,13 @@
# Flags to enable native support for EXR image files, using the OpenEXR library.
# ( http://www.openexr.com/ )
@@ -49,11 +49,13 @@
# Flags to enable native support for various video files, using the FFMPEG library.
# ( http://www.ffmpeg.org/ )
-CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -D__STDC_CONSTANT_MACROS -I/usr/include/libavcodec -I/usr/include/libavformat -I/usr/include/libswscale -I/usr/include/ffmpeg
-+CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -D__STDC_CONSTANT_MACROS -I/$(LOCALBASE)/include/libavcodec -I/$(LOCALBASE)/include/libavformat -I/$(LOCALBASE)/include/libswscale -I/$(LOCALBASE)/include/ffmpeg
- CIMG_FFMPEG_LDFLAGS = -lavcodec -lavformat -lswscale
+-CIMG_FFMPEG_LDFLAGS = -lavcodec -lavformat -lswscale
++CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -D__STDC_CONSTANT_MACROS -I/$(LOCALBASE)/include/ffmpeg1/libavcodec -I/$(LOCALBASE)/include/ffmpeg1/libavformat -I/$(LOCALBASE)/include/ffmpeg1/libswscale -I/$(LOCALBASE)/include/ffmpeg1
++CIMG_FFMPEG_LDFLAGS = -L$(LOCALBASE)/lib/ffmpeg1 -lavcodec1 -lavformat1 -lswscale1
# Flags to enable native support for compressed .cimgz files, using the Zlib library.
-@@ -201,8 +201,8 @@
+ # ( http://www.zlib.net/ )
+@@ -202,8 +202,8 @@
# Flags to enable native support of most classical image file formats, using the Magick++ library.
# ( http://www.imagemagick.org/Magick++/ )
@@ -64,7 +66,7 @@
# Flags to enable faster Discrete Fourier Transform computation, using the FFTW3 library
# ( http://www.fftw.org/ )
-@@ -215,14 +215,17 @@
+@@ -216,14 +216,17 @@
# Flags to enable the use of LAPACK routines for matrix computation
# ( http://www.netlib.org/lapack/ )
@@ -85,7 +87,7 @@
# Flags to compile on Sun Solaris
CIMG_SOLARIS_LDFLAGS = -R$(X11PATH)/lib -lrt -lnsl -lsocket
-@@ -256,6 +259,9 @@
+@@ -257,6 +260,9 @@
@echo " > mlinux : Linus/BSD target, no display, minimal features, optimizations enabled."
@echo " > Mlinux : Linux/BSD target, X11 display, maximal features, optimizations enabled."
@echo
@@ -95,25 +97,25 @@
@echo " > solaris : Sun Solaris target, X11 display, optimizations disabled."
@echo " > dsolaris : Sun Solaris target, X11 display, debug mode."
@echo " > osolaris : Sun Solaris target, X11 display, optimizations enabled."
-@@ -292,7 +298,7 @@
- $(CC) -o gmic_gimp.o -c gmic.cpp -Dcimg_build -Dgmic_gimp -Dgmic_minimal $(CIMG_OPT_CFLAGS) $(CIMG_FFTW3_CFLAGS) $(CIMG_PNG_CFLAGS)
+@@ -293,7 +299,7 @@
+ $(CC) -o gmic_gimp.o -c gmic.cpp -Dcimg_build -Dgmic_gimp -Dgmic_float_only $(CIMG_OPT_CFLAGS) $(CIMG_FFTW3_CFLAGS) $(CIMG_PNG_CFLAGS)
gmic_gimp: gmic_gimp.o gmic_gimp.cpp
-- $(CC) -o $(EXEPFX)gmic_gimp gmic_gimp.cpp gmic_gimp.o -Dcimg_build `gimptool-2.0 --cflags` `gimptool-2.0 --libs` -lpthread $(CIMG_OPT_FLAGS) $(CIMG_FFTW3_LDFLAGS) $(CIMG_PNG_LDFLAGS) $(CIMG_GIMP_CFLAGS)
-+ $(CC) -o $(EXEPFX)gmic_gimp gmic_gimp.cpp gmic_gimp.o -Dcimg_build `gimptool-2.0 --cflags` `gimptool-2.0 --libs` $(CIMG_OPT_FLAGS) $(CIMG_FFTW3_LDFLAGS) $(CIMG_PNG_LDFLAGS) $(CIMG_GIMP_CFLAGS) $(PTHREAD_LIBS)
+- $(CC) -o $(EXEPFX)gmic_gimp gmic_gimp.cpp gmic_gimp.o -Dcimg_build `gimptool-2.0 --cflags` `gimptool-2.0 --libs` $(CIMG_GIMP_CFLAGS) $(CIMG_OPT_FLAGS) $(CIMG_FFTW3_LDFLAGS) $(CIMG_PNG_LDFLAGS) -lpthread
++ $(CC) -o $(EXEPFX)gmic_gimp gmic_gimp.cpp gmic_gimp.o -Dcimg_build `gimptool-2.0 --cflags` `gimptool-2.0 --libs` $(CIMG_GIMP_CFLAGS) $(CIMG_OPT_FLAGS) $(CIMG_FFTW3_LDFLAGS) $(CIMG_PNG_LDFLAGS) $(PTHREAD_LIBS)
# Specific targets for 'gmic'.
gmic_def: gmic_def.gmic
-@@ -326,7 +332,7 @@
- gmic_uint.o gmic_int.o gmic_float.o gmic_double.o $(CFLAGS) $(LDFLAGS) $(CONF_CFLAGS) $(CONF_LDFLAGS)
+@@ -327,7 +333,7 @@
+ gmic_uint.o gmic_int.o gmic_float.o gmic_double.o $(CFLAGS) $(CONF_CFLAGS) $(CONF_LDFLAGS) $(LDFLAGS)
gmic_minimal:
-- $(CC) -o $(EXEPFX)gmic gmic.cpp -I.. -Dcimg_build -Dgmic_minimal -Dgmic_main -Dcimg_use_fftw3 -Dcimg_use_png -Dcimg_display=1 -I/usr/X11R6/include -g -W -Wall -ansi -pedantic -L/usr/X11R6/lib -lX11 -lpthread -lfftw3 -lpng -lz
-+ $(CC) -o $(EXEPFX)gmic gmic.cpp -I.. -Dcimg_build -Dgmic_minimal -Dgmic_main -Dcimg_use_fftw3 -Dcimg_use_png -Dcimg_display=1 -I$(LOCALBASE)/X11R6/include -g -W -Wall -ansi -pedantic -L$(LOCALBASE)/X11R6/lib -lX11 -lfftw3 -lpng -lz $(PTHREAD_LIBS)
+- $(CC) -o $(EXEPFX)gmic gmic.cpp -Dgmic_main -Dgmic_float_only -Dcimg_build -Dcimg_use_fftw3 -Dcimg_use_png -Dcimg_display=1 -I/usr/X11R6/include -g -W -Wall -ansi -pedantic -L/usr/X11R6/lib -lX11 -lpthread -lfftw3 -lpng -lz
++ $(CC) -o $(EXEPFX)gmic gmic.cpp -Dgmic_main -Dgmic_float_only -Dcimg_build -Dcimg_use_fftw3 -Dcimg_use_png -Dcimg_display=1 -I$(X11PATH)/include -g -W -Wall -ansi -pedantic -L$(X11PATH)/lib -lX11 -lfftw3 -lpng -lz $(PTHREAD_LIBS)
ifeq ($(STRIP_EXE),true)
strip $(EXEPFX)gmic
-@@ -414,6 +420,56 @@
+@@ -415,6 +421,56 @@
"STRIP_EXE=true" \
all $(CIMG_EXTRA_FILES)
diff --git a/graphics/cimg/files/patch-examples_gmic.cpp b/graphics/cimg/files/patch-examples_gmic.cpp
deleted file mode 100644
index de18683e1088..000000000000
--- a/graphics/cimg/files/patch-examples_gmic.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- examples/gmic.cpp.orig 2012-10-15 17:31:08.000000000 +0200
-+++ examples/gmic.cpp 2012-11-05 18:29:29.000000000 +0100
-@@ -10776,7 +10776,7 @@
- *const command = is_help1?is_help1:is_help2?is_help2:is_help3?is_help3:is_help4;
- if (!std::strcmp(is_help,command)) gmic("-v - -help",images,images_names); // Global help.
- else { // Help for a specified command.
-- std::snprintf(command_line,sizeof(command_line),"-v - -help \"%s\",1",command);
-+ snprintf(command_line,sizeof(command_line),"-v - -help \"%s\",1",command);
- gmic(command_line,images,images_names);
- }
- std::exit(0);
-@@ -10796,7 +10796,7 @@
- e.command());
- images.assign(); images_names.assign();
- CImg<unsigned char>(data_gmic_def,1,size_data_gmic_def,1,1).move_to(images);
-- std::snprintf(command_line,sizeof(command_line),"-v - -help \"%s\",0",e.command());
-+ snprintf(command_line,sizeof(command_line),"-v - -help \"%s\",0",e.command());
- gmic(command_line,images,images_names);
- } else { std::fprintf(cimg::output(),"\n\n"); std::fflush(cimg::output()); }
- return -1;
diff --git a/graphics/cimg/pkg-descr b/graphics/cimg/pkg-descr
index ea8ce3d19ac8..0d6ed014ce3a 100644
--- a/graphics/cimg/pkg-descr
+++ b/graphics/cimg/pkg-descr
@@ -21,4 +21,4 @@ CImg stands for Cool Image: it is simple to use and efficient.
lapack library to be able to compute eigenvalues or eigenvectors of big
matrices.
-WWW: http://cimg.sourceforge.net/
+WWW: http://cimg.sourceforge.net/
diff --git a/graphics/cimg/pkg-plist b/graphics/cimg/pkg-plist
index ee48e4d60525..cc07324cc824 100644
--- a/graphics/cimg/pkg-plist
+++ b/graphics/cimg/pkg-plist
@@ -1,6 +1,36 @@
%%PORTDOCS%%bin/CImg_demo
+%%PORTDOCS%%bin/captcha
+%%PORTDOCS%%bin/curve_editor2d
+%%PORTDOCS%%bin/dtmri_view3d
+%%PORTDOCS%%bin/edge_explorer2d
+%%PORTDOCS%%bin/fade_images
+%%PORTDOCS%%bin/gaussian_fit1d
+%%PORTDOCS%%bin/generate_loop_macros
%%PORTDOCS%%bin/gmic
+%%PORTDOCS%%bin/hough_transform2d
+%%PORTDOCS%%bin/image2ascii
+%%PORTDOCS%%bin/image_registration2d
+%%PORTDOCS%%bin/image_surface3d
+%%PORTDOCS%%bin/jawbreaker
+%%PORTDOCS%%bin/mcf_levelsets2d
+%%PORTDOCS%%bin/mcf_levelsets3d
+%%PORTDOCS%%bin/odykill
+%%PORTDOCS%%bin/pde_TschumperleDeriche2d
+%%PORTDOCS%%bin/pde_heatflow2d
+%%PORTDOCS%%bin/plotter1d
+%%PORTDOCS%%bin/radon_transform2d
+%%PORTDOCS%%bin/scene3d
+%%PORTDOCS%%bin/spherical_function3d
+%%PORTDOCS%%bin/tetris
+%%PORTDOCS%%bin/tron
+%%PORTDOCS%%bin/tutorial
+%%PORTDOCS%%bin/use_RGBclass
+%%PORTDOCS%%bin/use_chlpca
+%%PORTDOCS%%bin/use_draw_gradient
%%PORTDOCS%%bin/use_jpeg_buffer
+%%PORTDOCS%%bin/use_nlmeans
+%%PORTDOCS%%bin/use_skeleton
+%%PORTDOCS%%bin/wavelet_atrous
include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/CImg.doxygen
%%PORTDOCS%%%%DOCSDIR%%/CImg_documentation.h
@@ -87,6 +117,11 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/img/postcard38.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard39.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard4.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard40.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard41.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard42.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard43.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard44.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard5.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard6.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard7.jpg
@@ -220,6 +255,7 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/news.shtml
%%PORTDOCS%%%%DOCSDIR%%/reference/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/reference/bc_s.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/bdwn.png
%%PORTDOCS%%%%DOCSDIR%%/reference/classes.html
%%PORTDOCS%%%%DOCSDIR%%/reference/closed.png
%%PORTDOCS%%%%DOCSDIR%%/reference/doxygen.css
@@ -260,6 +296,22 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/form_8.png
%%PORTDOCS%%%%DOCSDIR%%/reference/form_9.png
%%PORTDOCS%%%%DOCSDIR%%/reference/formula.repository
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2blank.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2cl.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2doc.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2folderclosed.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2folderopen.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2lastnode.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2link.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2mlastnode.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2mnode.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2mo.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2node.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2ns.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2plastnode.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2pnode.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2splitbar.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2vertline.png
%%PORTDOCS%%%%DOCSDIR%%/reference/functions.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x62.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x63.html
@@ -334,6 +386,7 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/namespacemembers_vars.html
%%PORTDOCS%%%%DOCSDIR%%/reference/namespaces.html
%%PORTDOCS%%%%DOCSDIR%%/reference/nav_f.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/nav_g.png
%%PORTDOCS%%%%DOCSDIR%%/reference/nav_h.png
%%PORTDOCS%%%%DOCSDIR%%/reference/open.png
%%PORTDOCS%%%%DOCSDIR%%/reference/ref_box3d.jpg
@@ -384,6 +437,8 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgException.html
%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgList-members.html
%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgList.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/sync_off.png
+%%PORTDOCS%%%%DOCSDIR%%/reference/sync_on.png
%%PORTDOCS%%%%DOCSDIR%%/reference/tab_a.png
%%PORTDOCS%%%%DOCSDIR%%/reference/tab_b.png
%%PORTDOCS%%%%DOCSDIR%%/reference/tab_h.png
@@ -432,6 +487,7 @@ include/CImg.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tron.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_RGBclass.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_chlpca.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_cimgIPL.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_cimgmatlab.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_cimgmatlab.m