aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-02-03 10:01:32 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-02-03 10:01:32 +0000
commit96d473108b1e9880766b6a6658b408b528e600ce (patch)
tree78dcaa350f7cdbb14f7e5ce4963c2302a3bdc1e0 /graphics
parente25e7cbbc10279eeac9080e4adb8df0d2438f89f (diff)
downloadports-96d473108b1e9880766b6a6658b408b528e600ce.tar.gz
ports-96d473108b1e9880766b6a6658b408b528e600ce.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/xrml/Makefile103
-rw-r--r--graphics/xrml/distinfo1
-rw-r--r--graphics/xrml/files/patch-Config.site88
-rw-r--r--graphics/xrml/files/patch-FILTERS-cso-importer.C11
-rw-r--r--graphics/xrml/files/patch-PROGS-Makefile11
-rw-r--r--graphics/xrml/pkg-comment1
-rw-r--r--graphics/xrml/pkg-descr11
-rw-r--r--graphics/xrml/pkg-plist384
9 files changed, 611 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 966214b25038..e49fdc373605 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -433,6 +433,7 @@
SUBDIR += xpdf
SUBDIR += xpm
SUBDIR += xpx
+ SUBDIR += xrml
SUBDIR += xsane
SUBDIR += xtheater
SUBDIR += xv
diff --git a/graphics/xrml/Makefile b/graphics/xrml/Makefile
new file mode 100644
index 000000000000..c641e514c22d
--- /dev/null
+++ b/graphics/xrml/Makefile
@@ -0,0 +1,103 @@
+# New ports collection makefile for: xrml
+# Date created: 23 July 2002
+# Whom: Igor Pokrovsky <tiamat@telegraph.spb.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xrml
+PORTVERSION= 0.5.3
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.cs.kuleuven.ac.be/pub/graphics/software/RenderPark/
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= RenderPark
+
+MAINTAINER= tiamat@telegraph.spb.ru
+
+WRKSRC= ${WRKDIR}/XRML
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_MESA= yes
+USE_MOTIF= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+.if !defined(WITH_EXAMPLES)
+PLIST_SUB= WITH_EXAMPLES="@comment "
+.else
+PLIST_SUB= WITH_EXAMPLES=""
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+USE_GCC=2.95
+.endif
+
+.ifndef (WITH_EXAMPLES)
+pre-everything:
+ @${ECHO} "You can define WITH_EXAMPLES=yes to install example VRML files"
+.endif
+
+pre-patch:
+ @${CP} -f ${WRKSRC}/Config.Linux ${WRKSRC}/Config.site
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g ; \
+ s|%%CXX%%|${CXX}|g ; \
+ s|%%CXXFLAGS%%|${CXXFLAGS}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/Config.site
+
+pre-build:
+ ${GMAKE} -C ${WRKSRC}/FILTERS link_includes
+ ${GMAKE} -C ${WRKSRC}/XRML link_includes
+ @${RM} -f ${WRKSRC}/PROGS/vrmldump/deps
+
+do-install:
+ @${MKDIR} ${PREFIX}/include/xrml
+ ${INSTALL_DATA} ${WRKSRC}/include/*.H ${PREFIX}/include/xrml
+ ${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/xrml
+ @${MKDIR} ${PREFIX}/include/xrml/cso
+ ${INSTALL_DATA} ${WRKSRC}/include/cso/* ${PREFIX}/include/xrml/cso
+ @${MKDIR} ${PREFIX}/include/xrml/mgf
+ ${INSTALL_DATA} ${WRKSRC}/include/mgf/* ${PREFIX}/include/xrml/mgf
+ @${MKDIR} ${PREFIX}/include/xrml/nff
+ ${INSTALL_DATA} ${WRKSRC}/include/nff/* ${PREFIX}/include/xrml/nff
+ @${MKDIR} ${PREFIX}/include/xrml/vrml2_utf8
+ ${INSTALL_DATA} ${WRKSRC}/include/vrml2_utf8/* ${PREFIX}/include/xrml/vrml2_utf8
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib/libxrml.so.0.5 ${PREFIX}/lib/libxrml.so.0
+ ${LN} -fs libxrml.so.0 ${PREFIX}/lib/libxrml.so
+ @${STRIP_CMD} ${WRKSRC}/lib/*.a
+ ${INSTALL_DATA} ${WRKSRC}/lib/*.a ${PREFIX}/lib
+
+.ifdef (WITH_EXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TEST/*.wrl ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TEST/*.ppm ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TEST/*.gz ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TEST/*.mgf ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TEST/plotfunc.c ${EXAMPLESDIR}
+.endif
+
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/DOC/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/DOC/nodeapi ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/DOC/nodegen ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/DOC/status ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/PhBRML
+ ${INSTALL_DATA} ${WRKSRC}/DOC/PhBRML/*.html ${DOCSDIR}/PhBRML
+ ${INSTALL_DATA} ${WRKSRC}/DOC/PhBRML/2ndtextured.gif ${DOCSDIR}/PhBRML
+ ${INSTALL_DATA} ${WRKSRC}/DOC/PhBRML/*.wrl ${DOCSDIR}/PhBRML
+ @${MKDIR} ${DOCSDIR}/VRML97
+ ${INSTALL_DATA} ${WRKSRC}/DOC/VRML97/*.html ${DOCSDIR}/VRML97
+ @${MKDIR} ${DOCSDIR}/VRML97/Images
+ ${INSTALL_DATA} ${WRKSRC}/DOC/VRML97/Images/* ${DOCSDIR}/VRML97/Images
+ @${MKDIR} ${DOCSDIR}/VRML97/part1
+ ${INSTALL_DATA} ${WRKSRC}/DOC/VRML97/part1/* ${DOCSDIR}/VRML97/part1
+ ${LN} -s VRML97 ${DOCSDIR}/VRML
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/xrml/distinfo b/graphics/xrml/distinfo
new file mode 100644
index 000000000000..62dcb3556498
--- /dev/null
+++ b/graphics/xrml/distinfo
@@ -0,0 +1 @@
+MD5 (RenderPark/xrml.tar.gz) = 7e700d54a761723a1b1b5877b34cebc4
diff --git a/graphics/xrml/files/patch-Config.site b/graphics/xrml/files/patch-Config.site
new file mode 100644
index 000000000000..9c1cd76a67a7
--- /dev/null
+++ b/graphics/xrml/files/patch-Config.site
@@ -0,0 +1,88 @@
+--- Config.site.orig Fri Jan 31 19:45:18 2003
++++ Config.site Fri Jan 31 19:46:38 2003
+@@ -1,8 +1,8 @@
+-# Configuration data for Linux
++# Configuration data for FreeBSD
+
+ # with GCC:
+-CC = gcc
+-CXX = g++
++CC = %%CC%%
++CXX = %%CXX%%
+ MAKEDEPEND = gcc -M
+ PROFLAGS = # -pg # for profiling
+ DEBUGFLAGS = -g # for debugging
+@@ -10,19 +10,19 @@
+ # If you have a processor of a type prior to a Pentium PRO or
+ # Pentium II, omit the -march=i686 flag or you'll get an invalid operation
+ # exception when you start RenderPark.
+-OPTFLAGS = -O3 -Wall -pedantic -Wno-long-long -mieee-fp -malign-double -march=i686
++OPTFLAGS = %%CXXFLAGS%% #-O3 -Wall -pedantic -Wno-long-long -mieee-fp -malign-double -march=i686
+ CXXFLAGS = # C++ specific flags
+
+ # no ranlib command on Linux. Use 'touch' instead.
+-RANLIB = touch
++RANLIB = ranlib
+
+ # See 0COMPILATIONFLAGS to see what flags you can set if you care.
+ EXTRAFLAGS = -DDEFAULT_GAMMA=2.2 -DNOPOOLS
+
+ ################################################################
+ # uncomment the following definitions in order to make shared libraries
+-#MKLIB = mklib.linux
+-#MKLIBFLAGS = -fPIC
++MKLIB = mklib.freebsd
++MKLIBFLAGS = -fPIC
+ #LIBEXT = so
+
+ ################################################################
+@@ -48,8 +48,8 @@
+
+ # OpenGL include files and library appear to be in /usr/include
+ # and /usr/lib normally on recent Linux systems
+-DRIVERFLAGS = -I/usr/include $(HWFLAGS)
+-DRIVERLIBS = -L/usr/lib -lGLU -lGL
++DRIVERFLAGS = -I${X11BASE}/include $(HWFLAGS)
++DRIVERLIBS = -L${X11BASE}/lib -lGLU -lGL
+
+ # Mesa (free OpenGL-like library: www.mesa3d.org)
+ # On recent systems, 'MesaGL' is installed as 'GL' and 'MesaGLU' as 'GLU' and
+@@ -75,14 +75,14 @@
+ ################################################################
+ # X window system flags and files:
+
+-X11HOME = /usr/X11R6
++X11HOME = ${X11BASE}
+ XINCLUDES = -I$(X11HOME)/include
+ XLIBS = -L$(X11HOME)/lib -lXt -lXmu -lX11 $(CCMALLOCLIB)
+ # CCMALLOCLIB = -lccmalloc -ldl
+
+-# MOTIFHOME = /usr/X11R6
++MOTIFHOME = ${X11BASE}
+ # lesstif:
+-MOTIFHOME = /usr/X11R6/LessTif/Motif1.2
++#MOTIFHOME = /usr/X11R6/LessTif/Motif1.2
+ # MOTIFHOME = /usr/local/Motif
+ MOTIFINCLUDES = -I$(MOTIFHOME)/include
+ # -lXpm library necessary for Motif >=2.0, not for Motif <2.0
+@@ -93,7 +93,7 @@
+ # TIFF support
+ # if you don't want/need TIFF support, uncomment all the following lines
+ #TIFFHOME = /usr/local/graphics
+-TIFFHOME = /usr
++TIFFHOME = ${LOCALBASE}
+
+ # flags: -DNO_TIFF if you have no TIFF library,
+ # -DOLD_TIFF if you have an old TIFF library without the high dynamic
+@@ -111,9 +111,9 @@
+
+ # Some tiff installation require that you also link with the jpeg and
+ # zlib libraries.
+-TIFFLIB = -L$(TIFFHOME)/lib -ltiff -ljpeg -lz
++TIFFLIB = -L$(TIFFHOME)/lib -ltiff
+
+
+ ################################################################
+ # C++/so import filter
+-DLLIB = -ldl
++#DLLIB = -ldl
diff --git a/graphics/xrml/files/patch-FILTERS-cso-importer.C b/graphics/xrml/files/patch-FILTERS-cso-importer.C
new file mode 100644
index 000000000000..c57215c632f6
--- /dev/null
+++ b/graphics/xrml/files/patch-FILTERS-cso-importer.C
@@ -0,0 +1,11 @@
+--- FILTERS/cso/importer.C.orig Wed Mar 14 20:30:21 2001
++++ FILTERS/cso/importer.C Fri Jan 31 20:11:34 2003
+@@ -26,7 +26,7 @@
+ // find the address of the routine called "import"
+ void (*import)(void*, char**) = (void (*)(void*, char**))dlsym(handle, "import");
+ // void (*import)(xrml::world*, char**) = (void (*)(xrml::world*, char**))dlsym(handle, "import__FPQ24xrml5worldPPc");
+- char *error = dlerror();
++ const char *error = dlerror();
+ if (error) {
+ Error(NULL, "%s", error);
+ return false;
diff --git a/graphics/xrml/files/patch-PROGS-Makefile b/graphics/xrml/files/patch-PROGS-Makefile
new file mode 100644
index 000000000000..6e54843052f9
--- /dev/null
+++ b/graphics/xrml/files/patch-PROGS-Makefile
@@ -0,0 +1,11 @@
+--- PROGS/Makefile~ Thu Feb 22 23:55:52 2001
++++ PROGS/Makefile Tue Jul 23 18:37:32 2002
+@@ -15,7 +15,7 @@
+ # the toy subdirectory contains a sample program using the toy
+ # import and export filter.
+
+-SUBDIRS = vrmlint vrmlconv vrmlview
++SUBDIRS = vrmldump vrmlint vrmlconv vrmlview
+
+ #default target: compile
+ all: progs
diff --git a/graphics/xrml/pkg-comment b/graphics/xrml/pkg-comment
new file mode 100644
index 000000000000..a2d9a3b48d31
--- /dev/null
+++ b/graphics/xrml/pkg-comment
@@ -0,0 +1 @@
+Extensible scene graph library based on VRML'97
diff --git a/graphics/xrml/pkg-descr b/graphics/xrml/pkg-descr
new file mode 100644
index 000000000000..8d58b6ad58eb
--- /dev/null
+++ b/graphics/xrml/pkg-descr
@@ -0,0 +1,11 @@
+This package contains a extensible scene graph library based
+on VRML'97. It comes with a variety of import and export filters
+to read/write a scene graph from/in a variety of 3D file format
+and, of course, also a number of applications that make use
+of it: a file format convertor and a VRML viewer. It is used
+in RenderPark to read XRML input files.
+
+WWW: http://www.cs.kuleuven.ac.be/~graphics/XRML/
+
+- Igor Pokrovsky
+tiamat@telegraph.spb.ru
diff --git a/graphics/xrml/pkg-plist b/graphics/xrml/pkg-plist
new file mode 100644
index 000000000000..384216c8d9fd
--- /dev/null
+++ b/graphics/xrml/pkg-plist
@@ -0,0 +1,384 @@
+bin/vrmlconv
+bin/vrmldump
+bin/vrmlint
+bin/vv
+include/xrml/cso/exporter.H
+include/xrml/cso/importer.H
+@dirrm include/xrml/cso
+include/xrml/mgf/cie.h
+include/xrml/mgf/exporter.H
+include/xrml/mgf/renderer.H
+@dirrm include/xrml/mgf
+include/xrml/nff/exporter.H
+include/xrml/nff/renderer.H
+@dirrm include/xrml/nff
+include/xrml/vrml2_utf8/exporter.H
+include/xrml/vrml2_utf8/parser.H
+include/xrml/vrml2_utf8/scanner.H
+include/xrml/vrml2_utf8/tokens.H
+@dirrm include/xrml/vrml2_utf8
+include/xrml/Anchor.H
+include/xrml/Appearance.H
+include/xrml/AppearanceBase.H
+include/xrml/Array.H
+include/xrml/Assoc.H
+include/xrml/AudioClip.H
+include/xrml/Background.H
+include/xrml/Billboard.H
+include/xrml/Bindable.H
+include/xrml/Box.H
+include/xrml/Children.H
+include/xrml/CmpString.H
+include/xrml/Collision.H
+include/xrml/Color.H
+include/xrml/ColorInterpolator.H
+include/xrml/Cone.H
+include/xrml/Coordinate.H
+include/xrml/CoordinateInterpolator.H
+include/xrml/Cylinder.H
+include/xrml/CylinderSensor.H
+include/xrml/DirectionalLight.H
+include/xrml/DragSensor.H
+include/xrml/ElevationGrid.H
+include/xrml/EnvironmentalSensor.H
+include/xrml/EventManager.H
+include/xrml/ExternProto.H
+include/xrml/Extrusion.H
+include/xrml/FlexLexer.h
+include/xrml/Float.H
+include/xrml/Fog.H
+include/xrml/FontStyle.H
+include/xrml/Geometry.H
+include/xrml/Group.H
+include/xrml/Grouping.H
+include/xrml/ImageTexture.H
+include/xrml/IndexedFaceSet.H
+include/xrml/IndexedLineSet.H
+include/xrml/Inline.H
+include/xrml/Interpolator.H
+include/xrml/LOD.H
+include/xrml/LightSource.H
+include/xrml/List.H
+include/xrml/Material.H
+include/xrml/MovieTexture.H
+include/xrml/NavigationInfo.H
+include/xrml/Normal.H
+include/xrml/NormalInterpolator.H
+include/xrml/OrientationInterpolator.H
+include/xrml/PerlinNoise.H
+include/xrml/PhB3DCheckerTexture.H
+include/xrml/PhB3DNoiseTexture.H
+include/xrml/PhB3DSpiralTexture.H
+include/xrml/PhB3DTexture.H
+include/xrml/PhB3DTextureTransform.H
+include/xrml/PhB3DTexturedSurface.H
+include/xrml/PhBAppearance.H
+include/xrml/PhBAshikminReflector.H
+include/xrml/PhBAtmosphere.H
+include/xrml/PhBBackground.H
+include/xrml/PhBBackgroundLight.H
+include/xrml/PhBBackgroundProjection.H
+include/xrml/PhBBilinearInterpolation.H
+include/xrml/PhBBlackBodySpectrum.H
+include/xrml/PhBBoxTextureProjection.H
+include/xrml/PhBBrushMap.H
+include/xrml/PhBBumpMap.H
+include/xrml/PhBConeTextureProjection.H
+include/xrml/PhBCylinderTextureProjection.H
+include/xrml/PhBDiffuseEmitter.H
+include/xrml/PhBDiffuseReflector.H
+include/xrml/PhBDiffuseRefractor.H
+include/xrml/PhBDistortion.H
+include/xrml/PhBEDF.H
+include/xrml/PhBEmitter.H
+include/xrml/PhBFresnelBSDF.H
+include/xrml/PhBHenyeyGreensteinPhaseFunction.H
+include/xrml/PhBHeterogeneousSurface.H
+include/xrml/PhBHomogeneousBackground.H
+include/xrml/PhBHomogeneousMedium.H
+include/xrml/PhBHomogeneousSurface.H
+include/xrml/PhBImageTexture.H
+include/xrml/PhBImageTextureBase.H
+include/xrml/PhBInterpolatedMedium.H
+include/xrml/PhBInterpolatedSpectrum.H
+include/xrml/PhBInterpolatedSurface.H
+include/xrml/PhBIsotropicPhaseFunction.H
+include/xrml/PhBLafortuneReflector.H
+include/xrml/PhBLandscapePhotoBackground.H
+include/xrml/PhBLxySpectrum.H
+include/xrml/PhBMedium.H
+include/xrml/PhBMixedSpectrum.H
+include/xrml/PhBMonitorCalibration.H
+include/xrml/PhBMonochromaticSpectrum.H
+include/xrml/PhBNeumannReflector.H
+include/xrml/PhBNoiseTexture.H
+include/xrml/PhBNormalMap.H
+include/xrml/PhBPerfectSpecularReflector.H
+include/xrml/PhBPerfectSpecularRefractor.H
+include/xrml/PhBPhF.H
+include/xrml/PhBPhaseFunction.H
+include/xrml/PhBPhongEmitter.H
+include/xrml/PhBPhongReflector.H
+include/xrml/PhBPhongRefractor.H
+include/xrml/PhBPixelTexture.H
+include/xrml/PhBProcedural3DTexture.H
+include/xrml/PhBProceduralBackground.H
+include/xrml/PhBProceduralEmitter.H
+include/xrml/PhBProceduralPhaseFunction.H
+include/xrml/PhBProceduralScatterer.H
+include/xrml/PhBProceduralSpectrum.H
+include/xrml/PhBProceduralTexture.H
+include/xrml/PhBProceduralTextureProjection.H
+include/xrml/PhBRGBSpectrum.H
+include/xrml/PhBSDF.H
+include/xrml/PhBSampledIsotropicEmitter.H
+include/xrml/PhBSampledSpectrum.H
+include/xrml/PhBScatterer.H
+include/xrml/PhBSchlickPhaseFunction.H
+include/xrml/PhBSchlickReflector.H
+include/xrml/PhBShadingFrameDistortion.H
+include/xrml/PhBSimpleBSDF.H
+include/xrml/PhBSpectrum.H
+include/xrml/PhBSphereTextureProjection.H
+include/xrml/PhBSurface.H
+include/xrml/PhBSurfaceDistortion.H
+include/xrml/PhBTabulatedSpectrum.H
+include/xrml/PhBTexture.H
+include/xrml/PhBTextureEmitter.H
+include/xrml/PhBTextureFilter.H
+include/xrml/PhBTextureProjection.H
+include/xrml/PhBTexturedBackground.H
+include/xrml/PhBTexturedMedium.H
+include/xrml/PhBTexturedSurface.H
+include/xrml/PhBToggleTexture.H
+include/xrml/PhBVolumeDistortion.H
+include/xrml/PhBWardReflector.H
+include/xrml/PhBXYZSpectrum.H
+include/xrml/PixelTexture.H
+include/xrml/PlaneSensor.H
+include/xrml/PointLight.H
+include/xrml/PointSet.H
+include/xrml/PointingDeviceSensor.H
+include/xrml/PositionInterpolator.H
+include/xrml/Proto.H
+include/xrml/ProximitySensor.H
+include/xrml/ReadImage.H
+include/xrml/ScalarInterpolator.H
+include/xrml/Script.H
+include/xrml/Sensor.H
+include/xrml/Shape.H
+include/xrml/Sound.H
+include/xrml/SoundSource.H
+include/xrml/Sphere.H
+include/xrml/SphereSensor.H
+include/xrml/SpotLight.H
+include/xrml/Stack.H
+include/xrml/StackManager.H
+include/xrml/Switch.H
+include/xrml/Text.H
+include/xrml/Texture.H
+include/xrml/TextureCoordinate.H
+include/xrml/TextureTransform.H
+include/xrml/TimeDependent.H
+include/xrml/TimeSensor.H
+include/xrml/TouchSensor.H
+include/xrml/Transform.H
+include/xrml/Transforming.H
+include/xrml/Viewpoint.H
+include/xrml/VisibilitySensor.H
+include/xrml/WorldInfo.H
+include/xrml/cie.H
+include/xrml/complex.H
+include/xrml/error.H
+include/xrml/exporter.H
+include/xrml/fieldValue.H
+include/xrml/file.H
+include/xrml/granges.H
+include/xrml/importer.H
+include/xrml/matrix.H
+include/xrml/memory.H
+include/xrml/mipmap.H
+include/xrml/nodeCatalog.H
+include/xrml/nodeInterface.H
+include/xrml/renderer.H
+include/xrml/route.H
+include/xrml/smodes.H
+include/xrml/spectrum.H
+include/xrml/texture_projection.H
+include/xrml/transform.H
+include/xrml/utils.H
+include/xrml/vector.H
+include/xrml/version.H
+include/xrml/world.H
+include/xrml/xrml.H
+include/xrml/xrmlP.H
+@dirrm include/xrml
+lib/libxrml.so.0
+@exec ln -fs libxrml.so.0 %D/lib/libxrml.so || true
+@unexec rm -f %D/lib/libxrml.so || true
+lib/libxrml.a
+lib/libxrml2cso.a
+lib/libxrml2mgf.a
+lib/libxrml2nff.a
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/plotfunc.c
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/checker.ppm.gz
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/grid.ppm.gz
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/land.pic.gz
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/plasma.ppm.gz
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/refractiontest.mgf
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/wardtest.mgf
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/Check4x4Color.ppm
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/bump.ppm
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/gradient.ppm
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/normal.ppm
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/thing.ppm
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/white.ppm
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/white16.ppm
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/white4x3.ppm
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/BrushMap.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/Bumpmap.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/ProceduralBumpMap.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/ProceduralNoise.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/ShadingFrameDistord.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/TextureMap.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/ashikminScene.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/ashikminScene2.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/ashikmintest.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/backgroundlight.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/backgroundtest.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/blackbodySpectrum.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/box.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/box2.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/bug.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/colors.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/cone.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/cornellcube.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/cyl.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/extrusion.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/fresneltest.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/heterotest.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/homogeneousbackground.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/imagetexture.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/lafortunetest.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/landscapeEnvironmentmap.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/mixsphere.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/monochromatic.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/neumanntest.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/nondifflight.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/phbtexture.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/refractiontest.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/rev.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/sampledSpectrum.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/schlicktest.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/sincos.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/sine.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/sph.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/tabulatedSpectrum.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/test.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/textureEmitter.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/texturetest.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/wardtest.wrl
+%%WITH_EXAMPLES%%%%EXAMPLESDIR%%/whitehomogeneous.wrl
+%%WITH_EXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/nodeapi
+%%PORTDOCS%%%%DOCSDIR%%/nodegen
+%%PORTDOCS%%%%DOCSDIR%%/status
+%%PORTDOCS%%%%DOCSDIR%%/applications.html
+%%PORTDOCS%%%%DOCSDIR%%/changes.html
+%%PORTDOCS%%%%DOCSDIR%%/design.html
+%%PORTDOCS%%%%DOCSDIR%%/extensions.html
+%%PORTDOCS%%%%DOCSDIR%%/filters.html
+%%PORTDOCS%%%%DOCSDIR%%/howToCreateASceneGraph.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/installation.html
+%%PORTDOCS%%%%DOCSDIR%%/sourcetree.html
+%%PORTDOCS%%%%DOCSDIR%%/template.html
+%%PORTDOCS%%%%DOCSDIR%%/world.html
+%%PORTDOCS%%%%DOCSDIR%%/PhBRML/2ndtextured.gif
+%%PORTDOCS%%%%DOCSDIR%%/PhBRML/PhBexample2.wrl
+%%PORTDOCS%%%%DOCSDIR%%/PhBRML/examples.html
+%%PORTDOCS%%%%DOCSDIR%%/PhBRML/glossary.html
+%%PORTDOCS%%%%DOCSDIR%%/PhBRML/index.html
+%%PORTDOCS%%%%DOCSDIR%%/PhBRML/mixsphere.html
+%%PORTDOCS%%%%DOCSDIR%%/PhBRML/mixsphere.wrl
+%%PORTDOCS%%%%DOCSDIR%%/PhBRML/nodes.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/PhBRML
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/acknowledgements.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/copyright.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/index.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/vrml97.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/Sound.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/whitespace.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/ElevationGrid.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/FontStylespacing.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/spotlight.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/vrmlbar.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/cylinder.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/leaves.jpg
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/cube.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/cone.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/rsmbb.jpg
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/timestamp-order.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/IFStexture2.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/TimeSensor.jpg
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/proto.jpg
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/box.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/Extrusion.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/key.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/pi.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/background.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/ImageTexture.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/sphere.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/vertical.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/Concepts2.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/Sound2.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/instancing.jpg
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/IFStexture.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/timeDep.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/horizontal.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/Concepts1.gif
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/Images/infinity.gif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/VRML97/Images
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/grammar.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.4.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/concepts.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/scope.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/javascript.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.5.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/nodesRef.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/glossary.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/examples.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/foreword.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/chopperbody.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.18.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.6.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/chopperrotor.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/references.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.19.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.7.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.13.1.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/rotor.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.13.2.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.2.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.3.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/conformance.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.12.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/java.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/refractivematerial.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.10.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/fieldsRef.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.11.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/extensions.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.16.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/click.wav
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.17.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.9.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.14.wrl
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/bibliography.html
+%%PORTDOCS%%%%DOCSDIR%%/VRML97/part1/exampleD.15.wrl
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/VRML97/part1
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/VRML97
+%%PORTDOCS%%@exec ln -s VRML97 %D/%%DOCSDIR%%/VRML || true
+%%PORTDOCS%%@unexec rm %D/%%DOCSDIR%%/VRML || true
+%%PORTDOCS%%@dirrm %%DOCSDIR%%