aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-10-19 11:56:49 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-10-19 11:56:49 +0000
commit07eb55de8901fc4680702d5c7cc265103ae2106d (patch)
tree6e2d5740a47768e2a22e0f7e7b35a82c0ec9167c /graphics
parent01b5fe46344c543e403c07c29e5ac33e37fd6c55 (diff)
downloadports-07eb55de8901fc4680702d5c7cc265103ae2106d.tar.gz
ports-07eb55de8901fc4680702d5c7cc265103ae2106d.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/xzgv/Makefile26
-rw-r--r--graphics/xzgv/distinfo1
-rw-r--r--graphics/xzgv/files/patch-aa93
-rw-r--r--graphics/xzgv/pkg-comment1
-rw-r--r--graphics/xzgv/pkg-descr12
-rw-r--r--graphics/xzgv/pkg-plist7
7 files changed, 141 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 79996a7e5581..9343df38240e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -218,6 +218,7 @@
SUBDIR += xv
SUBDIR += xv-m17n
SUBDIR += xwpick
+ SUBDIR += xzgv
SUBDIR += zimg
.include <bsd.port.subdir.mk>
diff --git a/graphics/xzgv/Makefile b/graphics/xzgv/Makefile
new file mode 100644
index 000000000000..a3bf37e428fd
--- /dev/null
+++ b/graphics/xzgv/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: xzgv
+# Date created: 7 Oct 2000
+# Whom: Norio Suzuki <nosuzuki@e-mail.ne.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xzgv
+PORTVERSION= 0.5
+CATEGORIES= graphics
+MASTER_SITES= http://xzgv.browser.org/ \
+ ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/graphics/viewers/X
+
+MAINTAINER= nosuzuki@e-mail.ne.jp
+
+USE_GMAKE= yes
+USE_IMLIB= yes
+
+MAN1= xzgv.1
+
+post-install:
+ strip ${PREFIX}/bin/xzgv
+ install-info ${PREFIX}/info/xzgv ${PREFIX}/info/dir
+
+.include <bsd.port.mk>
diff --git a/graphics/xzgv/distinfo b/graphics/xzgv/distinfo
new file mode 100644
index 000000000000..974e2bfabd64
--- /dev/null
+++ b/graphics/xzgv/distinfo
@@ -0,0 +1 @@
+MD5 (xzgv-0.5.tar.gz) = e357639c95fc0b660f3b47fe93a00dc7
diff --git a/graphics/xzgv/files/patch-aa b/graphics/xzgv/files/patch-aa
new file mode 100644
index 000000000000..bbf50d58a5d6
--- /dev/null
+++ b/graphics/xzgv/files/patch-aa
@@ -0,0 +1,93 @@
+diff -ur xzgv-0.5/Makefile work/xzgv-0.5/Makefile
+--- Makefile Sat May 6 23:49:52 2000
++++ Makefile Sun Oct 8 05:56:44 2000
+@@ -24,9 +24,10 @@
+
+
+
+-all: src man infowarn
++#all: src man infowarn
++all: src man info
+
+-src: xzgv src/install-info
++src: xzgv #src/install-info
+
+ # We try this the whole time, as the dependancies are a bit
+ # complicated to duplicate here.
+diff -ur xzgv-0.5/config.mk work/xzgv-0.5/config.mk
+--- config.mk Fri Aug 4 20:02:12 2000
++++ xzgv-0.5/config.mk Sun Oct 8 05:58:05 2000
+@@ -60,7 +60,7 @@
+ #
+ # If you don't know what to do, leave it as-is.
+ #
+-#INFO_DIR_UPDATE=no
++INFO_DIR_UPDATE=no
+
+
+ # -------------------- Miscellaneous options -----------------------
+diff -ur xzgv-0.5/src/Makefile work/xzgv-0.5/src/Makefile
+--- src/Makefile Sat Mar 11 02:44:29 2000
++++ src/Makefile Sun Oct 8 05:56:44 2000
+@@ -19,7 +19,7 @@
+ # compile when you do `make install'. :-)
+ # (It would also be weird to have it made by the `doc' Makefile, IMHO.)
+
+-all: xzgv install-info
++all: xzgv #install-info
+
+ OBJS= main.o \
+ filedetails.o gotodir.o updatetn.o confirm.o \
+@@ -43,14 +43,14 @@
+ installdirs:
+ /bin/sh ../mkinstalldirs $(BINDIR)
+
+-install: xzgv installdirs
++install: xzgv #installdirs
+ install -m 511 xzgv $(BINDIR)
+
+ uninstall:
+ $(RM) $(BINDIR)/xzgv
+
+ clean:
+- $(RM) *~ *.o xzgv install-info
++ $(RM) *~ *.o xzgv #install-info
+ $(RM) rcfile_opt.h rcfile_var.h rcfile_short.h
+ $(RM) logodata.h logoconv
+
+@@ -63,7 +63,7 @@
+ getopt.o: getopt.c
+ getopt1.o: getopt1.c getopt.h
+ gotodir.o: gotodir.c main.h gotodir.h
+-install-info.o: install-info.c
++#install-info.o: install-info.c
+ logo.o: logo.c logodata.h
+ logoconv.o: logoconv.c
+ main.o: main.c readmrf.h readgif.h readjpegtn.h resizepic.h rcfile.h \
+--- doc/makeman.awk.orig Sun Apr 23 02:51:12 2000
++++ doc/makeman.awk Thu Oct 19 11:36:45 2000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/gawk -f
++#!/usr/bin/awk -f
+ #
+ # makeman - make xzgv man page from texinfo file.
+ # Public domain by Russell Marks.
+--- doc/Makefile.orig Mon Nov 22 17:23:34 1999
++++ doc/Makefile Thu Oct 19 11:36:31 2000
+@@ -27,14 +27,14 @@
+ man: xzgv.1
+ xzgv.1: xzgv.texi makeman.awk
+ @echo 'Making man page from xzgv.texi...'
+- gawk -f makeman.awk <xzgv.texi >xzgv.1
++ awk -f makeman.awk <xzgv.texi >xzgv.1
+
+ installdirs:
+ /bin/sh ../mkinstalldirs $(INFODIR) $(MANDIR)
+
+ # I think this one's getting just a tiny bit confusing :-}
+ ifeq ($(INFO_DIR_UPDATE),no)
+-install: installdirs
++install:
+ else
+ install: ../src/install-info installdirs
+ endif
diff --git a/graphics/xzgv/pkg-comment b/graphics/xzgv/pkg-comment
new file mode 100644
index 000000000000..c206d2abdd5e
--- /dev/null
+++ b/graphics/xzgv/pkg-comment
@@ -0,0 +1 @@
+An image viewer with thumbnail-based file selector for X
diff --git a/graphics/xzgv/pkg-descr b/graphics/xzgv/pkg-descr
new file mode 100644
index 000000000000..d173684367d1
--- /dev/null
+++ b/graphics/xzgv/pkg-descr
@@ -0,0 +1,12 @@
+This is an image file viewer with thumbnail-based file selector. it uses GTK+
+and Imlib libraries and support most image file formats. The thumbnail file is
+compatible with xv and Gimp.
+
+In contrast to other image file viewers for X, xzgv uses only one window and
+can fit a large image to the size of the window without changing the aspect
+ratio.
+
+WWW: http://xzgv.browser.org/
+
+Norio Suzuki
+nosuzuki@e-mail.ne.jp
diff --git a/graphics/xzgv/pkg-plist b/graphics/xzgv/pkg-plist
new file mode 100644
index 000000000000..09cb1f2ca4ca
--- /dev/null
+++ b/graphics/xzgv/pkg-plist
@@ -0,0 +1,7 @@
+bin/xzgv
+@unexec install-info --delete %D/info/xzgv %D/info/dir
+info/xzgv.gz
+info/xzgv-1.gz
+info/xzgv-2.gz
+info/xzgv-3.gz
+@exec install-info %D/info/xzgv %D/info/dir