aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2006-05-07 18:49:33 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2006-05-07 18:49:33 +0000
commitb6dc9f6ee5dab662368578732dd1ecd6fe87eb9b (patch)
tree38f97e54849bfabe2e73e203f8d9a70b4a5dae0c /graphics
parentac4a53c7df26bbf31f290755e9a26c20801d683b (diff)
downloadports-b6dc9f6ee5dab662368578732dd1ecd6fe87eb9b.tar.gz
ports-b6dc9f6ee5dab662368578732dd1ecd6fe87eb9b.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-soya3d/Makefile34
-rw-r--r--graphics/py-soya3d/distinfo6
-rw-r--r--graphics/py-soya3d/files/patch-ode-0.5_Makefile28
-rw-r--r--graphics/py-soya3d/files/patch-ode-0.5_configurator.c11
4 files changed, 65 insertions, 14 deletions
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index 94f1c7d9e56d..9262b24e2ce2 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= soya3d
-PORTVERSION= 0.10.2
+PORTVERSION= 0.10.4
CATEGORIES= graphics
MASTER_SITES= http://download.gna.org/soya/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -36,27 +36,39 @@ USE_GMAKE= yes
MANDIR= ${WRKDIR}/${DISTNAME}/manpage/man1
MAN1= soya_editor.1
INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}
+SOYATUTVER= 0.10.2
.if !defined(NOPORTDOCS)
-DISTFILES+= SoyaTutorial-${PORTVERSION}${EXTRACT_SUFX}
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN= Does not compile in ${ARCH}
+DISTFILES+= SoyaTutorial-${SOYATUTVER}${EXTRACT_SUFX}
.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e \
+ 's|malloc.h|stdlib.h|g' \
+ ${WRKSRC}/ode-0.5/configurator.c
+ @${REINPLACE_CMD} -e \
+ 's|g++|${CXX}|; \
+ s|-Wall||g; \
+ s|-L/usr/X11/lib|-lXext|; \
+ s|-L/usr/lib/X11R6||; \
+ s|-L/usr/lib/X11||; \
+ s|-L/usr/X11R6/lib|-L${X11BASE}/lib|; \
+ s|-fno-rtti||; \
+ s|-ffast-math|${CXXFLAGS} -I${X11BASE}/include|' \
+ ${WRKSRC}/ode-0.5/config/makefile.unix-gcc
+ @${REINPLACE_CMD} -e \
+ 's|^BUILD=debug|#BUILD=debug|; \
+ s|^#BUILD=release|BUILD=release|' \
+ ${WRKSRC}/ode-0.5/config/user-settings
post-install:
@${INSTALL_DIR} ${EXAMPLESDIR}
- @${CP} -R ${WRKDIR}/SoyaTutorial-${PORTVERSION}/tutorial/* ${EXAMPLESDIR}
+ @${CP} -R ${WRKDIR}/SoyaTutorial-${SOYATUTVER}/tutorial/* ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${INSTALL_DIR} ${DOCSDIR}
- @${CP} -R ${WRKDIR}/SoyaTutorial-${PORTVERSION}/doc/* ${DOCSDIR}
+ @${CP} -R ${WRKDIR}/SoyaTutorial-${SOYATUTVER}/doc/* ${DOCSDIR}
@${FIND} ${EXAMPLESDIR}/* -type f -print0 | \
${XARGS} -0 ${CHMOD} ${SHAREMODE}
.for f in ${MAN1}
@@ -64,4 +76,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/py-soya3d/distinfo b/graphics/py-soya3d/distinfo
index 4adc22e82ff4..fac8eb6957c6 100644
--- a/graphics/py-soya3d/distinfo
+++ b/graphics/py-soya3d/distinfo
@@ -1,6 +1,6 @@
-MD5 (python/Soya-0.10.2.tar.bz2) = d92cb987c73a1356ab8fd273b3465668
-SHA256 (python/Soya-0.10.2.tar.bz2) = 6a3be34393e81481912abb2912717bb2435c6f156f388072a626996d416bc507
-SIZE (python/Soya-0.10.2.tar.bz2) = 2167772
+MD5 (python/Soya-0.10.4.tar.bz2) = 1c2dc2bd62724201f7ef1b85bed3890f
+SHA256 (python/Soya-0.10.4.tar.bz2) = bf1f8dd13ac8f66db9a61ef57747025c19401ea0ad8651a86160f06f8415aa7d
+SIZE (python/Soya-0.10.4.tar.bz2) = 2164015
MD5 (python/SoyaTutorial-0.10.2.tar.bz2) = 6f03171bb18ec3baf6aee582f5edc845
SHA256 (python/SoyaTutorial-0.10.2.tar.bz2) = 26793a43fe0a14813ffd0613b2a8087e2e1d8a8b4a4af539536825e440705a8a
SIZE (python/SoyaTutorial-0.10.2.tar.bz2) = 3970014
diff --git a/graphics/py-soya3d/files/patch-ode-0.5_Makefile b/graphics/py-soya3d/files/patch-ode-0.5_Makefile
new file mode 100644
index 000000000000..94f8b540c287
--- /dev/null
+++ b/graphics/py-soya3d/files/patch-ode-0.5_Makefile
@@ -0,0 +1,28 @@
+--- ode-0.5/Makefile Sun May 7 12:12:01 2006
++++ ode-0.5/Makefile Sun May 7 12:12:01 2006
+@@ -329,13 +329,13 @@
+ -$(DEL_CMD) OPCODE/*.obj OPCODE/*.o OPCODE/Ice/*.obj OPCODE/Ice/*.o
+
+ %$(OBJ): %.c
+- $(CC) $(C_FLAGS) $(C_INC)$(INCPATH) $(DEFINES) $(C_OPT)1 $(C_OUT)$@ $<
++ $(CC) $(C_INC)$(INCPATH) $(C_FLAGS) -fPIC $(DEFINES) $(C_OUT)$@ $<
+
+ %$(OBJ): %.cpp
+- $(CC) $(C_FLAGS) $(C_INC)$(INCPATH) $(INC_OPCODE) $(DEFINES) $(C_OPT)$(OPT) $(C_OUT)$@ $<
++ $(CC) $(C_INC)$(INCPATH) $(C_FLAGS) -fPIC $(INC_OPCODE) $(DEFINES) $(C_OUT)$@ $<
+
+ %.exe: %$(OBJ)
+- $(CC) $(C_EXEOUT)$@ $< $(ODE_LIB) $(DRAWSTUFF_LIB) $(RESOURCE_FILE) $(LINK_OPENGL) $(LINK_MATH)
++ $(CC) $(C_EXEOUT)$@ $< $(ODE_LIB) $(DRAWSTUFF_LIB) $(RESOURCE_FILE) $(LINK_OPENGL) $(LINK_MATH) ${LDFLAGS}
+
+
+ # windows specific rules
+@@ -357,7 +357,7 @@
+
+ # unix-gcc specific dependency making
+
+-DEP_RULE=gcc -M $(C_INC)$(INCPATH) $(DEFINES)
++DEP_RULE=${CC} -M $(C_INC)$(INCPATH) $(DEFINES)
+ depend:
+ $(DEP_RULE) $(ODE_SRC) $(ODE_PREGEN_SRC) | tools/process_deps ode/src/ > Makefile.deps
+ $(DEP_RULE) $(DRAWSTUFF_SRC) | tools/process_deps drawstuff/src/ >> Makefile.deps
diff --git a/graphics/py-soya3d/files/patch-ode-0.5_configurator.c b/graphics/py-soya3d/files/patch-ode-0.5_configurator.c
new file mode 100644
index 000000000000..cd3138184107
--- /dev/null
+++ b/graphics/py-soya3d/files/patch-ode-0.5_configurator.c
@@ -0,0 +1,11 @@
+--- ode-0.5/configurator.c Sun May 7 12:12:01 2006
++++ ode-0.5/configurator.c Sun May 7 12:12:52 2006
+@@ -222,7 +222,7 @@
+ write_header_comment (file,"is this a pentium on a gcc-based platform?");
+ write_to_file ("ctest.cpp",
+ "int main() {\n"
+- " asm (\"mov $0,%%eax\\n cpuid\\n\" : : : \"%eax\");\n"
++ " asm (\"mov $0,%%eax\\n mov %%eax,(%%esi)\\n cpuid\\n\" : : : \"%eax\");\n"
+ " return 0;\n"
+ "}\n");
+ delete_file ("ctest.exe");