aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-21 10:08:58 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-21 10:08:58 +0000
commitde6c575e969180eeeb3b759aeaa8d57f9492d622 (patch)
treeab63799214b7f2bc76c3b3facd7cee40605d4873 /graphics
parent418c77a63af5b8df161f319f8ef6d0e84729baee (diff)
downloadports-de6c575e969180eeeb3b759aeaa8d57f9492d622.tar.gz
ports-de6c575e969180eeeb3b759aeaa8d57f9492d622.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/oglext/Makefile20
-rw-r--r--graphics/oglext/distinfo4
-rw-r--r--graphics/oglext/files/patch-build_OglExt.pro15
-rw-r--r--graphics/oglext/files/patch-build_linux-gcc_Makefile91
-rw-r--r--graphics/oglext/files/patch-src_Macros.h11
5 files changed, 36 insertions, 105 deletions
diff --git a/graphics/oglext/Makefile b/graphics/oglext/Makefile
index b57caa79c637..56723e29e0d6 100644
--- a/graphics/oglext/Makefile
+++ b/graphics/oglext/Makefile
@@ -6,15 +6,17 @@
#
PORTNAME= oglext
-PORTVERSION= 1.0.2
+PORTVERSION= 1.1.0
CATEGORIES= graphics devel
-MASTER_SITES= http://www.julius.caesar.de/oglext/
+MASTER_SITES= http://www.julius.caesar.de/oglext/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ip@doom.homeunix.org
COMMENT= A library for easier access to OpenGL extensions
-USE_ZIP= yes
+BUILD_DEPENDS= ${LOCALBASE}/bin/tmake:${PORTSDIR}/devel/tmake
+
+USE_BZIP2= yes
USE_GMAKE= yes
USE_GL= yes
USE_X_PREFIX= yes
@@ -24,16 +26,22 @@ REINPLACE_ARGS= -i ""
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/src
-MAKEFILE= ${WRKSRC}/build/linux-gcc/Makefile
-MAKE_ENV= AR="${AR}" LN="${LN}" RM="${RM}"
+ALL_TARGET= all staticlib
+
+TMAKE?= ${LOCALBASE}/bin/tmake
+TMAKEPATH?= ${LOCALBASE}/share/tmake/freebsd-g++
pre-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e "s/`${PRINTF} '\r'`//"
+pre-build:
+ ${SETENV} TMAKEPATH=${TMAKEPATH} \
+ ${TMAKE} ${WRKSRC}/build/OglExt.pro >${BUILD_WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/libOglExt.so.1 ${PREFIX}/lib
${LN} -sf ${PREFIX}/lib/libOglExt.so.1 ${PREFIX}/lib/libOglExt.so
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/libOglExt.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/libOglExt.a ${PREFIX}/lib
# install includes in separate dir to avoid conflicts with Mesa
@${MKDIR} ${PREFIX}/include/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/${PORTNAME}
diff --git a/graphics/oglext/distinfo b/graphics/oglext/distinfo
index c8798f9e45a2..57c5af9f0bef 100644
--- a/graphics/oglext/distinfo
+++ b/graphics/oglext/distinfo
@@ -1,2 +1,2 @@
-MD5 (oglext-1.0.2-src.zip) = 569e331cb6131e75e105b9c6a0e4ae6a
-SIZE (oglext-1.0.2-src.zip) = 172296
+MD5 (oglext-1.1.0-src.tar.bz2) = f3bfa6f2664346bf783cbfc9179b90a0
+SIZE (oglext-1.1.0-src.tar.bz2) = 95390
diff --git a/graphics/oglext/files/patch-build_OglExt.pro b/graphics/oglext/files/patch-build_OglExt.pro
new file mode 100644
index 000000000000..fc1983c29911
--- /dev/null
+++ b/graphics/oglext/files/patch-build_OglExt.pro
@@ -0,0 +1,15 @@
+--- build/OglExt.pro.orig Thu Aug 19 23:58:56 2004
++++ build/OglExt.pro Thu Aug 19 23:59:25 2004
+@@ -2,9 +2,11 @@
+ # Tue Jun 15 10:34:01 CET 2004
+
+ TEMPLATE = lib
+-CONFIG += dll warn_on release opengl
++CONFIG = dll warn_on release opengl
+ TARGET = OglExt
+ VERSION = 1.1.0
++
++INCLUDEPATH= ../include
+
+ SOURCES += \
+ OglExt.cpp \
diff --git a/graphics/oglext/files/patch-build_linux-gcc_Makefile b/graphics/oglext/files/patch-build_linux-gcc_Makefile
deleted file mode 100644
index d705152277c6..000000000000
--- a/graphics/oglext/files/patch-build_linux-gcc_Makefile
+++ /dev/null
@@ -1,91 +0,0 @@
---- build/linux-gcc/Makefile.orig Mon Feb 2 19:30:41 2004
-+++ build/linux-gcc/Makefile Mon Feb 2 19:34:14 2004
-@@ -8,28 +8,28 @@
-
- ####### Compiler, tools and options
-
--CC = gcc
--CXX = g++
--LEX = flex
--YACC = yacc
--CFLAGS = -pipe -Wall -W -fPIC
--CXXFLAGS = -pipe -Wall -W -fPIC
--LEXFLAGS =
--YACCFLAGS= -d
--LINK = g++
-+#CC = gcc
-+#CXX = g++
-+#LEX = flex
-+#YACC = yacc
-+CFLAGS += -pipe -Wall -W -fPIC -I${X11BASE}/include
-+CXXFLAGS += -pipe -Wall -W -fPIC -I${X11BASE}/include
-+#LEXFLAGS =
-+#YACCFLAGS= -d
-+LINK = ${CXX}
- LFLAGS = -shared -Wl,-soname,libOglExt.so.1
--LIBS =
--AR = ar cqs
--RANLIB =
--TAR = tar -cf
--GZIP = gzip -9f
--COPY = cp -f
--COPY_FILE= $(COPY) -p
--COPY_DIR = $(COPY) -pR
--DEL_FILE = rm -f
--SYMLINK = ln -sf
--DEL_DIR = rmdir
--MOVE = mv -f
-+LIBS = -L${X11BASE}/lib -lGL
-+#AR = ${AR} cqs
-+#RANLIB =
-+#TAR = ${TAR} -cf
-+#GZIP = ${GZIP_CMD} -9f
-+#COPY = ${CP} -f
-+#COPY_FILE= $(COPY) -p
-+#COPY_DIR = $(COPY) -pR
-+DEL_FILE = ${RM} -f
-+SYMLINK = ${LN} -sf
-+#DEL_DIR = ${RMDIR}
-+#MOVE = ${MV} -f
-
- ####### Output directory
-
-@@ -45,12 +45,12 @@
- RenderingContext.cpp
- OBJECTS = OglExt.o \
- RenderingContext.o
--TARGET = libOglExt.so.1.0.0
-+TARGET = libOglExt.so.1
- TARGETA = libOglExt.a
--TARGETD = libOglExt.so.1.0.0
--TARGET0 = libOglExt.so
--TARGET1 = libOglExt.so.1
--TARGET2 = libOglExt.so.1.0
-+#TARGETD = libOglExt.so.1.0.0
-+#TARGET0 = libOglExt.so
-+#TARGET1 = libOglExt.so.1
-+#TARGET2 = libOglExt.so.1.0
-
- first: all
- ####### Implicit rules
-@@ -74,15 +74,15 @@
-
- ####### Build rules
-
--all: Makefile $(TARGET)
-+all: $(TARGET) $(TARGETA)
-
- $(TARGET): $(OBJECTS)
-- -$(DEL_FILE) $(TARGET) $(TARGET0) $(TARGET1) $(TARGET2)
-+ -$(DEL_FILE) $(TARGET)
- $(LINK) $(LFLAGS) -o $(TARGET) $(OBJECTS) $(LIBS)
-- -ln -s $(TARGET) $(TARGET0)
-- -ln -s $(TARGET) $(TARGET1)
-- -ln -s $(TARGET) $(TARGET2)
-
-+$(TARGETA): $(OBJECTS)
-+ -$(DEL_FILE) $(TARGETA)
-+ $(AR) cqs $@ $(OBJECTS)
-
- clean:
- -$(DEL_FILE) $(OBJECTS)
diff --git a/graphics/oglext/files/patch-src_Macros.h b/graphics/oglext/files/patch-src_Macros.h
index 6557a788f92d..820f5ac40c7e 100644
--- a/graphics/oglext/files/patch-src_Macros.h
+++ b/graphics/oglext/files/patch-src_Macros.h
@@ -1,10 +1,9 @@
---- src/Macros.h.orig Mon Feb 2 19:23:57 2004
-+++ src/Macros.h Mon Feb 2 19:24:13 2004
-@@ -18,7 +18,7 @@
- #define _OGL_MACROS_H_
+--- src/Macros.h.orig Thu Aug 19 23:19:51 2004
++++ src/Macros.h Thu Aug 19 23:20:28 2004
+@@ -19,6 +19,7 @@
+
+ #if !defined(_WIN32) && (!defined(__APPLE__) || !defined(__GNUC__)) && !defined(__MACOSX__)
- #ifndef _WIN32
--
+ #define GLX_GLXEXT_PROTOTYPES
#include <GL/glx.h>