aboutsummaryrefslogtreecommitdiff
path: root/irc/anope
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-12-29 13:45:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-12-29 13:45:41 +0000
commit3c606e457f2b442460bc5b14ce725d3f8eb706ff (patch)
treefa525eae08d542ce991c07c0e97e4249a9c24c79 /irc/anope
parent80d951324ebf73e79670f9fffcfc0476fb87cbd5 (diff)
downloadports-3c606e457f2b442460bc5b14ce725d3f8eb706ff.tar.gz
ports-3c606e457f2b442460bc5b14ce725d3f8eb706ff.zip
Notes
Diffstat (limited to 'irc/anope')
-rw-r--r--irc/anope/Makefile5
-rw-r--r--irc/anope/files/patch-configure8
2 files changed, 11 insertions, 2 deletions
diff --git a/irc/anope/Makefile b/irc/anope/Makefile
index a918a337c9af..29e1683b9250 100644
--- a/irc/anope/Makefile
+++ b/irc/anope/Makefile
@@ -7,6 +7,7 @@
PORTNAME= anope
PORTVERSION= 1.6.3
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -109,9 +110,9 @@ pre-configure: #--{{{
.endif
# XXX Add here other arch which needs -fPIC :-)
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
- @${ECHO_CMD} CC_FLAGS=\"-O -fPIC\" >> ${CONFIG_CACHE}
+ @${ECHO_CMD} CC_FLAGS=\"${CFLAGS} -fPIC\" >> ${CONFIG_CACHE}
.else
- @${ECHO_CMD} CC_FLAGS=\"-O\" >> ${CONFIG_CACHE}
+ @${ECHO_CMD} CC_FLAGS=\"${CFLAGS}\" >> ${CONFIG_CACHE}
.endif
#}}}
diff --git a/irc/anope/files/patch-configure b/irc/anope/files/patch-configure
index 3ee1d1f4e3d7..9cd78bae21e2 100644
--- a/irc/anope/files/patch-configure
+++ b/irc/anope/files/patch-configure
@@ -389,3 +389,11 @@
###########################################################################
+@@ -830,6 +448,7 @@
+ fi
+ log cache supplied \`"$CC_LIBS'"
+ else
++ echo >tmp/test.c "int main(){return 1;}"
+ CC_LIBS=
+ if run $CC $CC_FLAGS tmp/test.c -lnsl -o tmp/test ; then
+ CC_LIBS="$CC_LIBS -lnsl"