aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2001-01-28 22:23:25 +0000
committerClive Lin <clive@FreeBSD.org>2001-01-28 22:23:25 +0000
commitcfac3acc7235e9cfa0fa7f815b16d0b79347677c (patch)
tree4bbce9cf255509e12314c3262c9fab0279610b19 /irc/bitchx/Makefile
parent9e6fc4c340a2c821e871c30858f219f64a8bbef0 (diff)
downloadports-cfac3acc7235e9cfa0fa7f815b16d0b79347677c.tar.gz
ports-cfac3acc7235e9cfa0fa7f815b16d0b79347677c.zip
Notes
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile24
1 files changed, 19 insertions, 5 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index d084e61bac7c..f497df003cb6 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= BitchX
PORTVERSION= 1.0c17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc gnome
MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
ftp://ftp.bitchx.org/pub/BitchX/source/
@@ -37,11 +37,14 @@ CONFIGURE_ARGS+=--with-gtk
.else
CONFIGURE_ARGS+=--without-gtk
.endif
-.if defined(HAVE_ESOUND)
+.if (defined(HAVE_ESOUND) && defined(HAVE_GNOME))
USE_ESOUND= yes
CONFIGURE_ARGS+=--enable-sound
.endif
-
+.if defined(HAVE_IPV6)
+USE_IPV6= yes
+CONFIGURE_ARGS+=--enable-ipv6
+.endif
.if defined(WITH_TCL)
BUILD_DEPENDS+= ${LOCALBASE}/include/tcl8.3/tcl.h:${PORTSDIR}/lang/tcl83
CONFIGURE_ARGS+=--with-tcl \
@@ -53,8 +56,8 @@ post-extract:
.endif
.if defined(WITH_SOCKS5)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a${PORTSDIR}/net/socks5
-CONFIGURE_ARGS+=--with-socks5=${LOCALBASE}
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
+CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
.endif
@@ -74,10 +77,21 @@ pre-patch:
pre-extract:
@${ECHO} "Available switches:"
@${ECHO} "-------------------"
+.if !defined(WITH_PLUGINS)
@${ECHO} "WITH_PLUGINS - Build the plugins"
+.endif
+.if !defined(WITH_LATIN)
@${ECHO} "WITH_LATIN - Recommended if you are using an ISO-8859-1 display"
+.endif
+.if !defined(WITH_TCL)
@${ECHO} "WITH_TCL - Build BitchX with TCL scripting"
+.endif
+.if !defined(WITH_SOCKS5)
@${ECHO} "WITH_SOCKS5 - Build BitchX with SOCKS5 support"
+.endif
+.if !defined(WITH_IPV6)
+ @${ECHO} "WITH_IPV6 - Build BitchX with IPV6 support"
+.endif
post-install:
.if !defined(NOPORTDOCS)