aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx/Makefile
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-06-27 16:16:16 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-06-27 16:16:16 +0000
commita3a9b5e28029f31d452c681387d65e10228fda89 (patch)
tree20a420d9cab6f89e03a45f1124e6bf2051f6bb69 /irc/bitchx/Makefile
parenteb11b51ed920d9d5e656085008d8f65926b60bc4 (diff)
downloadports-a3a9b5e28029f31d452c681387d65e10228fda89.tar.gz
ports-a3a9b5e28029f31d452c681387d65e10228fda89.zip
Notes
Diffstat (limited to 'irc/bitchx/Makefile')
-rw-r--r--irc/bitchx/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 43d2e7c36816..09f3aec41e55 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -3,13 +3,14 @@
# Date created: 26 Jan 1998
# Whom: griffin
#
-# $Id: Makefile,v 1.3 1998/07/21 11:38:44 eivind Exp $
+# $Id: Makefile,v 1.6 1999/06/27 05:25:00 cpiazza Exp $
#
DISTNAME= ircii-pana-75p3
PKGNAME= bitchx-75p3
CATEGORIES= net
-MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/
+MASTER_SITES= ftp://ftp.bitchx.org/pub/BitchX/source/ \
+ ftp://ftp.buk.net/pub/software/bitchx/source/
MAINTAINER= griffin@blackhole.iceworld.org
@@ -17,9 +18,12 @@ GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/BitchX
+MAN1= BitchX.1
+MANCOMPRESSED= yes
+
post-patch:
- ${SED} -e s,__PREFIX__,$(PREFIX), $(WRKSRC)/include/config.h > $(WRKSRC)/include/config.h.new
- ${MV} $(WRKSRC)/include/config.h.new $(WRKSRC)/include/config.h
+ @${SED} -e s,__PREFIX__,$(PREFIX), $(WRKSRC)/include/config.h > $(WRKSRC)/include/config.h.new
+ @${MV} $(WRKSRC)/include/config.h.new $(WRKSRC)/include/config.h
do-install:
${MKDIR} ${PREFIX}/lib/bx
@@ -27,5 +31,6 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/source/scr-bx ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/source/wserv ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/BitchX.help ${PREFIX}/lib/bx
+ ${INSTALL_MAN} ${WRKSRC}/BitchX.1.gz ${PREFIX}/man/man1
.include <bsd.port.mk>