aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-07 18:24:43 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-07 18:24:43 +0000
commit792eba5df08fdd6d5943c47d4bea3ef48c0dcc16 (patch)
tree4a2b6eec6110c489d7c1e7ae5fe370c31f571725 /irc/bitchx
parent03ee84edeb4632a4f111930d216053361c4751de (diff)
downloadports-792eba5df08fdd6d5943c47d4bea3ef48c0dcc16.tar.gz
ports-792eba5df08fdd6d5943c47d4bea3ef48c0dcc16.zip
Notes
Diffstat (limited to 'irc/bitchx')
-rw-r--r--irc/bitchx/Makefile32
-rw-r--r--irc/bitchx/files/patch-aj33
-rw-r--r--irc/bitchx/pkg-plist15
3 files changed, 59 insertions, 21 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index ac80238c2042..b57e1f0b511b 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -27,9 +27,14 @@ WRKSRC= ${WRKDIR}/BitchX
USE_AUTOCONF= yes
USE_GMAKE= yes
.if defined(WITH_GNOME)
-CONFIGURE_ARGS+= --with-plugins --with-gtk --enable-sound
+CONFIGURE_ARGS+= --with-gtk --enable-sound
.else
-CONFIGURE_ARGS+= --with-plugins --without-gtk
+CONFIGURE_ARGS+= --without-gtk
+.endif
+.if defined(WITH_PLUGINS)
+CONFIGURE_ARGS+= --with-plugins
+.else
+CONFIGURE_ARGS+= --without-plugins
.endif
CONFIGURE_ARGS+= --exec-prefix="${PREFIX}/share" \
--bindir="${PREFIX}/bin" \
@@ -46,11 +51,9 @@ MAKE_ENV+= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
.if !defined(WITH_GNOME)
pre-extract:
@${ECHO} "You can add hooks for GNOME by defining WITH_GNOME"
+ @${ECHO} "If you want to build the plugins define WITH_PLUGINS"
.endif
-pre-patch:
- @${PERL} -pi -e "s!#undef WANT_CHAN_NICK_SERV!#define WANT_CHAN_NICK_SERV!" ${WRKSRC}/include/config.h
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/bx/help
@@ -62,6 +65,24 @@ post-install:
@${ECHO} bin/gtkBitchX >> ${TMPPLIST}
@${ECHO} bin/gtkBitchX-1.0c16 >> ${TMPPLIST}
@${ECHO} share/bx/plugins/nicklist.so >> ${TMPPLIST}
+.if defined(WITH_PLUGINS)
+ @${ECHO} share/bx/plugins/BitchX.hints >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/acro.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/amp.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/autobot.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/blowfish.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/encrypt.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/fserv.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/hint.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/nap.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/pkga.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/possum.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/qmail.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/scan.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/wavplay.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/qbx.so >> ${TMPPLIST}
+ @${ECHO} share/bx/plugins/plugins >> ${TMPPLIST}
+.endif
.else
@${ECHO} bin/BitchX >> ${TMPPLIST}
@${ECHO} bin/BitchX-1.0c16 >> ${TMPPLIST}
@@ -69,7 +90,6 @@ post-install:
@${ECHO} share/bx/wserv >> ${TMPPLIST}
.endif
@${ECHO} @dirrm share/bx/help >> ${TMPPLIST}
- @${ECHO} @dirrm share/bx/plugins >> ${TMPPLIST}
@${ECHO} @dirrm share/bx/script >> ${TMPPLIST}
@${ECHO} @dirrm share/bx/translation >> ${TMPPLIST}
@${ECHO} @dirrm share/bx >> ${TMPPLIST}
diff --git a/irc/bitchx/files/patch-aj b/irc/bitchx/files/patch-aj
new file mode 100644
index 000000000000..68c201f23875
--- /dev/null
+++ b/irc/bitchx/files/patch-aj
@@ -0,0 +1,33 @@
+--- include/config.h.orig Tue Jul 4 20:27:01 2000
++++ include/config.h Tue Jul 4 20:33:03 2000
+@@ -460,7 +460,7 @@
+
+ #define DEFAULT_HTTP_GRAB OFF
+ #define DEFAULT_HELP_WINDOW OFF
+-#define DEFAULT_NICK_COMPLETION ON
++#define DEFAULT_NICK_COMPLETION OFF
+ #define DEFAULT_NICK_COMPLETION_LEN 2
+ #define DEFAULT_NICK_COMPLETION_TYPE 0 /* 0 1 2 */
+ #define DEFAULT_NOTIFY ON
+@@ -495,9 +495,9 @@
+ #define DEFAULT_AINV 0
+ #define DEFAULT_ANNOY_KICK OFF
+ #define DEFAULT_AOP_VAR OFF
+-#define DEFAULT_AUTO_AWAY ON
+-#define DEFAULT_KICK_OPS ON
+-#define DEFAULT_AUTO_REJOIN ON
++#define DEFAULT_AUTO_AWAY OFF
++#define DEFAULT_KICK_OPS OFF
++#define DEFAULT_AUTO_REJOIN OFF
+ #define DEFAULT_DEOPFLOOD ON
+ #define DEFAULT_CTCP_FLOOD_AFTER 3
+ #define DEFAULT_CTCP_FLOOD_RATE 10
+@@ -735,7 +735,7 @@
+ #endif
+
+ #undef PARANOID /* #define this if your paranoid about dcc hijacking */
+-#undef WANT_CHAN_NICK_SERV /* do we want to include some chan/nick/oper server commands */
++#define WANT_CHAN_NICK_SERV /* do we want to include some chan/nick/oper server commands */
+
+ /* new epic stuff */
+ #define OLD_STATUS_S_EXPANDO_BEHAVIOR
diff --git a/irc/bitchx/pkg-plist b/irc/bitchx/pkg-plist
index 623958f02338..781a52888a6c 100644
--- a/irc/bitchx/pkg-plist
+++ b/irc/bitchx/pkg-plist
@@ -898,21 +898,6 @@ share/bx/help/8_Scripts/webster
share/bx/help/8_Scripts/2.8script
share/bx/help/8_Scripts/window
share/bx/help/README_FIRST
-share/bx/plugins/BitchX.hints
-share/bx/plugins/acro.so
-share/bx/plugins/amp.so
-share/bx/plugins/autobot.so
-share/bx/plugins/blowfish.so
-share/bx/plugins/encrypt.so
-share/bx/plugins/fserv.so
-share/bx/plugins/hint.so
-share/bx/plugins/nap.so
-share/bx/plugins/pkga.so
-share/bx/plugins/possum.so
-share/bx/plugins/qmail.so
-share/bx/plugins/scan.so
-share/bx/plugins/wavplay.so
-share/bx/plugins/qbx.so
share/bx/script/actplug.gmz
share/bx/script/bxglobal
share/bx/script/bxtcl.tcl