aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-05-28 16:09:11 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-05-28 16:09:11 +0000
commit1feb642b4c194ff14342df9462c3c99057018ddd (patch)
tree8160da22d58f6722d5e11c931eef843494bf2664 /irc/bitchx
parentbf9002d9767cd0e6f2253d3d4d817a654fe1919e (diff)
downloadports-1feb642b4c194ff14342df9462c3c99057018ddd.tar.gz
ports-1feb642b4c194ff14342df9462c3c99057018ddd.zip
Notes
Diffstat (limited to 'irc/bitchx')
-rw-r--r--irc/bitchx/Makefile139
-rw-r--r--irc/bitchx/distinfo2
-rw-r--r--irc/bitchx/pkg-plist52
3 files changed, 60 insertions, 133 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 435059ec197d..c9401c4a51a1 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -7,15 +7,14 @@
PORTNAME= BitchX
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES+= irc
-MASTER_SITES= ftp://ftp.bitchx.org/pub/BitchX/source/ \
- ftp://ftp.cyberpunkz.org/pub/BitchX/source/ \
- ftp://ftp.cyberpunkz.org/pub/BitchX/tcl-o/:tcl
-DISTFILES= ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX}
-EXTRACT_ONLY= ircii-pana-${PORTVERSION}-final${EXTRACT_SUFX}
+MASTER_SITES= ftp://ftp.bitchx.org/pub/BitchX/ \
+ ftp://ftp.cyberpunkz.org/pub/BitchX/
+DISTNAME= ircii-pana-${PORTVERSION}-final
-MAINTAINER?= ports@FreeBSD.org
-COMMENT?= An alternative ircII color client with optional GTK/GNOME support
+MAINTAINER?= beech@alaskaparadise.com
+COMMENT?= ircII color client with GTK/GNOME support
WRKSRC= ${WRKDIR}/BitchX
USE_PERL5= yes
@@ -29,149 +28,79 @@ CONFIGURE_ARGS+=--exec-prefix="${PREFIX}/share" \
--libdir="${PREFIX}/share" \
--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib" \
+ CFLAGS="${CFLAGS}"
MAN1= BitchX.1
-#OPTIONS= ESOND "With ESOUND support" off \
-# GNOME "With GTK/GNOME1 Frontend" off \
-# IPV6 "With IPV6 support" off \
-# LATIN "Recommended if you are using an ISO-8859-1 display" off \
-# PLUGINS "With BitchX Plugins" off \
-# SOCKS5 "With SOCKS5 support" off \
-# SSL "With SSL" off \
-# TCL "With TCL support" off \
-# XMMS "With XMMS plugin" off
+OPTIONS= ESOUND "With ESOUND support" off \
+ GNOME "With GTK/GNOME1 Frontend" off \
+ IPV6 "With IPV6 support" off \
+ LATIN "Recommended if you are using an ISO-8859-1 display" off \
+ PLUGINS "With BitchX Plugins" off \
+ SOCKS5 "With SOCKS5 support" off \
+ SSL "With SSL" off \
+ XMMS "With XMMS plugin" off
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
+
+.if defined(WITH_SSL)
+CONFIGURE_ARGS+=--with-ssl
+.endif
.if defined(WITH_GNOME)
-USE_X_PREFIX= yes
USE_GNOME= gnomelibs
CONFIGURE_ARGS+=--with-gtk
CFLAGS+= -I${X11BASE}/include/gnome-1.0/
-PLIST_SUB+= NOGNOME:="@comment " GNOME:=""
+PLIST_SUB+= NOGNOME="@comment " GNOME=""
.else
CONFIGURE_ARGS+=--without-gtk
-PLIST_SUB+= GNOME:="@comment " NOGNOME:=""
+PLIST_SUB+= GNOME="@comment " NOGNOME=""
.endif
+
.if (defined(WITH_ESOUND) && defined(WITH_GNOME))
USE_GNOME+= esound
CONFIGURE_ARGS+=--enable-sound
.endif
-.if defined(WITH_SSL)
-USE_OPENSSL= yes
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_TCL)
-DISTFILES+= freebsd4-tcl83-bx1.0c19-tcl.o:tcl
-.endif
-
.if defined(WITH_XMMS)
LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
.endif
.if defined(WITH_IPV6)
-USE_AUTOTOOLS= autoconf:253
-.endif
-
-.if defined(WITH_IPV6)
CONFIGURE_ARGS+=--enable-ipv6
.endif
-.if defined(WITH_TCL)
-BUILD_DEPENDS+= ${LOCALBASE}/include/tcl8.3/tcl.h:${PORTSDIR}/lang/tcl83
-CONFIGURE_ARGS+=--with-tcl \
- --with-tcl-libs=${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3"
-CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3
-ONLY_FOR_ARCHS= i386
-.if ${OSVERSION} > 500017
-BROKEN= "WITH_TCL is not available on 5.X, try to install without TCL"
-.endif
-.endif
-
.if defined(WITH_SOCKS5)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
-.endif
-
-.if defined(WITH_SSL)
-CONFIGURE_ARGS+= --with-ssl
.endif
.if defined(WITH_PLUGINS)
PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay
-PLIST_SUB+= PLUGINS:=""
+PLIST_SUB+= PLUGINS=""
.else
CONFIGURE_ARGS+=--without-plugins
-PLIST_SUB+= PLUGINS:="@comment "
+PLIST_SUB+= PLUGINS="@comment "
.endif
.if defined(WITH_XMMS)
PLUGINS= xmms
-PLIST_SUB+= XMMS:=""
+PLIST_SUB+= XMMS=""
.else
-PLIST_SUB+= XMMS:="@comment "
+PLIST_SUB+= XMMS="@comment "
.endif
.if (defined(WITH_XMMS) && defined(WITH_PLUGINS))
PLUGINS= abot,acro,aim,arcfour,autocycle,blowfish,cavlink,encrypt,fserv,hint,identd,nap,pkga,possum,qbx,qmail,scan,wavplay,xmms
.endif
.if (defined(WITH_PLUGINS) || defined(WITH_XMMS))
-INSTALLS_SHLIB= yes
CONFIGURE_ARGS+= --with-plugins=${PLUGINS}
.endif
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
-
-.if defined(WITH_TCL)
-
-pre-fetch:
-.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
- ${DIALOG} --yesno "SECURITY NOTICE: TCL support is only \
- available by linking a precompiled binary object into the Application. \
- Do you really want to proceed building BitchX with TCL support?" 7 70 || ${FALSE}
-.endif # BATCH
-
-.endif # WITH_TCL
-
-pre-extract:
- @${ECHO_CMD} "Available switches:"
- @${ECHO_CMD} "-------------------"
-.if !defined (WITH_XMMS)
- @${ECHO_CMD} "WITH_XMMS - Building BitchX with XMMS-Plugin"
-.endif
-.if !defined(WITH_PLUGINS)
- @${ECHO_CMD} "WITH_PLUGINS - Building BitchX with some other plugins"
-.endif
-.if !defined(WITH_LATIN)
- @${ECHO_CMD} "WITH_LATIN - Recommended if you are using an ISO-8859-1 display"
-.endif
-.if !defined(WITH_TCL)
- @${ECHO_CMD} "WITH_TCL - Build BitchX with TCL scripting"
-.endif
-.if !defined(WITH_SOCKS5)
- @${ECHO_CMD} "WITH_SOCKS5 - Build BitchX with SOCKS5 support"
-.endif
-.if !defined(WITH_SSL)
- @${ECHO_CMD} "WITH_SSL - Build BitchX with SSL support"
-.endif
-.if !defined(WITH_IPV6)
- @${ECHO_CMD} "WITH_IPV6 - Build BitchX with IPV6 support"
- @${ECHO_CMD} " (Please Note: /detach crashes BitchX with IPv6)"
-.endif
-.if !defined(WITH_GNOME)
- @${ECHO_CMD} "WITH_GNOME - Build BitchX with Gtk-Frontend"
-.endif
-
-.if defined(WITH_TCL)
-
-post-extract:
- @${CP} ${DISTDIR}/freebsd4-tcl83-bx1.0c19-tcl.o ${WRKSRC}/source/tcl.o
-
-.endif
pre-patch:
.if defined(WITH_LATIN)
@@ -183,7 +112,7 @@ post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/bx/help
${MKDIR} ${PREFIX}/share/doc/bitchx
- ${TAR} --directory ${WRKSRC}/bitchx-docs -cf - . --exclude CVS | \
+ ${TAR} --directory ${WRKSRC}/bitchx-docs -cf - . | \
${TAR} --directory ${PREFIX}/share/bx/help -xf -
.else
${RMDIR} ${PREFIX}/share/bx/help
diff --git a/irc/bitchx/distinfo b/irc/bitchx/distinfo
index 122a138c7ae4..d396c394fdbc 100644
--- a/irc/bitchx/distinfo
+++ b/irc/bitchx/distinfo
@@ -1,5 +1,3 @@
MD5 (ircii-pana-1.1-final.tar.gz) = 611d2dda222f00c10140236f4c331572
SHA256 (ircii-pana-1.1-final.tar.gz) = 7464cd75a10f2d117a10cf0184e5d4b9ece44de03a226402c17bdd3f2c7eca57
SIZE (ircii-pana-1.1-final.tar.gz) = 2532476
-MD5 (freebsd4-tcl83-bx1.0c19-tcl.o) = a49fd4cab976de64ea8b4215a50a9553
-SIZE (freebsd4-tcl83-bx1.0c19-tcl.o) = 46620
diff --git a/irc/bitchx/pkg-plist b/irc/bitchx/pkg-plist
index 16e1248325e3..afe92987695b 100644
--- a/irc/bitchx/pkg-plist
+++ b/irc/bitchx/pkg-plist
@@ -1,8 +1,8 @@
-%%NOGNOME:%%bin/BitchX
-%%NOGNOME:%%bin/BitchX-1.1-final
-%%GNOME:%%bin/gtkBitchX
-%%GNOME:%%bin/gtkBitchX-1.1-final
-%%NOGNOME:%%bin/scr-bx
+%%NOGNOME%%bin/BitchX
+%%NOGNOME%%bin/BitchX-1.1-final
+%%GNOME%%bin/gtkBitchX
+%%GNOME%%bin/gtkBitchX-1.1-final
+%%NOGNOME%%bin/scr-bx
share/bx/BitchX.help
share/bx/BitchX.ircnames
share/bx/BitchX.quit
@@ -916,26 +916,26 @@ share/bx/BitchX.kick
%%PORTDOCS%%share/bx/help/findcomm
%%PORTDOCS%%share/bx/help/functions
%%PORTDOCS%%share/bx/help/out
-%%PLUGINS:%%share/bx/plugins/BitchX.hints
-%%PLUGINS:%%share/bx/plugins/acro.so
-%%PLUGINS:%%share/bx/plugins/autobot.so
-%%PLUGINS:%%share/bx/plugins/blowfish.so
-%%PLUGINS:%%share/bx/plugins/encrypt.so
-%%PLUGINS:%%share/bx/plugins/fserv.so
-%%PLUGINS:%%share/bx/plugins/hint.so
-%%PLUGINS:%%share/bx/plugins/nap.so
-%%PLUGINS:%%share/bx/plugins/pkga.so
-%%PLUGINS:%%share/bx/plugins/possum.so
-%%PLUGINS:%%share/bx/plugins/qmail.so
-%%PLUGINS:%%share/bx/plugins/scan.so
-%%PLUGINS:%%share/bx/plugins/wavplay.so
-%%PLUGINS:%%share/bx/plugins/qbx.so
-%%PLUGINS:%%share/bx/plugins/aim.so
-%%PLUGINS:%%share/bx/plugins/arcfour.so
-%%PLUGINS:%%share/bx/plugins/autocycle.so
-%%PLUGINS:%%share/bx/plugins/cavlink.so
-%%PLUGINS:%%share/bx/plugins/identd.so
-%%XMMS:%%share/bx/plugins/xmms.so
+%%PLUGINS%%share/bx/plugins/BitchX.hints
+%%PLUGINS%%share/bx/plugins/acro.so
+%%PLUGINS%%share/bx/plugins/autobot.so
+%%PLUGINS%%share/bx/plugins/blowfish.so
+%%PLUGINS%%share/bx/plugins/encrypt.so
+%%PLUGINS%%share/bx/plugins/fserv.so
+%%PLUGINS%%share/bx/plugins/hint.so
+%%PLUGINS%%share/bx/plugins/nap.so
+%%PLUGINS%%share/bx/plugins/pkga.so
+%%PLUGINS%%share/bx/plugins/possum.so
+%%PLUGINS%%share/bx/plugins/qmail.so
+%%PLUGINS%%share/bx/plugins/scan.so
+%%PLUGINS%%share/bx/plugins/wavplay.so
+%%PLUGINS%%share/bx/plugins/qbx.so
+%%PLUGINS%%share/bx/plugins/aim.so
+%%PLUGINS%%share/bx/plugins/arcfour.so
+%%PLUGINS%%share/bx/plugins/autocycle.so
+%%PLUGINS%%share/bx/plugins/cavlink.so
+%%PLUGINS%%share/bx/plugins/identd.so
+%%XMMS%%share/bx/plugins/xmms.so
share/bx/script/SCRIPTS
share/bx/script/actplug.gmz
share/bx/script/bxglobal
@@ -985,7 +985,7 @@ share/bx/translation/SWEDISH_NAMES_COM
share/bx/translation/SWISS
share/bx/translation/UNITED_KINGDOM
share/bx/translation/UNITED_KINGDOM_COM
-%%NOGNOME:%%share/bx/wserv
+%%NOGNOME%%share/bx/wserv
%%PORTDOCS%%@dirrm share/doc/bitchx
@dirrm share/bx/translation
@dirrm share/bx/script