aboutsummaryrefslogtreecommitdiff
path: root/irc/bitchx
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-11-19 04:01:48 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-11-19 04:01:48 +0000
commit916e01dcd837b84f67b74a7ba29a95dfe918ced3 (patch)
treef6f527ed3ee9c159d9e01bf1b7395ffbf10cef9e /irc/bitchx
parent39a5f36418c4c6689edbe92f23277c86ba76f51d (diff)
downloadports-916e01dcd837b84f67b74a7ba29a95dfe918ced3.tar.gz
ports-916e01dcd837b84f67b74a7ba29a95dfe918ced3.zip
Notes
Diffstat (limited to 'irc/bitchx')
-rw-r--r--irc/bitchx/Makefile39
-rw-r--r--irc/bitchx/distinfo4
-rw-r--r--irc/bitchx/files/patch-amd64_fix12
-rw-r--r--irc/bitchx/files/patch-ap11
-rw-r--r--irc/bitchx/files/patch-aq9
-rw-r--r--irc/bitchx/files/patch-configure156
-rw-r--r--irc/bitchx/files/patch-source_gcc_fix36
-rw-r--r--irc/bitchx/files/patch-source_server_c12
-rw-r--r--irc/bitchx/pkg-plist10
9 files changed, 262 insertions, 27 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 11cc9d5aa7c9..c3e8db6d1d60 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -1,30 +1,33 @@
# Created by: Jimbo Bahooli <griffin@blackhole.iceworld.org>
# $FreeBSD$
+#
PORTNAME= BitchX
-PORTVERSION= 1.2
+PORTVERSION= 1.1.0.1
+PORTREVISION= 4
+PORTEPOCH= 1
CATEGORIES+= irc
-DISTNAME= ${PORTNAME}-${PORTNAME}${PORTVERSION}-${GH_COMMIT}
+MASTER_SITES= SF/bitchx/ircii-pana/ircii-pana-1.1
+DISTNAME= ircii-pana-1.1-final
MAINTAINER?= c.petrik.sosa@gmail.com
COMMENT?= Feature-rich scriptable IRC client
-USE_GITHUB= yes
-GH_ACCOUNT= ${PORTNAME}
-GH_PROJECT= ${PORTNAME}1.2
-GH_TAGNAME= master
-GH_COMMIT= a22b86f
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --libdir="${PREFIX}/share"
-USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/BitchX
USE_PERL5= yes
+GNU_CONFIGURE= yes
WANT_GNOME= yes
+USE_GMAKE= yes
DOCSDIR= ${PREFIX}/share/bx/help
PORTDOCS= *
+CONFIGURE_ARGS+=--exec-prefix="${PREFIX}/share" \
+ --bindir="${PREFIX}/bin" \
+ --datadir="${PREFIX}/share" \
+ --libdir="${PREFIX}/share"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
-MAN1= ${PORTNAME}.1
+MAN1= BitchX.1
OPTIONS_DEFINE= ESOUND GNOME IPV6 LATIN PLUGINS SSL XMMS
@@ -64,9 +67,8 @@ PLIST_SUB+= GNOME="@comment " NOGNOME=""
.endif
.if ${PORT_OPTIONS:MPLUGINS}
-PLUGINS= abot acro aim arcfour autocycle blowfish cavlink cdrom \
- encrypt europa fserv hint nap nicklist pkga possum qbx \
- qmail wavplay
+PLUGINS= abot acro arcfour autocycle blowfish cdrom encrypt scan \
+ europa fserv hint nicklist pkga possum qbx qmail wavplay
PLIST_SUB+= PLUGINS=""
.else
PLIST_SUB+= PLUGINS="@comment "
@@ -95,9 +97,9 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MGNOME}
- ${STRIP_CMD} ${PREFIX}/bin/gtkBitchX
+ ${STRIP_CMD} ${PREFIX}/bin/gtkBitchX-1.1-final
.else
- ${STRIP_CMD} ${PREFIX}/bin/BitchX
+ ${STRIP_CMD} ${PREFIX}/bin/BitchX-1.1-final
${STRIP_CMD} ${PREFIX}/bin/scr-bx
.endif
.if ${PORT_OPTIONS:MDOCS}
@@ -105,7 +107,6 @@ post-install:
cd ${WRKSRC}/bitchx-docs && ${COPYTREE_SHARE} . ${DOCSDIR}
.endif
-# Ensure that `@dirrm share/bx' will be appended last (after PORTDOCS stuff)
add-plist-post:
@${ECHO_CMD} "@dirrm share/bx" >> ${TMPPLIST}
.if (${PREFIX} != ${LOCALBASE} && ${PREFIX} != ${LINUXBASE} && ${PREFIX} != "/usr")
diff --git a/irc/bitchx/distinfo b/irc/bitchx/distinfo
index 669b1bfc4859..f84abf14821e 100644
--- a/irc/bitchx/distinfo
+++ b/irc/bitchx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (BitchX-BitchX1.2-a22b86f.tar.gz) = 78868bf79960fdb3cb716f38a90a084aaf9dfd76498e0c7df252ef1e43ca9a08
-SIZE (BitchX-BitchX1.2-a22b86f.tar.gz) = 2555622
+SHA256 (ircii-pana-1.1-final.tar.gz) = 7464cd75a10f2d117a10cf0184e5d4b9ece44de03a226402c17bdd3f2c7eca57
+SIZE (ircii-pana-1.1-final.tar.gz) = 2532476
diff --git a/irc/bitchx/files/patch-amd64_fix b/irc/bitchx/files/patch-amd64_fix
index 51dfe89a9ac7..bd73ca030e38 100644
--- a/irc/bitchx/files/patch-amd64_fix
+++ b/irc/bitchx/files/patch-amd64_fix
@@ -14,6 +14,18 @@ diff -ur BitchX.orig/include/module.h BitchX/include/module.h
#ifdef WANT_DLL
#ifdef HPUX
+diff -ur BitchX.orig/include/modval.h BitchX/include/modval.h
+--- BitchX.orig/include/modval.h Fri Apr 11 03:09:07 2003
++++ include/modval.h Sun Jan 8 17:18:15 2006
+@@ -318,7 +318,7 @@
+ #define show_window(x) ((void) (global[SHOW_WINDOW]((Window *)x)))
+ #define get_status_by_refnum(x, y) ((char *) (global[GET_STATUS_BY_REFNUM]((unsigned int)x, (unsigned int)y)))
+ #define get_visible_by_refnum(x) ((int) (global[GET_VISIBLE_BY_REFNUM]((char *)x)))
+-#define get_window_by_desc(x) ((Window *) (global[GET_WINDOW_BY_DESC]((unsigned int)x)))
++#define get_window_by_desc(x) ((Window *) (global[GET_WINDOW_BY_DESC]((unsigned long)x)))
+ #define get_window_by_refnum(x) ((Window *) (global[GET_WINDOW_BY_REFNUM]((unsigned int)x)))
+ #define get_window_by_name(x) ((Window *) (global[GET_WINDOW_BY_NAME]((char *)x)))
+ #define next_window(x, y) ((void) (global[FUNC_NEXT_WINDOW]((char)x, (char *)y)))
diff -ur BitchX.orig/source/screen.c BitchX/source/screen.c
--- BitchX.orig/source/screen.c Thu Jul 31 09:01:08 2003
+++ source/screen.c Sun Jan 8 17:18:18 2006
diff --git a/irc/bitchx/files/patch-ap b/irc/bitchx/files/patch-ap
new file mode 100644
index 000000000000..1aefc825ee4a
--- /dev/null
+++ b/irc/bitchx/files/patch-ap
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Mar 5 21:30:04 2001
++++ Makefile.in Fri Apr 19 15:09:40 2002
+@@ -115,7 +115,7 @@
+ # This command will be used to install the BitchX help files. If you don't
+ # want to install them, replace with the following:
+ # INSTALL_HELP_CMD = @echo The help files have not been installed.
+-INSTALL_HELP_CMD = @INSTALL_HELP_CMD@
++INSTALL_HELP_CMD = echo
+
+ # This is where the optional plugins will be copied to.
+ PLUGINDIR = @PLUGINDIR@ \ No newline at end of file
diff --git a/irc/bitchx/files/patch-aq b/irc/bitchx/files/patch-aq
index 7c46ba4760f5..226680a1dcf1 100644
--- a/irc/bitchx/files/patch-aq
+++ b/irc/bitchx/files/patch-aq
@@ -9,6 +9,15 @@
/* if you use cidentd the filename is called .authlie instead of .noident.
* as well some modifications to the format of the file were made. So we
+@@ -449,7 +449,7 @@
+ #define DEFAULT_FTP_GRAB OFF
+ #define DEFAULT_HTTP_GRAB OFF
+ #define DEFAULT_HELP_WINDOW OFF
+-#define DEFAULT_NICK_COMPLETION ON
++#define DEFAULT_NICK_COMPLETION OFF
+ #define DEFAULT_NICK_COMPLETION_LEN 2
+ #define DEFAULT_NICK_COMPLETION_TYPE 0 /* 0 1 2 */
+ #define DEFAULT_NOTIFY ON
@@ -480,9 +480,9 @@
#define DEFAULT_AINV 0
#define DEFAULT_ANNOY_KICK OFF
diff --git a/irc/bitchx/files/patch-configure b/irc/bitchx/files/patch-configure
new file mode 100644
index 000000000000..0a2bd8f7aa67
--- /dev/null
+++ b/irc/bitchx/files/patch-configure
@@ -0,0 +1,156 @@
+--- configure.orig 2003-04-10 21:09:04.000000000 -0400
++++ configure 2012-11-18 22:36:48.000000000 -0500
+@@ -11830,100 +11830,27 @@
+ echo $ECHO_N "checking whether to enable IPv6 support... $ECHO_C" >&6
+ # Check whether --enable-ipv6 or --disable-ipv6 was given.
+ if test "${enable_ipv6+set}" = set; then
+- enableval="$enable_ipv6"
+- case "$enableval" in
++ enableval=$enable_ipv6; case "$enableval" in
+ yes)
+- case "$(uname -s)" in
+- Linux)
+- if test -d "/usr/inet6/include"; then
+- CFLAGS="$CFLAGS -I/usr/inet6/include"
+- LIBS="-L/usr/inet6/lib -linet6 $LIBS"
+- echo "$as_me:$LINENO: result: yes (libinet6)" >&5
+-echo "${ECHO_T}yes (libinet6)" >&6
++ { $as_echo "$as_me:$LINENO: result: yes (notchecked)" >&5
++$as_echo "yes (notchecked)" >&6; }
+
+ cat >>confdefs.h <<\_ACEOF
+ #define IPV6 1
+ _ACEOF
+
+- else
+- if test -d "/usr/local/v6/lib"; then
+- LIBS="-L/usr/local/v6/lib -linet6 $LIBS"
+- echo "$as_me:$LINENO: result: yes (freebsd+kame)" >&5
+-echo "${ECHO_T}yes (freebsd+kame)" >&6
+-
+-cat >>confdefs.h <<\_ACEOF
+-#define IPV6 1
+-_ACEOF
+-
+- else
+- if test "$cross_compiling" = yes; then
+- { echo "$as_me:$LINENO: WARNING: cross-compiling: assuming no ipv6" >&5
+-echo "$as_me: WARNING: cross-compiling: assuming no ipv6" >&2;}
++ ;;
++ *)
++ { $as_echo "$as_me:$LINENO: result: no" >&5
++$as_echo "no" >&6; }
++ ;;
++ esac
+ else
+- cat >conftest.$ac_ext <<_ACEOF
+-#line $LINENO "configure"
+-#include "confdefs.h"
+-
+- int main()
+- {
+- #if !defined(__GLIBC__) || (__GLIBC__ < 2)
+- #define NO_GLIBC_2 1
+- #endif
+-
+- if (NO_GLIBC_2)
+- exit(0);
+- else
+- exit(1);
+- }
+-_ACEOF
+-rm -f conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- echo "$as_me:$LINENO: result: yes (glibc2)" >&5
+-echo "${ECHO_T}yes (glibc2)" >&6
++ { $as_echo "$as_me:$LINENO: result: no" >&5
++$as_echo "no" >&6; }
+
+-cat >>confdefs.h <<\_ACEOF
+-#define IPV6 1
+-_ACEOF
+-
+-
+-else
+- echo "$as_me: program exited with status $ac_status" >&5
+-echo "$as_me: failed program was:" >&5
+-cat conftest.$ac_ext >&5
+-( exit $ac_status )
+-echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-fi
+-rm -f core core.* *.core conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
+ fi
+- fi
+- fi
+- ;;
+- *)
+- echo "$as_me:$LINENO: result: no (ipv6 support can currently be enabled on Linux only)" >&5
+-echo "${ECHO_T}no (ipv6 support can currently be enabled on Linux only)" >&6
+- ;;
+- esac
+- ;;
+- no)
+- echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+- ;;
+- esac
+-else
+- echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+
+-fi;
+
+ echo "$as_me:$LINENO: checking whether to enable SOCKS support" >&5
+ echo $ECHO_N "checking whether to enable SOCKS support... $ECHO_C" >&6
+@@ -12609,7 +12536,7 @@
+ system="unknown"
+ else
+ if test -r "/etc/.relid" -a x"`uname -n`" = x"`uname -s`"; then
+- system="MP-RAS-`$AWK '{print }' /etc/.relid'`"
++ system="MP-RAS-`$AWK '{print $3}' /etc/.relid`"
+ fi
+ fi
+ fi
+@@ -12658,11 +12585,6 @@
+ SHLIB_LD="ld -shared"
+ fi
+ ;;
+- FreeBSD-1*)
+- { { echo "$as_me:$LINENO: error: sorry" >&5
+-echo "$as_me: error: sorry" >&2;}
+- { (exit no plugins on $ac_cv_system_version); exit no plugins on $ac_cv_system_version; }; }
+- ;;
+ FreeBSD-2.2*)
+ SHLIB_LD="ld -Bshareable"
+ ;;
+@@ -13877,7 +13799,7 @@
+ system="unknown"
+ else
+ if test -r "/etc/.relid" -a x"`uname -n`" = x"`uname -s`"; then
+- system="MP-RAS-`$AWK '{print }' /etc/.relid'`"
++ system="MP-RAS-`$AWK '{print $3}' /etc/.relid`"
+ fi
+ fi
+ fi
+@@ -13926,11 +13848,6 @@
+ SHLIB_LD="ld -shared"
+ fi
+ ;;
+- FreeBSD-1*)
+- { { echo "$as_me:$LINENO: error: sorry" >&5
+-echo "$as_me: error: sorry" >&2;}
+- { (exit no plugins on $ac_cv_system_version); exit no plugins on $ac_cv_system_version; }; }
+- ;;
+ FreeBSD-2.2*)
+ SHLIB_LD="ld -Bshareable"
+ ;;
diff --git a/irc/bitchx/files/patch-source_gcc_fix b/irc/bitchx/files/patch-source_gcc_fix
new file mode 100644
index 000000000000..ba36272ccf1d
--- /dev/null
+++ b/irc/bitchx/files/patch-source_gcc_fix
@@ -0,0 +1,36 @@
+diff -ru source.orig/ctcp.c source/ctcp.c
+--- source.orig/ctcp.c 2003-05-26 23:00:22.000000000 -0800
++++ source/ctcp.c 2008-01-28 07:31:56.000000000 -0900
+@@ -176,7 +176,7 @@
+
+ /* CDE do ops and unban logging */
+
+-static char *ctcp_type[] =
++char *ctcp_type[] =
+ {
+ "PRIVMSG",
+ "NOTICE"
+diff -ru source.orig/term.c source/term.c
+--- source.orig/term.c 2003-04-10 17:09:07.000000000 -0800
++++ source/term.c 2008-01-28 07:58:45.000000000 -0900
+@@ -92,7 +92,7 @@
+ #endif
+
+ extern char *getenv();
+-extern char *tparm();
++
+
+ /*
+ * The old code assumed termcap. termcap is almost always present, but on
+diff -ru source.orig/timer.c source/timer.c
+--- source.orig/timer.c 2003-04-10 17:09:07.000000000 -0800
++++ source/timer.c 2008-01-28 08:00:29.000000000 -0900
+@@ -148,7 +148,7 @@
+ * This is put here on purpose -- we dont want any of the above functions
+ * to have any knowledge of this struct.
+ */
+-static TimerList *PendingTimers;
++TimerList *PendingTimers;
+ static char *schedule_timer (TimerList *ntimer);
+
+ static char *current_exec_timer = empty_string;
diff --git a/irc/bitchx/files/patch-source_server_c b/irc/bitchx/files/patch-source_server_c
new file mode 100644
index 000000000000..5910cca38940
--- /dev/null
+++ b/irc/bitchx/files/patch-source_server_c
@@ -0,0 +1,12 @@
+$OpenBSD: patch-source_server_c,v 1.1 2003/04/16 09:04:24 avsm Exp $
+--- source/server.c.orig Mon Apr 14 23:56:28 2003
++++ source/server.c Mon Apr 14 23:56:59 2003
+@@ -144,7 +144,7 @@ void close_server (int cs_index, char *m
+ if (x_debug & DEBUG_OUTBOUND)
+ yell("Closing server %d because [%s]",
+ cs_index, message ? message : empty_string);
+- snprintf(buffer, BIG_BUFFER_SIZE, "QUIT :%s\n", message);
++ snprintf(buffer, sizeof buffer, "QUIT :%s\n", message);
+ #ifdef HAVE_SSL
+ if (get_server_ssl(cs_index))
+ SSL_write(server_list[cs_index].ssl_fd, buffer, strlen(buffer));
diff --git a/irc/bitchx/pkg-plist b/irc/bitchx/pkg-plist
index f0e3b8fbf2dd..4c28fc9f98ba 100644
--- a/irc/bitchx/pkg-plist
+++ b/irc/bitchx/pkg-plist
@@ -1,8 +1,8 @@
@unexec if [ -f %D/share/bx/script/bxglobal.old ]; then rm -f %D/share/bx/script/bxglobal.old; fi
%%NOGNOME%%bin/BitchX
-%%NOGNOME%%bin/BitchX-1.2c01-svn
+%%NOGNOME%%bin/BitchX-1.1-final
%%GNOME%%bin/gtkBitchX
-%%GNOME%%bin/gtkBitchX-1.2c01-svn
+%%GNOME%%bin/gtkBitchX-1.1-final
%%NOGNOME%%bin/scr-bx
share/bx/BitchX.help
share/bx/BitchX.ircnames
@@ -18,14 +18,12 @@ share/bx/BitchX.kick
%%PLUGINS%%share/bx/plugins/pkga.so
%%PLUGINS%%share/bx/plugins/possum.so
%%PLUGINS%%share/bx/plugins/qmail.so
+%%PLUGINS%%share/bx/plugins/scan.so
%%PLUGINS%%share/bx/plugins/wavplay.so
%%PLUGINS%%share/bx/plugins/qbx.so
%%PLUGINS%%share/bx/plugins/arcfour.so
%%PLUGINS%%share/bx/plugins/autocycle.so
-%%PLUGINS%%share/bx/plugins/aim.so
-%%PLUGINS%%share/bx/plugins/cavlink.so
%%PLUGINS%%share/bx/plugins/cdrom.so
-%%PLUGINS%%share/bx/plugins/nap.so
%%PLUGINS%%share/bx/plugins/nicklist.so
%%XMMS%%share/bx/plugins/xmms.so
share/bx/script/SCRIPTS
@@ -81,4 +79,4 @@ share/bx/translation/UNITED_KINGDOM_COM
@dirrm share/bx/translation
@dirrm share/bx/script
@dirrm share/bx/plugins
-@comment "@dirrm share/bx" must be appended after PORTDOCS stuff, see Makefile
+@dirrm share/bx