aboutsummaryrefslogtreecommitdiff
path: root/irc/bitlbee-otr/Makefile
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@FreeBSD.org>2008-03-18 20:37:15 +0000
committerHenrik Brix Andersen <brix@FreeBSD.org>2008-03-18 20:37:15 +0000
commit82d81e1f2f5dbbdd72417c96bc753754ae49da36 (patch)
treefedb669b2b49278bb3213ea16df4dc5e5c344426 /irc/bitlbee-otr/Makefile
parente50e297a5ab2f663dd9ecac773fb7f4fb60001fe (diff)
downloadports-82d81e1f2f5dbbdd72417c96bc753754ae49da36.tar.gz
ports-82d81e1f2f5dbbdd72417c96bc753754ae49da36.zip
Notes
Diffstat (limited to 'irc/bitlbee-otr/Makefile')
-rw-r--r--irc/bitlbee-otr/Makefile26
1 files changed, 6 insertions, 20 deletions
diff --git a/irc/bitlbee-otr/Makefile b/irc/bitlbee-otr/Makefile
index 1f132e8725a3..dedf983c49ff 100644
--- a/irc/bitlbee-otr/Makefile
+++ b/irc/bitlbee-otr/Makefile
@@ -6,13 +6,10 @@
#
PORTNAME= bitlbee
-PORTVERSION= 1.0.4
-PORTREVISION= 2
+PORTVERSION= 1.2
CATEGORIES= irc
MASTER_SITES= http://get.bitlbee.org/src/
-PATCH_SITES= http://get.bitlbee.org/patches/
-
MAINTAINER= brix@FreeBSD.org
COMMENT= An IRC to other chat networks gateway
@@ -30,20 +27,14 @@ USE_RC_SUBR= bitlbee
PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= MSN "Enable MSN protocol support" On \
- LDAP "Enable LDAP authentication support" Off \
- RECODE "Enable oscar_recode_charset" Off \
DEBUG "Create debuggable binary" Off \
OPENSSL "Use openssl rather than gnutls" Off \
IPV6 "Compile IPV6 support" On
-CONFIGURE_ARGS= --config=/var/db/bitlbee
+CONFIGURE_ARGS= --config=/var/db/bitlbee --strip=0
.include <bsd.port.pre.mk>
-.if defined(WITH_LDAP)
-PATCHFILES+= ${PORTNAME}-1.0-ldap.diff
-.endif
-
.if !defined(WITHOUT_MSN)
CONFIGURE_ARGS+=--msn=1
.else
@@ -57,15 +48,6 @@ CONFIGURE_ARGS+=--ssl=gnutls
LIB_DEPENDS+= gnutls.26:${PORTSDIR}/security/gnutls
.endif
-.if defined(WITH_LDAP)
-USE_OPENLDAP= yes
-CONFIGURE_ARGS+=--ldap=${LOCALBASE}
-.endif
-
-.if defined(WITH_RECODE)
-EXTRA_PATCHES+= ${FILESDIR}/oscar-recode-patch
-.endif
-
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=--debug=1
.endif
@@ -76,6 +58,10 @@ CONFIGURE_ARGS+=--ipv6=0
post-patch:
@${REINPLACE_CMD} \
+ -e "s:^EFLAGS=:EFLAGS=${LDFLAGS}:" \
+ ${WRKSRC}/configure
+
+ @${REINPLACE_CMD} \
-e "s:/etc/bitlbee/motd.txt:${PREFIX}/etc/bitlbee/motd.txt:" \
-e "s:/var/lib/bitlbee:/var/db/bitlbee:" \
${WRKSRC}/bitlbee.conf