aboutsummaryrefslogtreecommitdiff
path: root/irc/bitlbee/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-12-12 14:48:05 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-12-12 14:48:05 +0000
commit147fc77aff6b3e82ddabd69242001f6bdc637393 (patch)
treeca40ef3cab3127118e55e918d3ac9393ef65d43a /irc/bitlbee/Makefile
parenta110ceccb6250278492b07c7923df8d241821425 (diff)
- upgrade 0.74a to 0.82
- add WITH_MSN to decide if want MSN support - add pkg-message to notice installed config files PR: 58798 Submitted by: Cheng-Lung Sung <clsung@dragon2.net> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=95667
Diffstat (limited to 'irc/bitlbee/Makefile')
-rw-r--r--irc/bitlbee/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/irc/bitlbee/Makefile b/irc/bitlbee/Makefile
index a3d1c70d0134..8c73da40d050 100644
--- a/irc/bitlbee/Makefile
+++ b/irc/bitlbee/Makefile
@@ -6,22 +6,36 @@
#
PORTNAME= bitlbee
-PORTVERSION= 0.74a
+PORTVERSION= 0.82
PORTREVISION= 0
CATEGORIES= irc
-MASTER_SITES= http://www.lintux.cx/downloads/
+MASTER_SITES= http://get.bitlbee.org/src/
MAINTAINER= peter@dataloss.nl
COMMENT= An IRC to other chat networks gateway
MAN8= bitlbee.8
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${PREFIX}/man --config=${PREFIX}/etc/bitlbee
USE_GMAKE= yes
-USE_GNOME= glib12
+USE_GNOME= glib20
+
+.if defined(WITH_MSN)
+LIB_DEPENDS= soup-2.0.0:${PORTSDIR}/devel/libsoup
+pre-configure:
+ @${ECHO_CMD} "MSN support will be enabled."
+.else
+pre-configure:
+ @${ECHO_CMD} "Type \"make -DWITH_MSN\" if you want enable MSN support."
+.endif
pre-install:
@mkdir -p -m 700 ${PREFIX}/etc/bitlbee
+post-install:
+ @cp ${WRKSRC}/bitlbee.conf ${PREFIX}/etc/bitlbee/bitlbee.conf.orig
+ @cp ${WRKSRC}/motd.txt ${PREFIX}/etc/bitlbee/motd.txt.orig
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>