aboutsummaryrefslogtreecommitdiff
path: root/irc/bitlbee
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2015-07-20 20:26:40 +0000
committerRenato Botelho <garga@FreeBSD.org>2015-07-20 20:26:40 +0000
commitf63770ebcab8e5038ff4d3dd7a81ba228fea8157 (patch)
tree0acd7d661746111c0592459b4c3b32ea14475665 /irc/bitlbee
parentaeb2a6d99388ac899554af8a65d64532de4f8d94 (diff)
downloadports-f63770ebcab8e5038ff4d3dd7a81ba228fea8157.tar.gz
ports-f63770ebcab8e5038ff4d3dd7a81ba228fea8157.zip
Notes
Diffstat (limited to 'irc/bitlbee')
-rw-r--r--irc/bitlbee/Makefile1
-rw-r--r--irc/bitlbee/files/patch-irc__channel.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/irc/bitlbee/Makefile b/irc/bitlbee/Makefile
index a894369c08cc..883681b80563 100644
--- a/irc/bitlbee/Makefile
+++ b/irc/bitlbee/Makefile
@@ -2,6 +2,7 @@
PORTNAME= bitlbee
PORTVERSION= 3.4.1
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://get.bitlbee.org/src/ \
LOCAL/brix
diff --git a/irc/bitlbee/files/patch-irc__channel.c b/irc/bitlbee/files/patch-irc__channel.c
new file mode 100644
index 000000000000..46e1c9495480
--- /dev/null
+++ b/irc/bitlbee/files/patch-irc__channel.c
@@ -0,0 +1,11 @@
+--- irc_channel.c.orig 2015-07-20 20:09:00 UTC
++++ irc_channel.c
+@@ -444,7 +444,7 @@ void irc_channel_auto_joins(irc_t *irc,
+ can only auto-join them if their account is online. */
+ char *acc_s;
+
+- if (!aj || (ic->flags & IRC_CHANNEL_JOINED)) {
++ if (!aj && !(ic->flags & IRC_CHANNEL_JOINED)) {
+ /* Only continue if this one's marked as auto_join
+ or if we're in it already. (Possible if the
+ client auto-rejoined it before identyfing.) */