aboutsummaryrefslogtreecommitdiff
path: root/irc/bobot++
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-02 03:58:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-02 03:58:31 +0000
commit7b6353c912b6f548ee3f9bb45e7aff9089a1e8a8 (patch)
treed5128e14e8d066d3f1f83bcb958951c24ef7ed7e /irc/bobot++
parentfe8309d7fd15ad476dac9606b0f078110e7f82bc (diff)
downloadports-7b6353c912b6f548ee3f9bb45e7aff9089a1e8a8.tar.gz
ports-7b6353c912b6f548ee3f9bb45e7aff9089a1e8a8.zip
Notes
Diffstat (limited to 'irc/bobot++')
-rw-r--r--irc/bobot++/Makefile29
-rw-r--r--irc/bobot++/distinfo2
-rw-r--r--irc/bobot++/files/patch-configure13
-rw-r--r--irc/bobot++/files/patch-source::ChannelList.C11
-rw-r--r--irc/bobot++/files/patch-source::Makefile.in13
-rw-r--r--irc/bobot++/files/patch-source::ServerList.C11
-rw-r--r--irc/bobot++/files/patch-source::TodoList.H11
-rw-r--r--irc/bobot++/pkg-descr2
-rw-r--r--irc/bobot++/pkg-plist47
9 files changed, 44 insertions, 95 deletions
diff --git a/irc/bobot++/Makefile b/irc/bobot++/Makefile
index 7e4f3241355a..77c495ba52b4 100644
--- a/irc/bobot++/Makefile
+++ b/irc/bobot++/Makefile
@@ -7,42 +7,41 @@
#
PORTNAME= bobot++
-PORTVERSION= 1.97
+PORTVERSION= 1.99.2
CATEGORIES= irc
-MASTER_SITES= http://pltplp.net/bobot++/archive/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://savannah.nongnu.org/download/bobotpp/stable.pkg/${PORTVERSION}/
+DISTNAME= Bobot++-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An IRC bot written in C++
GNU_CONFIGURE= yes
-USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
-.if defined(WITH_GUILE)
+.if defined(WITHOUT_GUILE)
+CONFIGURE_ARGS+= --disable-script
+.else
LIB_DEPENDS+= guile:${PORTSDIR}/lang/guile
-GUILE_CONFIG= ${LOCALBASE}/bin/guile-config
CONFIGURE_ARGS+= --enable-script
.endif
.if defined(WITH_TELNET)
CONFIGURE_ARGS+= --enable-telnetserver
+.else
+CONFIGURE_ARGS+= --disable-telnetserver
.endif
-post-patch:
- @${REINPLACE_CMD} -e "s,%%GUILE_CONFIG%%,${GUILE_CONFIG},g ; \
- s,%%PTHREAD_CFLAGS%%,${PTHREAD_CFLAGS},g ; \
- s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS},g" ${WRKSRC}/configure
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bobot++ ${PREFIX}/bin
+post-extract:
+ @${FIND} ${WRKSRC}/scripts -name "*~" -delete
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
${CP} ${WRKSRC}/doc/* ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
@${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/examples ${DATADIR}
${CP} -R ${WRKSRC}/scripts ${DATADIR}
.endif
diff --git a/irc/bobot++/distinfo b/irc/bobot++/distinfo
index b185fe56b154..366e99e755ab 100644
--- a/irc/bobot++/distinfo
+++ b/irc/bobot++/distinfo
@@ -1 +1 @@
-MD5 (bobot++.1.97.tgz) = e41c1927ff13cdf77e5386de7fba6270
+MD5 (Bobot++-1.99.2.tar.gz) = 41c87d61d34c07430318c5c7436585bd
diff --git a/irc/bobot++/files/patch-configure b/irc/bobot++/files/patch-configure
deleted file mode 100644
index 7c736fac64c7..000000000000
--- a/irc/bobot++/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.orig Fri Sep 7 21:52:05 2001
-+++ configure Fri Sep 7 21:53:18 2001
-@@ -545,8 +545,8 @@
- enableval="$enable_script"
-
- if test $enableval = "yes"; then
-- GUILE_DEFINES="-DUSESCRIPTS -DMULTITHREAD"
-- GUILE_LIBS="-lguile"
-+ GUILE_DEFINES="-DUSESCRIPTS -DMULTITHREAD `%%GUILE_CONFIG%% compile` %%PTHREAD_CFLAGS%%"
-+ GUILE_LIBS="-lguile `%%GUILE_CONFIG%% link` %%PTHREAD_LIBS%%"
- GUILE_SOURCES="BotInterp.C Interp.C ScriptCommands.C"
- GUILE_INCLUDES="BotInterp.H Interp.H ScriptCommands.H"
- fi
diff --git a/irc/bobot++/files/patch-source::ChannelList.C b/irc/bobot++/files/patch-source::ChannelList.C
deleted file mode 100644
index b472aaecb8d9..000000000000
--- a/irc/bobot++/files/patch-source::ChannelList.C
+++ /dev/null
@@ -1,11 +0,0 @@
---- source/ChannelList.C.orig Sat Nov 23 21:40:56 2002
-+++ source/ChannelList.C Sat Nov 23 21:41:04 2002
-@@ -41,7 +41,7 @@
- }
-
- void
--ChannelList::addChannel(ServerConnection *cnx, String name, String wantedModes = "")
-+ChannelList::addChannel(ServerConnection *cnx, String name, String wantedModes)
- {
- name = name.toLower();
- list[name] = new Channel(cnx, name, wantedModes);
diff --git a/irc/bobot++/files/patch-source::Makefile.in b/irc/bobot++/files/patch-source::Makefile.in
deleted file mode 100644
index ff59337842f5..000000000000
--- a/irc/bobot++/files/patch-source::Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- source/Makefile.in.orig Fri Sep 7 21:53:43 2001
-+++ source/Makefile.in Fri Sep 7 21:53:51 2001
-@@ -4,8 +4,8 @@
- DEFINES=@HAVE_STL_CLEAR@ @DISABLE_CRYPT@ @GUILE_DEFINES@ @TSERVER_DEFINES@
-
- RM=rm -f
--CXX=@CXX@ -g
--CXXFLAGS=$(DEFINES)
-+CXX=@CXX@
-+CXXFLAGS+=$(DEFINES)
- LDFLAGS=@LDFLAGS@ @GUILE_LIBS@
-
- SOURCES=BanEntry.C \
diff --git a/irc/bobot++/files/patch-source::ServerList.C b/irc/bobot++/files/patch-source::ServerList.C
deleted file mode 100644
index d710d24d1e83..000000000000
--- a/irc/bobot++/files/patch-source::ServerList.C
+++ /dev/null
@@ -1,11 +0,0 @@
---- source/ServerList.C.orig Sat Nov 23 21:47:22 2002
-+++ source/ServerList.C Sat Nov 23 21:47:47 2002
-@@ -40,7 +40,7 @@
- void
- ServerList::delServer(int n)
- {
-- v.erase(&v[n]);
-+ v.erase(v.begin() + n);
- }
-
- Server *
diff --git a/irc/bobot++/files/patch-source::TodoList.H b/irc/bobot++/files/patch-source::TodoList.H
deleted file mode 100644
index a462a4df9a2d..000000000000
--- a/irc/bobot++/files/patch-source::TodoList.H
+++ /dev/null
@@ -1,11 +0,0 @@
---- source/TodoList.H.orig Sat Nov 23 21:55:46 2002
-+++ source/TodoList.H Sat Nov 23 22:07:57 2002
-@@ -23,6 +23,8 @@
-
- #include "String.H"
-
-+using namespace std;
-+
- class TodoList;
-
- class TodoListItem {
diff --git a/irc/bobot++/pkg-descr b/irc/bobot++/pkg-descr
index cfee0bd26198..df8bab90d98d 100644
--- a/irc/bobot++/pkg-descr
+++ b/irc/bobot++/pkg-descr
@@ -1,3 +1,3 @@
The bobot++ is an IRC bot written in C++.
-WWW: http://pltplp.net/bobot++/
+WWW: http://unknownlamer.org/code/bobot.html
diff --git a/irc/bobot++/pkg-plist b/irc/bobot++/pkg-plist
index fe339a6a0f0e..032108556e09 100644
--- a/irc/bobot++/pkg-plist
+++ b/irc/bobot++/pkg-plist
@@ -1,19 +1,28 @@
-bin/bobot++
-%%PORTDOCS%%share/doc/bobot++/index.html
-%%PORTDOCS%%share/bobot++/examples/bot.log
-%%PORTDOCS%%share/bobot++/examples/bot.help
-%%PORTDOCS%%share/bobot++/examples/bot.init
-%%PORTDOCS%%share/bobot++/examples/bot.conf
-%%PORTDOCS%%share/bobot++/examples/bot.shit
-%%PORTDOCS%%share/bobot++/examples/bot.users
-%%PORTDOCS%%share/bobot++/examples/bot.autoexec
-%%PORTDOCS%%share/bobot++/scripts/country
-%%PORTDOCS%%share/bobot++/scripts/hello
-%%PORTDOCS%%share/bobot++/scripts/tamere
-%%PORTDOCS%%share/bobot++/scripts/uname
-%%PORTDOCS%%share/bobot++/scripts/uptime
-%%PORTDOCS%%share/bobot++/scripts/boulet
-%%PORTDOCS%%@dirrm share/doc/bobot++
-%%PORTDOCS%%@dirrm share/bobot++/examples
-%%PORTDOCS%%@dirrm share/bobot++/scripts
-%%PORTDOCS%%@dirrm share/bobot++
+bin/bobotpp
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%EXAMPLESDIR%%/bot.log
+%%PORTDOCS%%%%EXAMPLESDIR%%/bot.help
+%%PORTDOCS%%%%EXAMPLESDIR%%/bot.init
+%%PORTDOCS%%%%EXAMPLESDIR%%/bot.conf
+%%PORTDOCS%%%%EXAMPLESDIR%%/bot.shit
+%%PORTDOCS%%%%EXAMPLESDIR%%/bot.users
+%%PORTDOCS%%%%EXAMPLESDIR%%/bot.autoexec
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DATADIR%%/scripts/bobot-utils.scm
+%%PORTDOCS%%%%DATADIR%%/scripts/boulet
+%%PORTDOCS%%%%DATADIR%%/scripts/country
+%%PORTDOCS%%%%DATADIR%%/scripts/eval
+%%PORTDOCS%%%%DATADIR%%/scripts/hello
+%%PORTDOCS%%%%DATADIR%%/scripts/scheme_add_user
+%%PORTDOCS%%%%DATADIR%%/scripts/scripts.load
+%%PORTDOCS%%%%DATADIR%%/scripts/stupid_stuff/insert_saying.scm
+%%PORTDOCS%%%%DATADIR%%/scripts/stupid_stuff/sayings
+%%PORTDOCS%%%%DATADIR%%/scripts/stupid_stuff/sayings.sh
+%%PORTDOCS%%%%DATADIR%%/scripts/stupid_stuff/stupid_stuff
+%%PORTDOCS%%%%DATADIR%%/scripts/tamere
+%%PORTDOCS%%%%DATADIR%%/scripts/uname
+%%PORTDOCS%%%%DATADIR%%/scripts/uptime
+%%PORTDOCS%%@dirrm %%DATADIR%%/scripts/stupid_stuff
+%%PORTDOCS%%@dirrm %%DATADIR%%/scripts
+%%PORTDOCS%%@dirrm %%DATADIR%%