aboutsummaryrefslogtreecommitdiff
path: root/irc/bobot++
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-08 15:54:13 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-08 15:54:13 +0000
commit2ba0668986cf6c7b94c7bf78e5be54ca183e0024 (patch)
tree06a0a90be7fff0c16395741093d2bc4d9456c02e /irc/bobot++
parentab8eccd2488df1fab1a636e293d096bea0f276fd (diff)
downloadports-2ba0668986cf6c7b94c7bf78e5be54ca183e0024.tar.gz
ports-2ba0668986cf6c7b94c7bf78e5be54ca183e0024.zip
Notes
Diffstat (limited to 'irc/bobot++')
-rw-r--r--irc/bobot++/Makefile53
-rw-r--r--irc/bobot++/distinfo4
-rw-r--r--irc/bobot++/files/patch-documentation__bobot++.texinfo12
-rw-r--r--irc/bobot++/files/patch-source_Parser.C13
-rw-r--r--irc/bobot++/pkg-plist28
5 files changed, 47 insertions, 63 deletions
diff --git a/irc/bobot++/Makefile b/irc/bobot++/Makefile
index 4869e098511a..30002e1fb571 100644
--- a/irc/bobot++/Makefile
+++ b/irc/bobot++/Makefile
@@ -7,43 +7,56 @@
#
PORTNAME= bobotpp
-PORTVERSION= 2.0.2
-PORTREVISION= 5
+PORTVERSION= 2.2.3
CATEGORIES= irc
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= bobotpp
+MASTER_SITES= SAVANNAH
MAINTAINER= ports@FreeBSD.org
COMMENT= An IRC bot written in C++
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
+OPTIONS= GUILE "Use Guile scripts" on
+
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
+
+INFO= bobot++
+PORTDOCS= *
+PORTEXAMPLES= *
+PLIST_FILES= bin/${PORTNAME}
+
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.include <bsd.port.pre.mk>
.if defined(WITHOUT_GUILE)
CONFIGURE_ARGS+= --disable-scripting
.else
LIB_DEPENDS+= guile.21:${PORTSDIR}/lang/guile
CONFIGURE_ARGS+= --enable-scripting
+PLIST_FILES+= share/guile/site/bobotpp/bot.scm \
+ %%DATADIR%%/scripts/bobot-utils.scm
+PLIST_DIRS+= %%DATADIR%%/scripts \
+ %%DATADIR%% \
+ share/guile/site/bobotpp
+PLIST_DIRSTRY+= share/guile/site
.endif
-.if defined(WITH_TELNET)
-CONFIGURE_ARGS+= --enable-telnetserver
-.else
-CONFIGURE_ARGS+= --disable-telnetserver
-.endif
-
-post-extract:
- @${FIND} ${WRKSRC}/scripts -name "*~" -delete
+post-patch:
+ @${REINPLACE_CMD} -e '/test/s|==|=|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|std::snprintf|snprintf|g' ${WRKSRC}/source/Bot.C
-.if !defined(NOPORTDOCS)
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${CP} ${WRKSRC}/doc/* ${DOCSDIR}
+ @(cd ${WRKSRC}/documentation && ${INSTALL_DATA} *.html ${DOCSDIR})
+.endif
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
- @${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/scripts ${DATADIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/irc/bobot++/distinfo b/irc/bobot++/distinfo
index cb8c22364630..390c7012a28f 100644
--- a/irc/bobot++/distinfo
+++ b/irc/bobot++/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bobotpp-2.0.2.tar.gz) = 60a21ef0486870aabdd63b79bc21ae3e4a55c2064c973e5ed84dbb64eacb6801
-SIZE (bobotpp-2.0.2.tar.gz) = 154007
+SHA256 (bobotpp-2.2.3.tar.gz) = b45e84529b4417d31686e355951e0d4ceb7f0bb470f5c6498adb530f50a6d908
+SIZE (bobotpp-2.2.3.tar.gz) = 301675
diff --git a/irc/bobot++/files/patch-documentation__bobot++.texinfo b/irc/bobot++/files/patch-documentation__bobot++.texinfo
new file mode 100644
index 000000000000..eb01d874ca1e
--- /dev/null
+++ b/irc/bobot++/files/patch-documentation__bobot++.texinfo
@@ -0,0 +1,12 @@
+--- documentation/bobot++.texinfo.orig 2008-11-13 09:51:42.000000000 +0900
++++ documentation/bobot++.texinfo 2011-03-21 12:50:48.000000000 +0900
+@@ -1,6 +1,9 @@
+ \input texinfo @c -*- texinfo -*-
+ @c %**start of header
+ @setfilename bobot++.info
++@direntry
++* Bobot++: (bobot++). A Schemeable IRC Bot.
++@end direntry
+ @settitle Bobot++: A Schemeable IRC Bot
+ @setchapternewpage on
+ @c %**end of header
diff --git a/irc/bobot++/files/patch-source_Parser.C b/irc/bobot++/files/patch-source_Parser.C
deleted file mode 100644
index 968fe9e344b2..000000000000
--- a/irc/bobot++/files/patch-source_Parser.C
+++ /dev/null
@@ -1,13 +0,0 @@
---- source/Parser.C.orig 2008-03-01 18:34:26.000000000 -0500
-+++ source/Parser.C 2008-03-01 18:34:45.000000000 -0500
-@@ -991,8 +991,8 @@ Parser::parseScriptFunction(ServerConnec
- wd.func = scmFunc;
- wd.args = args_list;
-
-- gh_catch(SCM_BOOL_T, (scm_catch_body_t) scm_apply_wrapper,
-- (void *)&wd, (scm_catch_handler_t) Interp::ErrorHandler,
-+ gh_catch(SCM_BOOL_T, (scm_t_catch_body) scm_apply_wrapper,
-+ (void *)&wd, (scm_t_catch_handler) Interp::ErrorHandler,
- 0);
- }
- #endif
diff --git a/irc/bobot++/pkg-plist b/irc/bobot++/pkg-plist
deleted file mode 100644
index 032108556e09..000000000000
--- a/irc/bobot++/pkg-plist
+++ /dev/null
@@ -1,28 +0,0 @@
-bin/bobotpp
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%%%EXAMPLESDIR%%/bot.log
-%%PORTDOCS%%%%EXAMPLESDIR%%/bot.help
-%%PORTDOCS%%%%EXAMPLESDIR%%/bot.init
-%%PORTDOCS%%%%EXAMPLESDIR%%/bot.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/bot.shit
-%%PORTDOCS%%%%EXAMPLESDIR%%/bot.users
-%%PORTDOCS%%%%EXAMPLESDIR%%/bot.autoexec
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%%%DATADIR%%/scripts/bobot-utils.scm
-%%PORTDOCS%%%%DATADIR%%/scripts/boulet
-%%PORTDOCS%%%%DATADIR%%/scripts/country
-%%PORTDOCS%%%%DATADIR%%/scripts/eval
-%%PORTDOCS%%%%DATADIR%%/scripts/hello
-%%PORTDOCS%%%%DATADIR%%/scripts/scheme_add_user
-%%PORTDOCS%%%%DATADIR%%/scripts/scripts.load
-%%PORTDOCS%%%%DATADIR%%/scripts/stupid_stuff/insert_saying.scm
-%%PORTDOCS%%%%DATADIR%%/scripts/stupid_stuff/sayings
-%%PORTDOCS%%%%DATADIR%%/scripts/stupid_stuff/sayings.sh
-%%PORTDOCS%%%%DATADIR%%/scripts/stupid_stuff/stupid_stuff
-%%PORTDOCS%%%%DATADIR%%/scripts/tamere
-%%PORTDOCS%%%%DATADIR%%/scripts/uname
-%%PORTDOCS%%%%DATADIR%%/scripts/uptime
-%%PORTDOCS%%@dirrm %%DATADIR%%/scripts/stupid_stuff
-%%PORTDOCS%%@dirrm %%DATADIR%%/scripts
-%%PORTDOCS%%@dirrm %%DATADIR%%