aboutsummaryrefslogtreecommitdiff
path: root/irc/darkbot
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-11-16 19:58:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-11-16 19:58:06 +0000
commit29c52e72133665411c43dcd1a195357b1425db45 (patch)
treee599d3de21af7d2cbd1769ea6dbb1fffc94bceda /irc/darkbot
parent682e8c87e36e8dd533036cf047be5c7efe54201e (diff)
downloadports-29c52e72133665411c43dcd1a195357b1425db45.tar.gz
ports-29c52e72133665411c43dcd1a195357b1425db45.zip
Notes
Diffstat (limited to 'irc/darkbot')
-rw-r--r--irc/darkbot/Makefile8
-rw-r--r--irc/darkbot/files/patch-darkbot.c29
2 files changed, 30 insertions, 7 deletions
diff --git a/irc/darkbot/Makefile b/irc/darkbot/Makefile
index 21bf8d6e4502..084e376304a2 100644
--- a/irc/darkbot/Makefile
+++ b/irc/darkbot/Makefile
@@ -24,13 +24,7 @@ MANCOMPRESSED= yes
GNU_CONFIGURE= yes
IS_INTERACTIVE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
pre-install:
${CAT} ${MASTERDIR}/pkg-plist | ${SED} -e "s,/usr/local,${LOCALBASE},g" > ${PLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/darkbot/files/patch-darkbot.c b/irc/darkbot/files/patch-darkbot.c
new file mode 100644
index 000000000000..f858678844f3
--- /dev/null
+++ b/irc/darkbot/files/patch-darkbot.c
@@ -0,0 +1,29 @@
+--- darkbot.c.orig Tue Oct 28 15:22:21 2003
++++ darkbot.c Tue Oct 28 15:22:21 2003
+@@ -3476,8 +3476,7 @@
+ strlwr (s2);
+ if (*s2 == '~') {
+ S
+- ("PRIVMSG %s :%s, rdb files can only be called from the data of a topic, they cannot be used in the
+- topic itself.\n",
++ ("PRIVMSG %s :%s, rdb files can only be called from the data of a topic, they cannot be used in the topic itself.\n",
+ target, source);
+ R;
+ }
+@@ -5026,14 +5025,12 @@
+ #else
+ if (pre_CLIENTS == 0 || pre_CLIENTS == L_CLIENTS) {
+ S
+- ("PRIVMSG %s :\1ACTION \37(\37%2d servers\37)\37: %2d opers + \2%4d\2 users \37(\37%s%% %5d global \2!\2 %3
+-ld avg\37)\37\1\n",
++ ("PRIVMSG %s :\1ACTION \37(\37%2d servers\37)\37: %2d opers + \2%4d\2 users \37(\37%s%% %5d global \2!\2 %3ld avg\37)\37\1\n",
+ CHAN, NUM_SERV, IRCOPS, L_CLIENTS, tmp,
+ G_USERS, G_USERS / NUM_SERV);}
+ else
+ S
+- ("PRIVMSG %s :\1ACTION \37(\37%2d servers\37)\37: %2d opers + \2%4d\2 users [\37%c%2d\37] \37(\37%s%% %5d g
+-lobal \2!\2 %3ld avg\37)\37\1\n",
++ ("PRIVMSG %s :\1ACTION \37(\37%2d servers\37)\37: %2d opers + \2%4d\2 users [\37%c%2d\37] \37(\37%s%% %5d global \2!\2 %3ld avg\37)\37\1\n",
+ CHAN, NUM_SERV, IRCOPS, L_CLIENTS,
+ Stat[0], pre_CLIENTS, tmp, G_USERS, G_USERS / NUM_SERV);
+ #endif