aboutsummaryrefslogtreecommitdiff
path: root/irc/epic4
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-04-02 06:00:30 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-04-02 06:00:30 +0000
commit7e0cd75c07c4c1c1e867929bc93ccd2192c694b1 (patch)
tree73d85a3c152d239c97cd5867cc17feb16b6fa515 /irc/epic4
parent351a3ad2a665e8e8ac7f000df1f28f62d587bcd1 (diff)
downloadports-7e0cd75c07c4c1c1e867929bc93ccd2192c694b1.tar.gz
ports-7e0cd75c07c4c1c1e867929bc93ccd2192c694b1.zip
Notes
Diffstat (limited to 'irc/epic4')
-rw-r--r--irc/epic4/Makefile16
-rw-r--r--irc/epic4/distinfo12
-rw-r--r--irc/epic4/pkg-plist2
3 files changed, 19 insertions, 11 deletions
diff --git a/irc/epic4/Makefile b/irc/epic4/Makefile
index 97c53f9ba122..b70f0379b1c3 100644
--- a/irc/epic4/Makefile
+++ b/irc/epic4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= epic4
-PORTVERSION= 2.8
+PORTVERSION= 2.10
CATEGORIES= irc ipv6
MASTER_SITES= http://ftp.epicsol.org/pub/epic/EPIC4-PRODUCTION/ \
http://tehran.lain.pl/epic-mirror/EPIC4-PRODUCTION/ \
@@ -15,7 +15,7 @@ MASTER_SITES= http://ftp.epicsol.org/pub/epic/EPIC4-PRODUCTION/ \
http://ftp.freenet.de/pub/ftp.prbh.org/pub/epic/EPIC4-PRODUCTION/ \
ftp://ftp.eu.uu.net/pub/unix/irc/epic/EPIC4-PRODUCTION/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}-help-20050315.tar.gz
+ ${PORTNAME}-help-20050315.tar.bz2
MAINTAINER= josh@tcbug.org
COMMENT= The (E)nhanced (P)rogrammable (I)RC-II (C)lient
@@ -26,12 +26,14 @@ GNU_CONFIGURE= yes
MAN1= epic.1
USE_OPENSSL= yes
SUB_FILES= pkg-message
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+USE_BZIP2= yes
OPTIONS= IPV6 "IPv6 support" on \
TCL "TCL support" on \
- PERL "Perl scripting support" off \
+ PERL "Perl scripting support" on \
SOCKS5 "Enable SOCKS5 proxy support" off \
- SSL "Enable SSL support" off \
+ SSL "Enable SSL support" on \
TERMCAP "Refuse to use terminfo/ncurses" off
.include <bsd.port.pre.mk>
@@ -47,6 +49,8 @@ CONFIGURE_ARGS+= --without-ipv6
.if !defined(WITHOUT_TCL)
LIB_DEPENDS+= tcl84:${PORTSDIR}/lang/tcl84
CONFIGURE_ARGS+= --with-tcl
+.else
+CONFIGURE_ARGS+= --without-tcl
.endif
## WITH_PERL: enable perl5 support (requires perl 5.6.1 or newer)
@@ -59,6 +63,8 @@ CONFIGURE_ARGS+= --with-tcl
.if defined(WITH_PERL)
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl=${SITE_PERL}/../../${PERL_VER}/mach/CORE
+.else
+CONFIGURE_ARGS+= --without-perl
.endif
## WITH_SOCKS5: enable SOCKS5 support
@@ -75,6 +81,8 @@ CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}/include
#
.if defined(WITH_SSL)
CONFIGURE_ARGS+= --with-ssl
+.else
+CONFIGURE_ARGS+= --without-ssl
.endif
## WITH_TERMCAP forceably refuse to use terminfo/ncurses
diff --git a/irc/epic4/distinfo b/irc/epic4/distinfo
index 171560327b91..24af001c1af0 100644
--- a/irc/epic4/distinfo
+++ b/irc/epic4/distinfo
@@ -1,6 +1,6 @@
-MD5 (epic4-2.8.tar.gz) = 26669602d0dcc5df9614f278f02d7bfc
-SHA256 (epic4-2.8.tar.gz) = ebb169f5e3584d6813a4cfb5292763e4c41b73d20a48f9ce699f898b1ee02fff
-SIZE (epic4-2.8.tar.gz) = 770922
-MD5 (epic4-help-20050315.tar.gz) = 9888d1af465ca72bf9a02487264071a5
-SHA256 (epic4-help-20050315.tar.gz) = 714afd07348731e6ac82e1f6548acc12e84539b3106ab27fa5d00ed5696256f7
-SIZE (epic4-help-20050315.tar.gz) = 332502
+MD5 (epic4-2.10.tar.bz2) = 92789d75f12882696817865ea072e44a
+SHA256 (epic4-2.10.tar.bz2) = b9043d9b039d3566a9b1b09426eda19bf6ad650ea47f79f68e89273b0fc6b089
+SIZE (epic4-2.10.tar.bz2) = 629828
+MD5 (epic4-help-20050315.tar.bz2) = b28872ca9234650eda6842ffc3425849
+SHA256 (epic4-help-20050315.tar.bz2) = a7b7026ecfc00ab7040ef5e435d72fd347d48fab128722d4e213dba194cd5bbe
+SIZE (epic4-help-20050315.tar.bz2) = 238390
diff --git a/irc/epic4/pkg-plist b/irc/epic4/pkg-plist
index fad3fbbfe7bd..a1f9740d10db 100644
--- a/irc/epic4/pkg-plist
+++ b/irc/epic4/pkg-plist
@@ -1,5 +1,5 @@
bin/epic
-bin/epic-EPIC4-2.8
+bin/epic-EPIC4-%%PORTVERSION%%
libexec/wserv4
share/epic/help/1_General/1_General
share/epic/help/1_General/away