aboutsummaryrefslogtreecommitdiff
path: root/irc/fisg
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-12-10 23:49:47 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-12-10 23:49:47 +0000
commit8edc81ddbbbc6d08ba98095bec779442c3093782 (patch)
tree356e5ef08656f4b92f2cc4d40a8d012731411107 /irc/fisg
parentc990fe99bfa1d384c2ba91a30f1400c599eba552 (diff)
downloadports-8edc81ddbbbc6d08ba98095bec779442c3093782.tar.gz
ports-8edc81ddbbbc6d08ba98095bec779442c3093782.zip
Notes
Diffstat (limited to 'irc/fisg')
-rw-r--r--irc/fisg/Makefile40
-rw-r--r--irc/fisg/distinfo2
-rw-r--r--irc/fisg/files/patch-Makefile13
-rw-r--r--irc/fisg/pkg-descr7
-rw-r--r--irc/fisg/pkg-plist21
5 files changed, 83 insertions, 0 deletions
diff --git a/irc/fisg/Makefile b/irc/fisg/Makefile
new file mode 100644
index 000000000000..484ebe2de3b5
--- /dev/null
+++ b/irc/fisg/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: fisg
+# Date created: 29 Nov 2004
+# Whom: Pasi Hirvonen <psh@iki.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fisg
+PORTVERSION= 0.2.0
+CATEGORIES= irc
+MASTER_SITES= http://www.tnsp.org/files/
+
+MAINTAINER= psh@iki.fi
+COMMENT= Fast IRC statistics generator
+
+USE_GMAKE= yes
+BUILD_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+
+PORTDOCS= README FAQ
+
+DATA_FILES= blue-h.png happy1.gif happy5.gif style-c64.css \
+ blue-v.png happy2.gif happy6.gif style-pisg.css \
+ green-h.png happy3.gif red-h.png yellow-h.png \
+ green-v.png happy4.gif red-v.png yellow-v.png
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/data/ && ${INSTALL_DATA} ${DATA_FILES} ${DATADIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.cfg ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/users.cfg ${EXAMPLESDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/fisg ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/fisg/distinfo b/irc/fisg/distinfo
new file mode 100644
index 000000000000..64827f565d36
--- /dev/null
+++ b/irc/fisg/distinfo
@@ -0,0 +1,2 @@
+MD5 (fisg-0.2.0.tar.gz) = c9632501cee22802934ecb266463e4d0
+SIZE (fisg-0.2.0.tar.gz) = 76700
diff --git a/irc/fisg/files/patch-Makefile b/irc/fisg/files/patch-Makefile
new file mode 100644
index 000000000000..75482fbd44f7
--- /dev/null
+++ b/irc/fisg/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- ../fisg-0.2.0-orig/src/Makefile Mon Nov 29 16:33:25 2004
++++ src/Makefile Mon Nov 29 16:33:51 2004
+@@ -2,8 +2,8 @@
+ # Makefile for UNIX
+ #
+ RM=rm
+-CC=gcc
+-CFLAGS= -g -O2 -Wall
++CC?=gcc
++CFLAGS?= -g -Wall
+
+ FISGEXE=fisg
+ TARGETS=$(FISGEXE) strmatch
diff --git a/irc/fisg/pkg-descr b/irc/fisg/pkg-descr
new file mode 100644
index 000000000000..e92b035be77e
--- /dev/null
+++ b/irc/fisg/pkg-descr
@@ -0,0 +1,7 @@
+FISG is a tool that creates statistics from IRC logs. FISG supports
+various logfile formats and has a very fast parsing engine.
+
+WWW: http://www.tnsp.org/fisg.php
+
+- Pasi Hirvonen
+psh@iki.fi
diff --git a/irc/fisg/pkg-plist b/irc/fisg/pkg-plist
new file mode 100644
index 000000000000..2f257052f9d6
--- /dev/null
+++ b/irc/fisg/pkg-plist
@@ -0,0 +1,21 @@
+bin/fisg
+%%EXAMPLESDIR%%/example.cfg
+%%EXAMPLESDIR%%/users.cfg
+%%DATADIR%%/blue-h.png
+%%DATADIR%%/blue-v.png
+%%DATADIR%%/green-h.png
+%%DATADIR%%/green-v.png
+%%DATADIR%%/happy1.gif
+%%DATADIR%%/happy2.gif
+%%DATADIR%%/happy3.gif
+%%DATADIR%%/happy4.gif
+%%DATADIR%%/happy5.gif
+%%DATADIR%%/happy6.gif
+%%DATADIR%%/red-h.png
+%%DATADIR%%/red-v.png
+%%DATADIR%%/style-c64.css
+%%DATADIR%%/style-pisg.css
+%%DATADIR%%/yellow-h.png
+%%DATADIR%%/yellow-v.png
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DATADIR%%