aboutsummaryrefslogtreecommitdiff
path: root/irc/gseen.mod
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-04 14:36:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-04 14:36:40 +0000
commitee7ece749df666d765232dc4c334562231d69cc4 (patch)
treec721ef1c573eb33afdf6fe718da7ae38ccadc449 /irc/gseen.mod
parent2a3c3501f5cd7d2520099fd0d8a80006079842ef (diff)
downloadports-ee7ece749df666d765232dc4c334562231d69cc4.tar.gz
ports-ee7ece749df666d765232dc4c334562231d69cc4.zip
Notes
Diffstat (limited to 'irc/gseen.mod')
-rw-r--r--irc/gseen.mod/Makefile19
-rw-r--r--irc/gseen.mod/files/pkg-message.in2
2 files changed, 9 insertions, 12 deletions
diff --git a/irc/gseen.mod/Makefile b/irc/gseen.mod/Makefile
index 4912e64bc196..4911eb86a284 100644
--- a/irc/gseen.mod/Makefile
+++ b/irc/gseen.mod/Makefile
@@ -11,21 +11,20 @@ DISTNAME= ${PORTNAME}.${PORTVERSION:S/p/dev/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Seen-module for the eggdrop IRC bot
-LICENSE= GPLv2
+LICENSE= GPLv2 # or later
-EXTRACT_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/irc/eggdrop:extract
+EXTRACT_DEPENDS=${NONEXISTENT}:${PORTSDIR}/irc/eggdrop:extract
BUILD_DEPENDS= eggdrop:${PORTSDIR}/irc/eggdrop
RUN_DEPENDS= eggdrop:${PORTSDIR}/irc/eggdrop
USES= tcl:85+
-
-WRKSRC= ${WRKDIR}/eggdrop
-
+GNU_CONGFIGURE= yes
CONFIGURE_ARGS= --with-tcllib=${LOCALBASE}/lib/libtcl${TCL_VER:S/.//}.so \
--with-tclinc=${TCL_INCLUDEDIR}/tcl.h
-
+WRKSRC= ${WRKDIR}/eggdrop
MAKE_JOBS_UNSAFE= yes
-GNU_CONGFIGURE= yes
+
+SUB_FILES= pkg-message
do-extract:
@${RM} -rf ${WRKDIR}
@@ -34,7 +33,7 @@ do-extract:
cd ${WRKSRC}/src/mod && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EXTRACT_ONLY} ${EXTRACT_AFTER_ARGS}
post-extract:
- ${REINPLACE_CMD} -e 's|"-g -O2"|"${CFLAGS}"|' \
+ @${REINPLACE_CMD} -e 's|"-g -O2"|"${CFLAGS}"|' \
-e 's|"-g"|"${CFLAGS}"|' \
-e 's|"-O2"|"${CFLAGS}"|' \
${WRKSRC}/configure
@@ -53,9 +52,5 @@ do-install:
${STAGEDIR}${LOCALBASE}/share/eggdrop/language
${INSTALL_DATA} ${WRKSRC}/src/mod/gseen.mod/gseen.conf \
${STAGEDIR}${PREFIX}/etc
- @${ECHO_MSG} "Please add the line"
- @${ECHO_MSG} "source ${PREFIX}/etc/gseen.conf"
- @${ECHO_MSG} "at the end of your eggdrop config file"
- @${ECHO_MSG} "and .rehash your bot"
.include <bsd.port.mk>
diff --git a/irc/gseen.mod/files/pkg-message.in b/irc/gseen.mod/files/pkg-message.in
new file mode 100644
index 000000000000..f26510132937
--- /dev/null
+++ b/irc/gseen.mod/files/pkg-message.in
@@ -0,0 +1,2 @@
+Please add the line source %%PREFIX%%/etc/gseen.conf at the end of
+your eggdrop config file and .rehash your bot