aboutsummaryrefslogtreecommitdiff
path: root/irc/hexchat
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2019-02-11 16:40:06 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2019-02-11 16:40:06 +0000
commitaf5a8af0bdb760e9f35c9fc4445356d35054fcea (patch)
treef9d68c30473e176157cd88b08c93f7568a585506 /irc/hexchat
parent7a1ae3268cc0e46b79d3d6e2cb69458474f426fb (diff)
downloadports-af5a8af0bdb760e9f35c9fc4445356d35054fcea.tar.gz
ports-af5a8af0bdb760e9f35c9fc4445356d35054fcea.zip
irc/hexchat: fix build when PYTHON option is off
- hexchat requires Python 3 - Specify PYTHON_VER in MESON_ARGS since each ports might be built with different Python versions PR: 235644 Submitted by: w.schwarzenfeld@utanet.at Reported by: Philipp Engel <kidon@posteo.de> Approved by: Piotr Kubaj <pkubaj@anongoth.pl> (maintainer)
Notes
Notes: svn path=/head/; revision=492699
Diffstat (limited to 'irc/hexchat')
-rw-r--r--irc/hexchat/Makefile21
-rw-r--r--irc/hexchat/pkg-plist2
2 files changed, 11 insertions, 12 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index b7c2c926fa3d..5eeed1990a02 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -3,8 +3,8 @@
PORTNAME= hexchat
PORTVERSION= 2.14.2
-PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= irc gnome ipv6
MAINTAINER= pkubaj@anongoth.pl
@@ -21,11 +21,12 @@ LIB_DEPENDS= libproxy.so:net/libproxy \
RUN_DEPENDS= ${LOCALBASE}/share/xml/iso-codes/iso_639.xml:misc/iso-codes
USES= compiler:c++11-lang desktop-file-utils gettext-tools gnome \
- libtool meson ninja pkgconfig shebangfix ssl
+ libtool meson ninja pkgconfig python:3.5+ shebangfix ssl
USE_GNOME= cairo gtk20 intltool libxml2
USE_XORG= x11
USE_GITHUB= yes
-MESON_ARGS= -Dwith-ssl=true -Dwith-gtk=true
+
+MESON_ARGS= -Dwith-ssl=true -Dwith-gtk=true -Dwith-python=python-${PYTHON_VER}
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
@@ -37,9 +38,9 @@ SUB_FILES= pkg-message
PORTDOCS= *
OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOCS FISHLIM LUA NOTIFY \
- PERL PYTHON TEXTFE SYSINFO
+ PERL TEXTFE SYSINFO
-OPTIONS_DEFAULT= CA_BUNDLE CANBERRA DBUS NOTIFY PERL PYTHON
+OPTIONS_DEFAULT= CA_BUNDLE CANBERRA DBUS NOTIFY PERL
OPTIONS_SUB= yes
@@ -66,15 +67,13 @@ NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
NOTIFY_MESON_TRUE= with-libnotify
PERL_MESON_TRUE= with-perl
PERL_USES= perl5
-PYTHON_MESON_ON= -Dwith-python=python-${PYTHON_VER}
-PYTHON_MESON_OFF= -Dwith-python=false
-PYTHON_USES= python:3.4+ shebangfix
-PYTHON_VARS= SHEBANG_FILES=meson_post_install.py
-PYTHON_VARS+= SHEBANG_FILES=plugins/perl/generate_header.py
-PYTHON_VARS+= SHEBANG_FILES=src/common/make-te.py
TEXTFE_MESON_TRUE= with-text
SYSINFO_MESON_TRUE= with-sysinfo
+SHEBANG_FILES= meson_post_install.py \
+ plugins/perl/generate_header.py \
+ src/common/make-te.py
+
post-patch:
@${REINPLACE_CMD} -e 's|%%CA_BUNDLE%%|${CA_BUNDLE}|' \
${WRKSRC}/src/common/server.c
diff --git a/irc/hexchat/pkg-plist b/irc/hexchat/pkg-plist
index ef0ac335501a..368fee2c86ac 100644
--- a/irc/hexchat/pkg-plist
+++ b/irc/hexchat/pkg-plist
@@ -4,7 +4,7 @@ include/hexchat-plugin.h
lib/hexchat/plugins/checksum.so
%%FISHLIM%%lib/hexchat/plugins/fishlim.so
%%PERL%%lib/hexchat/plugins/perl.so
-%%PYTHON%%lib/hexchat/plugins/python.so
+lib/hexchat/plugins/python.so
%%LUA%%%%LUA_LIBDIR%%/hexchat/plugins/lua.so
%%SYSINFO%%lib/hexchat/plugins/sysinfo.so
libdata/pkgconfig/hexchat-plugin.pc