aboutsummaryrefslogtreecommitdiff
path: root/irc/hexchat
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2016-12-16 13:48:37 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2016-12-16 13:48:37 +0000
commitf404b62eabcde3e2777cfbc89f907f6200377137 (patch)
treed22cc2fcc546a48f8fe30c6eddb4bfe3f3169c9c /irc/hexchat
parent4a2e8714d78f72e93d1a37ba4ed5b4cc7b0ed5bb (diff)
downloadports-f404b62eabcde3e2777cfbc89f907f6200377137.tar.gz
ports-f404b62eabcde3e2777cfbc89f907f6200377137.zip
Update to 2.12.4
PR: 215302 Submitted by: Piotr Kubaj (maintainer) Approved by: tabthorpe Differential Revision: https://reviews.freebsd.org/D8805
Notes
Notes: svn path=/head/; revision=428680
Diffstat (limited to 'irc/hexchat')
-rw-r--r--irc/hexchat/Makefile14
-rw-r--r--irc/hexchat/distinfo6
-rw-r--r--irc/hexchat/files/patch-src__common__server.c8
-rw-r--r--irc/hexchat/files/patch-src__common__ssl.c8
-rw-r--r--irc/hexchat/pkg-plist1
5 files changed, 19 insertions, 18 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index b18a6e70bfed..af995256cbe9 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= hexchat
-PORTVERSION= 2.12.3
+PORTVERSION= 2.12.4
CATEGORIES= irc gnome ipv6
-MASTER_SITES= http://dl.hexchat.net/${PORTNAME}/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/archive/
+DISTNAME= v${PORTVERSION}
MAINTAINER= pkubaj@anongoth.pl
COMMENT= IRC chat program with GTK and Text Frontend
@@ -12,12 +13,15 @@ COMMENT= IRC chat program with GTK and Text Frontend
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= devel/autoconf-archive>0:devel/autoconf-archive
LIB_DEPENDS= libproxy.so:net/libproxy \
libfontconfig.so:x11-fonts/fontconfig \
libdbus-1.so:devel/dbus \
libfreetype.so:print/freetype2
-USES= gmake desktop-file-utils libtool pkgconfig tar:xz ssl
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USES= autoreconf gmake desktop-file-utils libtool pkgconfig ssl
USE_GNOME= cairo gtk20 intltool libxml2
USE_XORG= x11
GNU_CONFIGURE= yes
@@ -36,7 +40,7 @@ SUB_FILES= pkg-message
PORTDOCS= *
-OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOAT DOCS FISHLIM LUA NLS NOTIFY \
+OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOCS FISHLIM LUA NLS NOTIFY \
PERL PYTHON SOCKS TEXTFE
OPTIONS_DEFAULT= CA_BUNDLE CANBERRA DBUS NOTIFY PERL PYTHON
@@ -45,7 +49,6 @@ OPTIONS_SUB= yes
CA_BUNDLE_DESC= Include CA bundle for SSL verification
CANBERRA_DESC= Audio support via Libcanberra
-DOAT_DESC= Do At plugin
FISHLIM_DESC= FiSHLiM plugin
TEXTFE_DESC= Text frontend
SOCKS_DESC= SOCKS proxy support, FORBIDDEN in FreeBSD 10+
@@ -56,7 +59,6 @@ CANBERRA_CONFIGURE_ENABLE=libcanberra
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
DBUS_CONFIGURE_ENABLE= dbus
DBUS_USE= GNOME=gconf2
-DOAT_CONFIGURE_ENABLE= doat
FISHLIM_CONFIGURE_ENABLE=fishlim
LUA_CONFIGURE_ENABLE= lua
LUA_USES= lua
diff --git a/irc/hexchat/distinfo b/irc/hexchat/distinfo
index adaa506372f9..09cbd528b6da 100644
--- a/irc/hexchat/distinfo
+++ b/irc/hexchat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477276791
-SHA256 (hexchat-2.12.3.tar.xz) = 6f2b22372c7a9ed8ffab817079638e8f4178f5f8ba63c89cb3baa01be614f2ba
-SIZE (hexchat-2.12.3.tar.xz) = 1577736
+TIMESTAMP = 1481549280
+SHA256 (v2.12.4.tar.gz) = eb9ebe45b1c9e39543517b48d63caa2f2736e82a8dbbd1da96132070752f8084
+SIZE (v2.12.4.tar.gz) = 2780008
diff --git a/irc/hexchat/files/patch-src__common__server.c b/irc/hexchat/files/patch-src__common__server.c
index 725ae96f033b..f9189abceb83 100644
--- a/irc/hexchat/files/patch-src__common__server.c
+++ b/irc/hexchat/files/patch-src__common__server.c
@@ -1,11 +1,11 @@
---- src/common/server.c.orig 2014-11-25 18:42:31.000000000 +0100
-+++ src/common/server.c 2015-05-21 15:48:24.162789182 +0200
-@@ -875,7 +875,7 @@
+--- src/common/server.c.orig 2016-12-10 14:30:51 UTC
++++ src/common/server.c
+@@ -743,7 +743,7 @@ server_connect_success (server *serv)
/* it'll be a memory leak, if connection isn't terminated by
server_cleanup() */
serv->ssl = _SSL_socket (serv->ctx, serv->sok);
- if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, NULL)))
-+ if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, %%CA_BUNDLE%%)))
++ if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, "/usr/local/share/certs/ca-root-nss.crt")))
{
EMIT_SIGNAL (XP_TE_CONNFAIL, serv->server_session, err, NULL,
NULL, NULL, 0);
diff --git a/irc/hexchat/files/patch-src__common__ssl.c b/irc/hexchat/files/patch-src__common__ssl.c
index 1112fe1f025a..5af87feaeb54 100644
--- a/irc/hexchat/files/patch-src__common__ssl.c
+++ b/irc/hexchat/files/patch-src__common__ssl.c
@@ -1,6 +1,6 @@
---- src/common/ssl.c.orig 2014-11-25 18:42:31.000000000 +0100
-+++ src/common/ssl.c 2015-05-21 15:58:31.403630733 +0200
-@@ -320,7 +320,7 @@
+--- src/common/ssl.c.orig 2016-12-10 14:30:51 UTC
++++ src/common/ssl.c
+@@ -328,7 +328,7 @@ _SSL_set_verify (SSL_CTX *ctx, void *ver
__SSL_fill_err_buf ("SSL_CTX_set_default_verify_paths");
return (err_buf);
}
@@ -9,7 +9,7 @@
if (cacert)
{
if (!SSL_CTX_load_verify_locations (ctx, cacert, NULL))
-@@ -329,7 +329,7 @@
+@@ -337,7 +337,7 @@ _SSL_set_verify (SSL_CTX *ctx, void *ver
return (err_buf);
}
}
diff --git a/irc/hexchat/pkg-plist b/irc/hexchat/pkg-plist
index bd807f200c1b..9653c09fbd59 100644
--- a/irc/hexchat/pkg-plist
+++ b/irc/hexchat/pkg-plist
@@ -2,7 +2,6 @@ bin/hexchat
%%TEXTFE%%bin/hexchat-text
include/hexchat-plugin.h
lib/hexchat/plugins/checksum.so
-%%DOAT%%lib/hexchat/plugins/doat.so
%%FISHLIM%%lib/hexchat/plugins/fishlim.so
%%PERL%%lib/hexchat/plugins/perl.so
%%PYTHON%%lib/hexchat/plugins/python.so