aboutsummaryrefslogtreecommitdiff
path: root/irc/insub
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2013-09-30 14:16:36 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2013-09-30 14:16:36 +0000
commited3bf2093a9d8ffdfd9888ea6ce6a660c064eed9 (patch)
treefde292daeaf4d43b519b010f3978049617bb1efe /irc/insub
parent337aaa4d63aa480f9a67e3de2a0be997c7151552 (diff)
downloadports-ed3bf2093a9d8ffdfd9888ea6ce6a660c064eed9.tar.gz
ports-ed3bf2093a9d8ffdfd9888ea6ce6a660c064eed9.zip
Staging support.
Notes
Notes: svn path=/head/; revision=328792
Diffstat (limited to 'irc/insub')
-rw-r--r--irc/insub/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/irc/insub/Makefile b/irc/insub/Makefile
index 9307469034d6..9668663dc5a9 100644
--- a/irc/insub/Makefile
+++ b/irc/insub/Makefile
@@ -13,22 +13,21 @@ RUN_DEPENDS= cowsay:${PORTSDIR}/games/cowsay \
figlet:${PORTSDIR}/misc/figlet
USES= perl5
+USE_PERL5= run
-NO_BUILD= YES
+USE_BZIP2= yes
-USE_BZIP2= YES
-USE_PERL5= run
+NO_BUILD= yes
SCRIPT= ${PORTNAME}.pl
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${SCRIPT} ${PREFIX}/bin/${SCRIPT:R}
- ${MKDIR} ${PREFIX}/share/irssi/scripts/
+ ${INSTALL_SCRIPT} ${WRKSRC}/${SCRIPT} ${STAGEDIR}${PREFIX}/bin/${SCRIPT:R}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/irssi/scripts/
${INSTALL_DATA} ${WRKSRC}/${SCRIPT} \
- ${PREFIX}/share/irssi/scripts/${SCRIPT}
- ${MKDIR} ${PREFIX}/share/cows/
+ ${STAGEDIR}${PREFIX}/share/irssi/scripts/${SCRIPT}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/cows/
cd ${WRKSRC} && \
- ${FIND} cows | ${CPIO} -pdmu ${PREFIX}/share/
+ ${FIND} cows | ${CPIO} -pdmu ${STAGEDIR}${PREFIX}/share/
.include <bsd.port.mk>