aboutsummaryrefslogtreecommitdiff
path: root/irc/irc
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-12-29 15:19:29 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-12-29 15:19:29 +0000
commit69662ccee34d1ed1dde54c81f5806485a7b557f8 (patch)
tree89b0bd8b6320ab78a89f0a9d830ccaa26c825c60 /irc/irc
parent2bc3a23ed26ddf07a7df7051e832c94661590869 (diff)
downloadports-69662ccee34d1ed1dde54c81f5806485a7b557f8.tar.gz
ports-69662ccee34d1ed1dde54c81f5806485a7b557f8.zip
Enable stage support
Notes
Notes: svn path=/head/; revision=338008
Diffstat (limited to 'irc/irc')
-rw-r--r--irc/irc/Makefile13
-rw-r--r--irc/irc/files/patch-support_Makefile.in94
-rw-r--r--irc/irc/files/patch-support_config.h.dist (renamed from irc/irc/files/patch-ab)18
-rw-r--r--irc/irc/pkg-plist4
4 files changed, 109 insertions, 20 deletions
diff --git a/irc/irc/Makefile b/irc/irc/Makefile
index 0e1b382ae5cc..fcebc24af3ed 100644
--- a/irc/irc/Makefile
+++ b/irc/irc/Makefile
@@ -17,22 +17,13 @@ CONFLICTS_INSTALL= charybdis-[0-9]* ircd-hybrid-[0-9]* Nefarious-[0-9]* \
ru-ircd-hybrid-[0-9]* ircd-ru-[0-9]*
USE_RC_SUBR= ircd
-MAN5= iauth.conf.5
-MAN8= ircd.8 iauth.8 ircdwatch.8
-
-GNU_CONFIGURE= YES
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/ircd
BUILD_WRKSRC= ${WRKSRC}/${MACHINE_ARCH}-unknown-${OPSYS:L}${OSREL}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
OPTIONS_DEFINE= IPV6
OPTIONS_DEFAULT=IPV6
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
+IPV6_CONFIGURE_ENABLE= ipv6
.include <bsd.port.mk>
diff --git a/irc/irc/files/patch-support_Makefile.in b/irc/irc/files/patch-support_Makefile.in
new file mode 100644
index 000000000000..7234b69436d1
--- /dev/null
+++ b/irc/irc/files/patch-support_Makefile.in
@@ -0,0 +1,94 @@
+--- support/Makefile.in.orig 2008-06-07 01:51:26.000000000 +0200
++++ support/Makefile.in 2013-12-29 16:16:43.000000000 +0100
+@@ -219,55 +219,55 @@ $(TKSERV): tkserv.o
+ install: install-server
+
+ install-ircd: $(IRCD_BIN)
+- -@if [ ! -d $(server_bin_dir) ]; then \
+- $(MKDIRHIER) $(server_bin_dir); \
++ -@if [ ! -d $(DESTDIR)$(server_bin_dir) ]; then \
++ $(MKDIRHIER) $(DESTDIR)$(server_bin_dir); \
+ fi
+- $(INSTALL_PROGRAM) -m $(ircd_mode) $(IRCD_BIN) $(server_bin_dir)
++ $(INSTALL_PROGRAM) -m $(ircd_mode) $(IRCD_BIN) $(DESTDIR)$(server_bin_dir)
+
+ install-server: install-ircd server
+- -@if [ ! -d $(server_man_dir) ]; then \
+- $(MKDIRHIER) $(server_man_dir); \
++ -@if [ ! -d $(DESTDIR)$(server_man_dir) ]; then \
++ $(MKDIRHIER) $(DESTDIR)$(server_man_dir); \
+ fi
+- -@if [ ! -d $(conf_man_dir) ]; then \
+- $(MKDIRHIER) $(conf_man_dir); \
++ -@if [ ! -d $(DESTDIR)$(conf_man_dir) ]; then \
++ $(MKDIRHIER) $(DESTDIR)$(conf_man_dir); \
+ fi
+- -@if [ ! -d $(ircd_conf_dir) ]; then \
+- $(MKDIRHIER) $(ircd_conf_dir); \
++ -@if [ ! -d $(DESTDIR)$(ircd_conf_dir) ]; then \
++ $(MKDIRHIER) $(DESTDIR)$(ircd_conf_dir); \
+ fi
+- -@if [ ! -d $(ircd_var_dir) ]; then \
+- $(MKDIRHIER) $(ircd_var_dir); \
+- fi
+- -@if [ ! -d $(ircd_log_dir) ]; then \
+- $(MKDIRHIER) $(ircd_log_dir); \
+- fi
+- $(INSTALL_PROGRAM) -m $(ircd_mode) $(IAUTH) $(server_bin_dir)
+- $(INSTALL_PROGRAM) -m $(ircd_mode) $(CHKCONF) $(server_bin_dir)
+- $(INSTALL_PROGRAM) -m $(ircd_mode) ircd-mkpasswd $(server_bin_dir)
+- $(INSTALL_PROGRAM) -m $(ircd_mode) $(IRCDWATCH) $(server_bin_dir)
+- $(RM) $(IRCDM4_PATH)
+- ../ircd/buildm4 $(IRCDM4_PATH)
+- $(INSTALL_DATA) ../doc/ircd.8 $(server_man_dir)
+- $(INSTALL_DATA) ../doc/iauth.8 $(server_man_dir)
+- $(INSTALL_DATA) ../doc/iauth.conf.5 $(conf_man_dir)
+- $(INSTALL_DATA) ../contrib/ircdwatch/ircdwatch.8 $(server_man_dir)
+- $(INSTALL_DATA) ../doc/ircd.conf.example $(ircd_conf_dir)
+- $(INSTALL_DATA) ../doc/iauth.conf.example $(ircd_conf_dir)
+- -@if [ ! -f $(IAUTHCONF_PATH) ]; then \
+- $(INSTALL_DATA) ../doc/iauth.conf.example $(IAUTHCONF_PATH); \
++ -@if [ ! -d $(DESTDIR)$(ircd_var_dir) ]; then \
++ $(MKDIRHIER) $(DESTDIR)$(ircd_var_dir); \
++ fi
++ -@if [ ! -d $(DESTDIR)$(ircd_log_dir) ]; then \
++ $(MKDIRHIER) $(DESTDIR)$(ircd_log_dir); \
++ fi
++ $(INSTALL_PROGRAM) -m $(ircd_mode) $(IAUTH) $(DESTDIR)$(server_bin_dir)
++ $(INSTALL_PROGRAM) -m $(ircd_mode) $(CHKCONF) $(DESTDIR)$(server_bin_dir)
++ $(INSTALL_PROGRAM) -m $(ircd_mode) ircd-mkpasswd $(DESTDIR)$(server_bin_dir)
++ $(INSTALL_PROGRAM) -m $(ircd_mode) $(IRCDWATCH) $(DESTDIR)$(server_bin_dir)
++ $(RM) $(DESTDIR)$(IRCDM4_PATH)
++ ../ircd/buildm4 $(DESTDIR)$(IRCDM4_PATH)
++ $(INSTALL_DATA) ../doc/ircd.8 $(DESTDIR)$(server_man_dir)
++ $(INSTALL_DATA) ../doc/iauth.8 $(DESTDIR)$(server_man_dir)
++ $(INSTALL_DATA) ../doc/iauth.conf.5 $(DESTDIR)$(conf_man_dir)
++ $(INSTALL_DATA) ../contrib/ircdwatch/ircdwatch.8 $(DESTDIR)$(server_man_dir)
++ $(INSTALL_DATA) ../doc/ircd.conf.example $(DESTDIR)$(ircd_conf_dir)
++ $(INSTALL_DATA) ../doc/iauth.conf.example $(DESTDIR)$(ircd_conf_dir)
++ -@if [ ! -f $(DESTDIR)$(IAUTHCONF_PATH) ]; then \
++ $(INSTALL_DATA) ../doc/iauth.conf.example $(DESTDIR)$(IAUTHCONF_PATH); \
+ fi
+- -@if [ ! -f $(IRCDMOTD_PATH) ]; then \
+- $(INSTALL_DATA) ../support/ircd.motd $(IRCDMOTD_PATH); \
++ -@if [ ! -f $(DESTDIR)$(IRCDMOTD_PATH) ]; then \
++ $(INSTALL_DATA) ../support/ircd.motd $(DESTDIR)$(IRCDMOTD_PATH); \
+ fi
+ @echo "installation of server done."
+
+ install-tkserv: $(TKSERV)
+- -@if [ ! -d $(server_bin_dir) ]; then \
+- $(MKDIRHIER) $(server_bin_dir); \
++ -@if [ ! -d $(DESTDIR)$(server_bin_dir) ]; then \
++ $(MKDIRHIER) $(DESTDIR)$(server_bin_dir); \
+ fi
+- -@if [ ! -d $(ircd_conf_dir) ]; then \
+- $(MKDIRHIER) $(ircd_conf_dir); \
++ -@if [ ! -d $(DESTDIR)$(ircd_conf_dir) ]; then \
++ $(MKDIRHIER) $(DESTDIR)$(ircd_conf_dir); \
+ fi
+- $(INSTALL_PROGRAM) -m $(ircd_mode) $(TKSERV) $(server_bin_dir)
++ $(INSTALL_PROGRAM) -m $(ircd_mode) $(TKSERV) $(DESTDIR)$(server_bin_dir)
+ @echo "installation of tkserv done."
+
+ clbsd.o: ../common/bsd.c setup.h config.h ../common/struct_def.h
diff --git a/irc/irc/files/patch-ab b/irc/irc/files/patch-support_config.h.dist
index e1c9242d90b9..f2992294d81a 100644
--- a/irc/irc/files/patch-ab
+++ b/irc/irc/files/patch-support_config.h.dist
@@ -1,6 +1,6 @@
---- support/config.h.dist.orig Sat Dec 11 01:56:41 2004
-+++ support/config.h.dist Sat Feb 26 01:13:29 2005
-@@ -118,13 +118,13 @@
+--- support/config.h.dist.orig 2010-08-13 21:53:03.000000000 +0200
++++ support/config.h.dist 2013-12-29 16:09:38.000000000 +0100
+@@ -123,13 +123,13 @@
/*
* Operator rights can be precisely defined in O:line flags. However
* if you undefine any of the following, it will make given function
@@ -17,9 +17,9 @@
+#define LOCOP_REHASH
+#define LOCOP_RESTART
#define OPER_SQUIT
- #define OPER_TKLINE
- /* In a perfect world these two (or at least second) would be undefined. */
-@@ -232,25 +232,25 @@
+ #define OPER_SQUIT_REMOTE
+ #define OPER_KLINE
+@@ -241,25 +241,25 @@
* this option is used unless you tell the system administrator beforehand
* and obtain their permission to send messages to the system log files.
*/
@@ -53,7 +53,7 @@
#endif /* USE_SYSLOG */
/*
-@@ -275,7 +275,7 @@
+@@ -308,7 +308,7 @@
* Define this if you want to use crypted passwords for operators in your
* ircd.conf file. See contrib/mkpasswd/README for more details on this.
*/
@@ -62,7 +62,7 @@
/*
* If you want to store encrypted passwords in N-lines for server links,
-@@ -324,7 +324,7 @@
+@@ -357,7 +357,7 @@
* send to the server without processing before disconnecting the client for
* flooding it. Values greater than 8000 make no difference to the server.
*/
@@ -71,7 +71,7 @@
/* Remote query flood protection. */
#define CHREPLLEN 8192
-@@ -359,7 +359,7 @@
+@@ -392,7 +392,7 @@
* The library and the include files must have been found by configure,
* if you have installed the zlib after running configure, run it again.
*/
diff --git a/irc/irc/pkg-plist b/irc/irc/pkg-plist
index 7f492613f9bc..5725557865c7 100644
--- a/irc/irc/pkg-plist
+++ b/irc/irc/pkg-plist
@@ -3,6 +3,10 @@ etc/ircd/iauth.conf.example
etc/ircd/iauth.conf
etc/ircd/ircd.motd
etc/ircd/ircd.m4
+man/man5/iauth.conf.5.gz
+man/man8/iauth.8.gz
+man/man8/ircd.8.gz
+man/man8/ircdwatch.8.gz
sbin/chkconf
sbin/ircd
sbin/iauth