aboutsummaryrefslogtreecommitdiff
path: root/irc/ircII
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-12-17 22:30:45 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2016-12-17 22:30:45 +0000
commitc64bb13b460dd476358cf9c7a290bc3a815f0ada (patch)
tree9a452ac32bb95ce7e99baaf535f2fba4dfeaafb2 /irc/ircII
parent225f371dce509f238d8c56c8205a21c04b2fbf71 (diff)
downloadports-c64bb13b460dd476358cf9c7a290bc3a815f0ada.tar.gz
ports-c64bb13b460dd476358cf9c7a290bc3a815f0ada.zip
Fix build against SSL from ports. The -L${ICONV_PREFIX}/lib prevents
cc from finding the correct libcrypto/libssl, so quick-fix this by only adding -L${ICONV_PREFIX}/lib if it's something other than /usr/lib. Also, use USES=ssl. PORTREVISION bump for the potential ldd change.
Notes
Notes: svn path=/head/; revision=428809
Diffstat (limited to 'irc/ircII')
-rw-r--r--irc/ircII/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/irc/ircII/Makefile b/irc/ircII/Makefile
index 5e6733022e99..868248352ada 100644
--- a/irc/ircII/Makefile
+++ b/irc/ircII/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ircii
PORTVERSION= 20151120
+PORTREVISION= 1
CATEGORIES= irc ipv6
MASTER_SITES= http://ircii.warped.com/
@@ -23,7 +24,7 @@ IRCBUG_DESC= Install ircII bug-reporting script
EMACS_KEYS_DESC=Use emacs meta keys
EMACS_KEYS_CONFIGURE_WITH= emacs-meta-keys
-OPENSSL_USE= OPENSSL=yes
+OPENSSL_USES= ssl
.include <bsd.port.pre.mk>
@@ -33,8 +34,10 @@ CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
CONFIGURE_ARGS+= --without-openssl
.endif
+.if ${ICONV_PREFIX} != /usr
CPPFLAGS+= -I${ICONV_PREFIX}/include
LDFLAGS+= -L${ICONV_PREFIX}/lib
+.endif
post-patch:
@${REINPLACE_CMD} -e '/^mandir =/s/@mandir@/$${DESTDIR}&/' \