aboutsummaryrefslogtreecommitdiff
path: root/irc/ircII
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-04-11 01:01:55 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-04-11 01:01:55 +0000
commit09a055a2fe7b9263c3f93f71ee74f970db322b28 (patch)
treef1dd56d78047f948b4e423f2e2191e0e368218f7 /irc/ircII
parent4833253e27b1aadfd33114bfab2ec1ac8c26d08c (diff)
downloadports-09a055a2fe7b9263c3f93f71ee74f970db322b28.tar.gz
ports-09a055a2fe7b9263c3f93f71ee74f970db322b28.zip
Notes
Diffstat (limited to 'irc/ircII')
-rw-r--r--irc/ircII/Makefile8
-rw-r--r--irc/ircII/files/patch-Makefile.in57
-rw-r--r--irc/ircII/files/patch-configure.in21
-rw-r--r--irc/ircII/pkg-descr2
-rw-r--r--irc/ircII/pkg-plist3
5 files changed, 86 insertions, 5 deletions
diff --git a/irc/ircII/Makefile b/irc/ircII/Makefile
index b7a5cfd473b3..13af6a2783dc 100644
--- a/irc/ircII/Makefile
+++ b/irc/ircII/Makefile
@@ -9,14 +9,14 @@ MASTER_SITES= http://ircii.warped.com/
MAINTAINER= sylvio@FreeBSD.org
COMMENT= The 'Internet Relay Chat' and 'Internet Citizens Band' Client
+LICENSE= BSD3CLAUSE
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= IRCLIB=${PREFIX}/share/irc
+USE_AUTOTOOLS= autoconf213 autoheader213
-USE_BZIP2= yes
-
-MAN1= irc.1 ircII.1 ircbug.1
+USES= tar:bzip2
PLIST_SUB= VERSION="${PORTVERSION}"
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/irc/ircII/files/patch-Makefile.in b/irc/ircII/files/patch-Makefile.in
new file mode 100644
index 000000000000..a4fd6d761c25
--- /dev/null
+++ b/irc/ircII/files/patch-Makefile.in
@@ -0,0 +1,57 @@
+--- ./Makefile.in.orig 2014-04-10 10:51:26.400763791 -0500
++++ ./Makefile.in 2014-04-10 10:53:08.187756816 -0500
+@@ -164,15 +164,15 @@
+ ( \
+ cd $(topdir)/script; \
+ for i in *; do \
+- if test "$$i" = "local" -a -f $(INSTALL_SCRIPT)/local; then \
++ if test "$$i" = "local" -a -f $(DESTDIR)$(INSTALL_SCRIPT)/local; then \
+ if test -f local; then \
+- $(INSTALL_DATA) local $(INSTALL_SCRIPT)/local.orig; \
++ $(INSTALL_DATA) local $(DESTDIR)$(INSTALL_SCRIPT)/local.orig; \
+ fi; \
+ elif test "$$i" != "CVS" -a "$$i" != ".CVS"; then \
+- $(INSTALL_DATA) $$i $(INSTALL_SCRIPT); \
++ $(INSTALL_DATA) $$i $(DESTDIR)$(INSTALL_SCRIPT); \
+ fi; \
+ done; \
+- chmod -x $(INSTALL_SCRIPT)/* \
++ chmod -x $(DESTDIR)$(INSTALL_SCRIPT)/* \
+ )
+
+ installtranslation: installdirs
+@@ -180,10 +180,10 @@
+ cd $(topdir)/translation; \
+ for i in *; do \
+ if test "$$i" != "CVS" -a "$$i" != ".CVS"; then \
+- $(INSTALL_DATA) $$i $(TRANS_PATH); \
++ $(INSTALL_DATA) $$i $(DESTDIR)$(TRANS_PATH); \
+ fi; \
+ done; \
+- chmod -x $(TRANS_PATH)/* \
++ chmod -x $(DESTDIR)$(TRANS_PATH)/* \
+ )
+
+ installserv: installio
+@@ -198,8 +198,8 @@
+
+ installhelp:
+ $(INSTALL_HELP_CMD)
+- find $(HELP_DIR) -type d -print | xargs chmod a+rx
+- find $(HELP_DIR) -type f -print | xargs chmod a+r
++ find $(DESTDIR)$(HELP_DIR) -type d -print | xargs chmod a+rx
++ find $(DESTDIR)$(HELP_DIR) -type f -print | xargs chmod a+r
+
+ installman:
+ (cd $(topdir)/doc; for i in ircII.1 ircbug.1; do $(INSTALL_DATA) $$i $(mandir); done)
+@@ -209,8 +209,8 @@
+ # $(INSTALL_DATA) $(topdir)/doc/query-pr.1 $(mandir)
+
+ installdirs:
+- umask 022; $(topdir)/mkinstalldirs $(IRCLIB) $(bindir) $(mandir) \
+- $(TRANS_PATH) $(INSTALL_SCRIPT) $(HELP_DIR) $(libexecdir)
++ umask 022; $(topdir)/mkinstalldirs $(DESTDIR)$(IRCLIB) $(bindir) $(mandir) \
++ $(DESTDIR)$(TRANS_PATH) $(DESTDIR)$(INSTALL_SCRIPT) $(DESTDIR)$(HELP_DIR) $(libexecdir)
+
+ clena clean:
+ cd $(objdir) && $(RM) $(PROGRAMS) $(OBJECTS) \
diff --git a/irc/ircII/files/patch-configure.in b/irc/ircII/files/patch-configure.in
new file mode 100644
index 000000000000..f61cb7d93ba7
--- /dev/null
+++ b/irc/ircII/files/patch-configure.in
@@ -0,0 +1,21 @@
+--- ./configure.in.orig 2014-04-10 10:50:59.524766021 -0500
++++ ./configure.in 2014-04-10 10:51:21.359765624 -0500
+@@ -882,15 +882,15 @@
+ fi
+ if test "x$COPY_DIRECTORY" = "xpax";
+ then
+- INSTALL_HELP_CMD='cd $(topdir)/help; pax -r -w -s ";.*/CVS$$;;" -s ";.*/\.CVS$$;;" -s ";.*/CVS/.*;;" -s ";.*/\.CVS/.*;;" . $(HELP_DIR)'
++ INSTALL_HELP_CMD='cd $(topdir)/help; pax -r -w -s ";.*/CVS$$;;" -s ";.*/\.CVS$$;;" -s ";.*/CVS/.*;;" -s ";.*/\.CVS/.*;;" . $(DESTDIR)$(HELP_DIR)'
+ else
+ if test "x$COPY_DIRECTORY" = "xtar";
+ then
+- INSTALL_HELP_CMD='cd $(topdir)/help; tar -cf - . | ( cd $(HELP_DIR); tar -xf - )'
++ INSTALL_HELP_CMD='cd $(topdir)/help; tar -cf - . | ( cd $(DESTDIR)$(HELP_DIR); tar -xf - )'
+ else
+ if test "x$COPY_DIRECTORY" = "xcpio";
+ then
+- INSTALL_HELP_CMD='cd $(topdir)/help; find . -print | cpio -pdu $(HELP_DIR)'
++ INSTALL_HELP_CMD='cd $(topdir)/help; find . -print | cpio -pdu $(DESTDIR)$(HELP_DIR)'
+ else
+ INSTALL_HELP_CMD="@echo \"I couldn't figure out a way to install the help files.\""
+ fi
diff --git a/irc/ircII/pkg-descr b/irc/ircII/pkg-descr
index 663263add2d2..072197ec368c 100644
--- a/irc/ircII/pkg-descr
+++ b/irc/ircII/pkg-descr
@@ -2,4 +2,4 @@ The ircII program is a full screen, termcap based interface to Internet Relay
Chat. It gives full access to all of the normal IRC functions, plus a variety
of additional options.
-WWW: http://www.eterna.com.au/ircii/
+WWW: http://www.eterna.com.au/ircii/
diff --git a/irc/ircII/pkg-plist b/irc/ircII/pkg-plist
index 0e64907f0146..8f922a0a7388 100644
--- a/irc/ircII/pkg-plist
+++ b/irc/ircII/pkg-plist
@@ -4,6 +4,9 @@ bin/ircbug
bin/ircflush
libexec/ircio
libexec/wserv
+man/man1/irc.1.gz
+man/man1/ircII.1.gz
+man/man1/ircbug.1.gz
share/irc/help/!
share/irc/help/.date
share/irc/help/: