aboutsummaryrefslogtreecommitdiff
path: root/irc/ircg
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-08 18:24:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-08 18:24:39 +0000
commitf70216f3c3364a04f9f1fd9e34d6251426de686c (patch)
treedb9e978b7199568a81454e5fa2c0a1f3cc26f9de /irc/ircg
parenta78a2ee16ea74ec727f58f63578cd273b7eb165a (diff)
IRCG is a fast, scalable web chat framework that connects a php frontend with
an irc backend. Sascha Schumann created IRCG a few years ago. Unfortunately, he decided to change the license to a commercial one starting with Version 3 and removed all traces of the BSD-Licensed IRCG 2. I kept on using the IRCG 2 sources and never had a problem with this setup. IRCG connects an irc server of your choice with a thttpd webserver. Using PHP, the frontend can be scripted. It?s mainly a framework for web-based chats, but could be used to pass any type of xml messages between multiple clients. Memory and CPU usage per client is quite low, so even an entry-level server can support hundreds of clients. PR: ports/86425 Submitted by: Alexander Novitsky <alecn2002@yandex.ru>
Notes
Notes: svn path=/head/; revision=144592
Diffstat (limited to 'irc/ircg')
-rw-r--r--irc/ircg/Makefile23
-rw-r--r--irc/ircg/distinfo2
-rw-r--r--irc/ircg/pkg-descr15
-rw-r--r--irc/ircg/pkg-plist9
4 files changed, 49 insertions, 0 deletions
diff --git a/irc/ircg/Makefile b/irc/ircg/Makefile
new file mode 100644
index 000000000000..b63d173daab2
--- /dev/null
+++ b/irc/ircg/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: iRCG
+# Date created: 2005-09-21
+# Whom: Alexander Novitsky <alecn2002@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iRCG
+PORTVERSION= 2.7
+CATEGORIES= irc
+MASTER_SITES= http://www.matthiaswinkelmann.com/files/
+
+MAINTAINER= alecn2002@yandex.ru
+COMMENT= Gateway betwean IRC server and PHP-powered Web server
+
+LIB_DEPENDS= st.1:${PORTSDIR}/devel/st
+
+WRKSRC= ${WRKDIR}/${DISTNAME:U}
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-st=${LOCALBASE}
+
+.include <bsd.port.mk>
diff --git a/irc/ircg/distinfo b/irc/ircg/distinfo
new file mode 100644
index 000000000000..781ed48882bb
--- /dev/null
+++ b/irc/ircg/distinfo
@@ -0,0 +1,2 @@
+MD5 (iRCG-2.7.tar.gz) = 1ae4439dbd596d597a31eff8784e2b64
+SIZE (iRCG-2.7.tar.gz) = 51488
diff --git a/irc/ircg/pkg-descr b/irc/ircg/pkg-descr
new file mode 100644
index 000000000000..999118126a1c
--- /dev/null
+++ b/irc/ircg/pkg-descr
@@ -0,0 +1,15 @@
+IRCG is a fast, scalable web chat framework that connects
+a php frontend with an irc backend. Sascha Schumann created
+IRCG a few years ago. Unfortunately, he decided to change the
+license to a commercial one starting with Version 3 and
+removed all traces of the BSD-Licensed IRCG 2. I kept on
+using the IRCG 2 sources and never had a problem with this setup.
+IRCG connects an irc server of your choice with a thttpd webserver.
+Using PHP, the frontend can be scripted. It?s mainly a framework
+for web-based chats, but could be used to pass any type of xml
+messages between multiple clients. Memory and CPU usage per client
+is quite low, so even an entry-level server can support hundreds of
+clients.
+
+Author: Matthias Winkelmann
+WWW: http://www.matthiaswinkelmann.com/
diff --git a/irc/ircg/pkg-plist b/irc/ircg/pkg-plist
new file mode 100644
index 000000000000..ae4d60cbd8bd
--- /dev/null
+++ b/irc/ircg/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+bin/driver
+bin/ircg-config
+include/if_irc.h
+include/queue.h
+include/php_smart_str_public.h
+include/irc_write_buffer.h
+include/ircg_config.h
+lib/libircg.a