aboutsummaryrefslogtreecommitdiff
path: root/irc/iroffer-dinoex/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-04-13 07:51:30 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-04-13 07:51:30 +0000
commit548da9f772da64664a8f3380c6ad7bd23efcd03a (patch)
tree0c715d3d559cd4d5a3880eb2e70d9bbd0c31d7b1 /irc/iroffer-dinoex/Makefile
parentdc79dacba728b4072f2e4db150181da7b334fcf9 (diff)
Notes
Diffstat (limited to 'irc/iroffer-dinoex/Makefile')
-rw-r--r--irc/iroffer-dinoex/Makefile78
1 files changed, 78 insertions, 0 deletions
diff --git a/irc/iroffer-dinoex/Makefile b/irc/iroffer-dinoex/Makefile
new file mode 100644
index 000000000000..4d3bbef5f350
--- /dev/null
+++ b/irc/iroffer-dinoex/Makefile
@@ -0,0 +1,78 @@
+# New ports collection makefile for: iroffer-dinoex
+# Date created: 10 Apr 2007
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= iroffer
+PORTVERSION= 3.13
+CATEGORIES= irc
+MASTER_SITES= http://iroffer.dinoex.net/
+PKGNAMESUFFIX= -dinoex${PKGNAMESUFFIX2}
+DISTNAME= iroffer-dinoex-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.ORG
+COMMENT= An IRC "bot" that makes sharing files via DCC extremely easy
+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= Configure
+MAN1= iroffer.1
+
+CONFLICTS= iroffer-1* iroffer-lamm-1.*
+
+OPTIONS= CURL "build ftp/http support" on \
+ RUBY "build RUBY script support" on \
+ UPNP "build UPNP support" on \
+ GEOIP "build GEOIP support" on \
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_CURL)
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= -curl
+.endif
+.if defined(WITH_GEOIP)
+LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
+CONFIGURE_ARGS+= -geoip
+.endif
+.if defined(WITH_UPNP)
+LIB_DEPENDS+= miniupnpc.3:${PORTSDIR}/net/miniupnpc
+CONFIGURE_ARGS+= -upnp
+.endif
+.if defined(WITH_RUBY)
+USE_RUBY= yes
+CONFIGURE_ARGS+= -ruby
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/iroffer ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README-iroffer.txt ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README.modDinoex ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/LIESMICH.modDinoex ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/THANKS ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/TODO ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/help-admin-en.txt ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/help-admin-de.txt ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/help-admin-it.txt ${DOCSDIR}/
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}/htdocs
+ ${INSTALL_DATA} ${WRKSRC}/iroffer.cron ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/sample.config ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/beispiel.config ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/header.html ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/footer.html ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/ruby-sample.rb ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/htdocs/iroffer-state.css \
+ ${WRKSRC}/htdocs/robots.txt \
+ ${EXAMPLESDIR}/htdocs/
+.endif
+ ${INSTALL_MAN} ${WRKSRC}/iroffer.1 ${PREFIX}/man/man1/
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>