aboutsummaryrefslogtreecommitdiff
path: root/irc/iroffer-dinoex
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2016-12-25 23:11:36 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2016-12-25 23:11:36 +0000
commit7a97406f0386fdd2f636de137599f8fa3c72e8a3 (patch)
tree20139c0ee8c6f9fd40bcb19a41a070f0a937b265 /irc/iroffer-dinoex
parent8d1478ada84dc7d298afd8455b2c9e8741cdf71e (diff)
downloadports-7a97406f0386fdd2f636de137599f8fa3c72e8a3.tar.gz
ports-7a97406f0386fdd2f636de137599f8fa3c72e8a3.zip
- update miniupnpc to 2.0.20161216
- bump API change
Notes
Notes: svn path=/head/; revision=429468
Diffstat (limited to 'irc/iroffer-dinoex')
-rw-r--r--irc/iroffer-dinoex/Makefile2
-rw-r--r--irc/iroffer-dinoex/files/patch-upnp.c26
2 files changed, 19 insertions, 9 deletions
diff --git a/irc/iroffer-dinoex/Makefile b/irc/iroffer-dinoex/Makefile
index 474c567e1b84..2ad68ba744f0 100644
--- a/irc/iroffer-dinoex/Makefile
+++ b/irc/iroffer-dinoex/Makefile
@@ -2,7 +2,7 @@
PORTNAME= iroffer
PORTVERSION= 3.30
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc
MASTER_SITES= http://iroffer.dinoex.net/
PKGNAMESUFFIX= -dinoex${PKGNAMESUFFIX2}
diff --git a/irc/iroffer-dinoex/files/patch-upnp.c b/irc/iroffer-dinoex/files/patch-upnp.c
index 55e6ddef2957..35e0e8f9a155 100644
--- a/irc/iroffer-dinoex/files/patch-upnp.c
+++ b/irc/iroffer-dinoex/files/patch-upnp.c
@@ -1,11 +1,5 @@
-Index: src/upnp.c
-===================================================================
-RCS file: /usr/home/public/iroffer/src/upnp.c,v
-retrieving revision 1.15
-retrieving revision 1.17
-diff -u -r1.15 -r1.17
---- src/upnp.c 13 Feb 2013 20:06:15 -0000 1.15
-+++ src/upnp.c 13 Oct 2015 18:30:24 -0000 1.17
+--- src/upnp.c.orig 2013-02-13 21:06:15.000000000 +0100
++++ src/upnp.c 2016-12-25 23:05:37.702936000 +0100
@@ -60,11 +60,15 @@
tostdout_write();
memset(&urls, 0, sizeof(struct UPNPUrls));
@@ -22,3 +16,19 @@ diff -u -r1.15 -r1.17
if (devlist)
{
dev = devlist;
+@@ -81,11 +85,15 @@
+ "UPnP device : desc: %s\n st: %s",
+ dev->descURL, dev->st);
+
++#if MINIUPNPC_API_VERSION >= 16
++ descXML = miniwget(dev->descURL, &descXMLsize, 0, 0);
++#else
+ #if MINIUPNPC_API_VERSION >= 9
+ descXML = miniwget(dev->descURL, &descXMLsize, 0);
+ #else
+ descXML = miniwget(dev->descURL, &descXMLsize);
+ #endif
++#endif
+ if (descXML)
+ {
+ parserootdesc (descXML, descXMLsize, &data);