aboutsummaryrefslogtreecommitdiff
path: root/irc/irssi/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2002-02-17 07:48:31 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2002-02-17 07:48:31 +0000
commitd68041ff0f5c60e8e748057b1ede4a61c002565f (patch)
treec9221aa0796d89e9fcd9c97f57ccfce5df71f60b /irc/irssi/Makefile
parent43b326ed067953d1e4823c4135fab7484d9dc40f (diff)
downloadports-d68041ff0f5c60e8e748057b1ede4a61c002565f.tar.gz
ports-d68041ff0f5c60e8e748057b1ede4a61c002565f.zip
Notes
Diffstat (limited to 'irc/irssi/Makefile')
-rw-r--r--irc/irssi/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index d27f8b6639e1..3db8ac5a6e2a 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -6,23 +6,24 @@
#
PORTNAME= irssi
-PORTVERSION= 0.7.98.4
+PORTVERSION= 0.8.0-20020217
PORTREVISION?= 0
CATEGORIES+= irc ipv6 # `+=' is for slave ports
-MASTER_SITES= http://irssi.org/files/
+MASTER_SITES= http://irssi.org/files/snapshots/
+DISTFILES= ${PORTNAME}-20020217${EXTRACT_SUFX}
MAINTAINER?= vanilla@FreeBSD.org
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
-USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.8.0
+#USE_BZIP2= yes
USE_PERL5= yes
USE_GLIB= yes
GNU_CONFIGURE= yes
# `+=' is for slave ports
-CONFIGURE_ARGS+= --without-socks --with-bot --without-servertest \
- --enable-perl-path=${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ARGS+= --without-socks --with-bot --with-textui \
+ --with-perl-lib=${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
.include <bsd.port.pre.mk>
@@ -39,12 +40,12 @@ pre-patch:
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
pre-configure:
- @cd ${WRKSRC} && ${MV} config config.sample
+ @cd ${WRKSRC} && ${MV} irssi.conf irssi.conf.sample
post-install:
- @if [ ! -f ${LOCALBASE}/etc/irssi/config ]; then \
+ @if [ ! -f ${LOCALBASE}/etc/irssi.conf ]; then \
${ECHO} "Installing default configuration file."; \
- ${INSTALL_SCRIPT} -m 644 ${WRKSRC}/config.sample ${LOCALBASE}/etc/irssi/config; \
+ ${INSTALL_SCRIPT} -m 644 ${WRKSRC}/irssi.conf.sample ${LOCALBASE}/etc/irssi.conf ; \
fi
.include <bsd.port.post.mk>