aboutsummaryrefslogtreecommitdiff
path: root/irc/irssi
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2010-04-07 01:53:34 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2010-04-07 01:53:34 +0000
commite995d60859a9b9ac53587e0173ec28b5e5afc28f (patch)
tree93032d46c3e8fbd63b720a6ad76df93e04fce4af /irc/irssi
parent0776dbed20a03a9bcec0efa793474df2db5d1def (diff)
downloadports-e995d60859a9b9ac53587e0173ec28b5e5afc28f.tar.gz
ports-e995d60859a9b9ac53587e0173ec28b5e5afc28f.zip
Notes
Diffstat (limited to 'irc/irssi')
-rw-r--r--irc/irssi/Makefile3
-rw-r--r--irc/irssi/distinfo6
-rw-r--r--irc/irssi/files/patch-core-network_openssl_c10
-rw-r--r--irc/irssi/files/patch-docs_Makefile.in11
-rw-r--r--irc/irssi/files/patch-openssl.c29
5 files changed, 14 insertions, 45 deletions
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index 3cb37e754b66..d1fa53955e63 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= irssi
-PORTVERSION= 0.8.14
-PORTREVISION?= 1
+PORTVERSION= 0.8.15
CATEGORIES?= irc
MASTER_SITES= http://mirror.irssi.org/
diff --git a/irc/irssi/distinfo b/irc/irssi/distinfo
index 864ad4f6286f..bc0f578274cb 100644
--- a/irc/irssi/distinfo
+++ b/irc/irssi/distinfo
@@ -1,3 +1,3 @@
-MD5 (irssi-0.8.14.tar.bz2) = 00efe7638dd596d5930dfa2aeae87b3a
-SHA256 (irssi-0.8.14.tar.bz2) = 63ea70eb1ce6fb3c995e984f919dcd18882e916478779dd899de9385ef8fdf28
-SIZE (irssi-0.8.14.tar.bz2) = 944708
+MD5 (irssi-0.8.15.tar.bz2) = 1dcb3f511b88df94b0c996f36668c7da
+SHA256 (irssi-0.8.15.tar.bz2) = c12d16fb605103d7c256ddce44012dc396af57f3771e086d0387c195a052a0a6
+SIZE (irssi-0.8.15.tar.bz2) = 948847
diff --git a/irc/irssi/files/patch-core-network_openssl_c b/irc/irssi/files/patch-core-network_openssl_c
new file mode 100644
index 000000000000..1f8692f69102
--- /dev/null
+++ b/irc/irssi/files/patch-core-network_openssl_c
@@ -0,0 +1,10 @@
+--- src/core/network-openssl.c.orig 2010-04-03 17:32:04.000000000 +0000
++++ src/core/network-openssl.c 2010-04-03 17:37:34.000000000 +0000
+@@ -406,6 +406,7 @@
+ g_error("Could not allocate memory for SSL context");
+ return NULL;
+ }
++ SSL_CTX_set_options(ctx, SSL_OP_ALL | SSL_OP_NO_SSLv2);
+
+ if (mycert && *mycert) {
+ char *scert = NULL, *spkey = NULL;
diff --git a/irc/irssi/files/patch-docs_Makefile.in b/irc/irssi/files/patch-docs_Makefile.in
deleted file mode 100644
index a2afc6254918..000000000000
--- a/irc/irssi/files/patch-docs_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- docs/Makefile.in.orig 2009-04-01 05:02:52.000000000 +0800
-+++ docs/Makefile.in 2009-04-02 09:29:16.000000000 +0800
-@@ -51,7 +51,7 @@
- install-pdf-recursive install-ps-recursive install-recursive \
- installcheck-recursive installdirs-recursive pdf-recursive \
- ps-recursive uninstall-recursive
--man1dir = $(mandir)/man1
-+man1dir = $(prefix)/man/man1
- am__installdirs = "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(docdir)"
- NROFF = nroff
- MANS = $(man_MANS)
diff --git a/irc/irssi/files/patch-openssl.c b/irc/irssi/files/patch-openssl.c
deleted file mode 100644
index 740de1a3714c..000000000000
--- a/irc/irssi/files/patch-openssl.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/core/network-openssl.c.orig 2009-08-17 09:27:52.000000000 +0800
-+++ src/core/network-openssl.c 2009-08-17 09:28:14.000000000 +0800
-@@ -230,7 +230,7 @@
- SSL_library_init();
- SSL_load_error_strings();
-
-- ssl_ctx = SSL_CTX_new(SSLv23_client_method());
-+ ssl_ctx = SSL_CTX_new(SSLv3_client_method());
- if(!ssl_ctx)
- {
- g_error("Initialization of the SSL library failed");
-@@ -259,7 +259,7 @@
-
- if (mycert && *mycert) {
- char *scert = NULL, *spkey = NULL;
-- if ((ctx = SSL_CTX_new(SSLv23_client_method())) == NULL) {
-+ if ((ctx = SSL_CTX_new(SSLv3_client_method())) == NULL) {
- g_error("Could not allocate memory for SSL context");
- return NULL;
- }
-@@ -279,7 +279,7 @@
- if ((cafile && *cafile) || (capath && *capath)) {
- char *scafile = NULL;
- char *scapath = NULL;
-- if (! ctx && (ctx = SSL_CTX_new(SSLv23_client_method())) == NULL) {
-+ if (! ctx && (ctx = SSL_CTX_new(SSLv3_client_method())) == NULL) {
- g_error("Could not allocate memory for SSL context");
- return NULL;
- }