aboutsummaryrefslogtreecommitdiff
path: root/irc/konversation/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-05-30 21:10:24 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-05-30 21:10:24 +0000
commit56f30722c2ff99613b941fd3e3a3546b1171171f (patch)
tree18700660c5b2c1538785b95034b4ea76c4a03c1a /irc/konversation/Makefile
parent084631492834e99f797a7afb3ec2e5b1caca7c04 (diff)
downloadports-56f30722c2ff99613b941fd3e3a3546b1171171f.tar.gz
ports-56f30722c2ff99613b941fd3e3a3546b1171171f.zip
Notes
Diffstat (limited to 'irc/konversation/Makefile')
-rw-r--r--irc/konversation/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/irc/konversation/Makefile b/irc/konversation/Makefile
new file mode 100644
index 000000000000..e088fe2b6e92
--- /dev/null
+++ b/irc/konversation/Makefile
@@ -0,0 +1,34 @@
+# Created by: Kirill Ponomarew <ponomarew@oberon.net>
+# $FreeBSD$
+
+PORTNAME= konversation
+PORTVERSION= 1.7.2
+CATEGORIES= irc kde
+MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}/src
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= User friendly IRC client for KDE
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libqca-qt5.so:devel/qca-qt5
+
+USES= cmake:outsource desktop-file-utils gettext kde:5 python:run shebangfix tar:xz
+USE_KDE= archive auth bookmarks codecs completion config \
+ configwidgets coreaddons crash dbusaddons doctools ecm \
+ emoticons globalaccel i18n iconthemes idletime itemviews \
+ jobwidgets kio notifications notifyconfig parts service solid \
+ sonnet textwidgets wallet widgetsaddons windowsystem xmlgui
+USE_QT5= core dbus gui network phonon4 widgets xml \
+ buildtools_build qmake_build
+
+SHEBANG_FILES= data/scripts/bug \
+ data/scripts/cmd \
+ data/scripts/mail \
+ data/scripts/media \
+ data/scripts/sayclip \
+ data/scripts/sysinfo \
+ data/updaters/*.pl
+
+.include <bsd.port.mk>