aboutsummaryrefslogtreecommitdiff
path: root/irc/lostirc
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-08 06:22:10 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-08 06:22:10 +0000
commitd47622b73b61d28c3a08731d7a655ce32667663c (patch)
treeb4e0f17e469f1c08ba17c7708d88798476e9350d /irc/lostirc
parent01c6d5e416ece9b33c66af5e8afac0a7f5c71994 (diff)
downloadports-d47622b73b61d28c3a08731d7a655ce32667663c.tar.gz
ports-d47622b73b61d28c3a08731d7a655ce32667663c.zip
Notes
Diffstat (limited to 'irc/lostirc')
-rw-r--r--irc/lostirc/Makefile15
-rw-r--r--irc/lostirc/distinfo2
-rw-r--r--irc/lostirc/files/patch-src::libirc::Parser.cpp11
-rw-r--r--irc/lostirc/pkg-plist8
4 files changed, 26 insertions, 10 deletions
diff --git a/irc/lostirc/Makefile b/irc/lostirc/Makefile
index 4590f8ae2f35..90c7e03f9a18 100644
--- a/irc/lostirc/Makefile
+++ b/irc/lostirc/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lostirc
-PORTVERSION= 0.2.5
-PORTREVISION= 1
+PORTVERSION= 0.2.7
CATEGORIES= irc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= rael@vectorstar.net
COMMENT= LostIRC is a simple and minimal IRC client for X
-LIB_DEPENDS= gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2 \
+LIB_DEPENDS= gtkmm-2:${PORTSDIR}/x11-toolkits/gtk--2 \
intl.4:${PORTSDIR}/devel/gettext
USE_X_PREFIX= yes
@@ -29,13 +28,15 @@ DOCS= AUTHORS COPYING ChangeLog TODO README INSTALL
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
post-patch:
${REINPLACE_CMD} -E "s@^(Gnomedir = ).*@\1${PREFIX}/share/gnome/apps/Internet@" ${WRKSRC}/Makefile.am
${REINPLACE_CMD} -E "s@(Gnomedir = ).*@\1${PREFIX}/share/gnome/apps/Internet@" ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -E "s@^(pixmapdir = ).*@\1${PREFIX}/share/gnome/pixmaps@" ${WRKSRC}/Makefile.am
+ ${REINPLACE_CMD} -E "s@(pixmapdir = ).*@\1${PREFIX}/share/gnome/pixmaps@" ${WRKSRC}/Makefile.in
+
+pre-install:
+ ${REINPLACE_CMD} -E 's|MKINSTALLDIRS = \$$\(top_builddir\)/|MKINSTALLDIRS = |g' ${WRKSRC}/intl/Makefile
+ ${REINPLACE_CMD} -E 's|MKINSTALLDIRS = \$$\(top_builddir\)/|MKINSTALLDIRS = |g' ${WRKSRC}/po/Makefile
post-install:
.if !defined(NOPORTDOCS)
diff --git a/irc/lostirc/distinfo b/irc/lostirc/distinfo
index 1fe4fc956216..f7ddd918b1f1 100644
--- a/irc/lostirc/distinfo
+++ b/irc/lostirc/distinfo
@@ -1 +1 @@
-MD5 (lostirc-0.2.5.tar.gz) = 978eb7dd736c95a1dc1892cf67aec2c2
+MD5 (lostirc-0.2.7.tar.gz) = 0b6f09dcbcb06076bdc6b17e39456c5c
diff --git a/irc/lostirc/files/patch-src::libirc::Parser.cpp b/irc/lostirc/files/patch-src::libirc::Parser.cpp
new file mode 100644
index 000000000000..a71575d93d2a
--- /dev/null
+++ b/irc/lostirc/files/patch-src::libirc::Parser.cpp
@@ -0,0 +1,11 @@
+--- src/libirc/Parser.cpp.orig Sat May 31 09:25:44 2003
++++ src/libirc/Parser.cpp Mon Jul 7 00:37:53 2003
+@@ -681,7 +681,7 @@
+ ss >> time;
+
+ long date = std::atol(time.c_str());
+- time = std::ctime(&date);
++ time = std::ctime((const time_t *)&date);
+
+ Channel *c = _conn->findChannel(chan);
+ assert(c);
diff --git a/irc/lostirc/pkg-plist b/irc/lostirc/pkg-plist
index c187a35df069..2d061aab9318 100644
--- a/irc/lostirc/pkg-plist
+++ b/irc/lostirc/pkg-plist
@@ -1,7 +1,10 @@
-share/gnome/apps/Internet/lostirc.desktop
+bin/lostirc
+lib/charset.alias
share/applnk/lostirc.desktop
+share/gnome/apps/Internet/lostirc.desktop
+share/gnome/pixmaps/lostirc.png
share/locale/da/LC_MESSAGES/lostirc.mo
-bin/lostirc
+share/locale/locale.alias
%%PORTDOCS%%share/doc/lostirc/AUTHORS
%%PORTDOCS%%share/doc/lostirc/COPYING
%%PORTDOCS%%share/doc/lostirc/ChangeLog
@@ -9,3 +12,4 @@ bin/lostirc
%%PORTDOCS%%share/doc/lostirc/README
%%PORTDOCS%%share/doc/lostirc/TODO
%%PORTDOCS%%@dirrm share/doc/lostirc
+