aboutsummaryrefslogtreecommitdiff
path: root/irc/nefarious
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-05 21:23:51 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-05 21:23:51 +0000
commit907704416b43aecee5b2fdf49bfa0d12acac33ec (patch)
tree401b7bb1c95ddcfcf9c80434783101e6bb541fb9 /irc/nefarious
parent2b4f0257f1b1229c5ca41f5d8c9e47b15c90038d (diff)
downloadports-907704416b43aecee5b2fdf49bfa0d12acac33ec.tar.gz
ports-907704416b43aecee5b2fdf49bfa0d12acac33ec.zip
Notes
Diffstat (limited to 'irc/nefarious')
-rw-r--r--irc/nefarious/Makefile49
-rw-r--r--irc/nefarious/files/patch-configure17
-rw-r--r--irc/nefarious/files/patch-ircd_m__help.c19
-rw-r--r--irc/nefarious/pkg-plist1
4 files changed, 60 insertions, 26 deletions
diff --git a/irc/nefarious/Makefile b/irc/nefarious/Makefile
index e7873d2f87e2..14bba1457bd1 100644
--- a/irc/nefarious/Makefile
+++ b/irc/nefarious/Makefile
@@ -12,41 +12,46 @@ COMMENT= IRC server used by evilnet based off of Undernet\'s ircu
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-USE_BZIP2= yes
+USES= tar:bzip2
HAS_CONFIGURE= yes
PLIST_SUB+= INSTALL_PREFIX=${INSTALL_PREFIX:S/${PREFIX}\///}
-MAN8= ircd.8
-.if defined(WITH_OPENSSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --enable-ssl
-.endif
+OPTIONS_DEFINE= SSL CHROOT
+CHROOT_DESC= Chroot the irc daemon within INSTALL_PREFIX
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+SSL_CONFIGURE_ENABLE= ssl
-.if !defined(INSTALL_PREFIX)
+.include <bsd.port.options.mk>
+
+.if defined(NEFARIUS_INSTALL_PREFIX)
+INSTALL_PREFIX=${NEFARIUS_INSTALL_PREFIX}
+.else
INSTALL_PREFIX=${PREFIX}/${PORTNAME}
.endif
-.if defined(WITH_CHROOT)
+.if ${PORT_OPTIONS:MSSL}
+USE_OPENSSL= yes
+.endif
+
+.if ${PORT_OPTIONS:MCHROOT}
CONFIGURE_ARGS+= --with-chroot=${INSTALL_PREFIX}
.endif
-.if defined(DOMAIN)
-CONFIGURE_ARGS+= --with-domain=${DOMAIN}
+.if defined(NEFARIOUS_DOMAIN)
+CONFIGURE_ARGS+= --with-domain=${NEFARIOUS_DOMAIN}
.endif
-CONFIGURE_ARGS+= --prefix=${INSTALL_PREFIX} --mandir=${MANPREFIX}/man --infodir=${PREFIX}/${INFO_PATH}
+CONFIGURE_ARGS+= --prefix=${STAGEDIR}${INSTALL_PREFIX} \
+ --mandir=${STAGEDIR}${MANPREFIX}/man
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|@PREFIX@|${PREFIX}|g' ${WRKSRC}/configure
pre-configure:
- @${ECHO_CMD} ""
+ @${ECHO_CMD}
@${ECHO_CMD} "User configurable options for ${PORTNAME}:"
- @${ECHO_CMD} "INSTALL_PREFIX - Where to install all Nefarious files (default: PREFIX/Nefarious)"
- @${ECHO_CMD} "WITH_OPENSSL - Compile with SSL support"
- @${ECHO_CMD} "WITH_CHROOT - chroot the ircd within INSTALL_PREFIX"
- @${ECHO_CMD} "DOMAIN - Domain to use for IRCd"
- @${ECHO_CMD} ""
- @sleep 5
-
-.include <bsd.port.post.mk>
+ @${ECHO_CMD} "NEFARIOUS_INSTALL_PREFIX - Install location for Nefarious (default: ${PREFIX}/Nefarious)"
+ @${ECHO_CMD} "NEFARIOUS_DOMAIN - Domain to use for IRCd"
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/irc/nefarious/files/patch-configure b/irc/nefarious/files/patch-configure
index 38daf2504f75..3692249da7db 100644
--- a/irc/nefarious/files/patch-configure
+++ b/irc/nefarious/files/patch-configure
@@ -1,11 +1,20 @@
---- configure.orig 2009-07-31 23:06:12.000000000 -0300
-+++ configure 2009-07-31 23:06:29.000000000 -0300
-@@ -10364,7 +10364,7 @@
+--- configure.orig 2008-08-04 02:56:02.000000000 +0000
++++ configure
+@@ -10364,7 +10364,7 @@ fi
test -n "$BASH" && break
done
-test -n "$BASH" || BASH="/bin/bash"
-+test -n "$BASH" || BASH="/usr/local/bin/bash"
++test -n "$BASH" || BASH="@PREFIX@/bin/bash"
{ echo "$as_me:$LINENO: checking for posix non-blocking" >&5
+@@ -10783,7 +10783,7 @@ echo "${ECHO_T}OpenBSD ($host) found." >
+ OSDEP_C=os_openbsd.c
+ ;;
+
+- *-*bsd*)
++ *-*bsd*|*-dragonfly*)
+ { echo "$as_me:$LINENO: result: Generic BSD ($host) found." >&5
+ echo "${ECHO_T}Generic BSD ($host) found." >&6; }
+ CFLAGS="-Wno-long-long $CFLAGS"
diff --git a/irc/nefarious/files/patch-ircd_m__help.c b/irc/nefarious/files/patch-ircd_m__help.c
new file mode 100644
index 000000000000..88365ba776bd
--- /dev/null
+++ b/irc/nefarious/files/patch-ircd_m__help.c
@@ -0,0 +1,19 @@
+--- ircd/m_help.c.orig 2008-08-04 02:55:42.000000000 +0000
++++ ircd/m_help.c
+@@ -243,6 +243,7 @@ sendhelpfile(struct Client *sptr, const
+ send_reply(sptr, RPL_ENDOFHELP, topic);
+ }
+
++void
+ dohelp(struct Client *sptr, const char *hpath, char *topic)
+ {
+ char path[PATH_MAX + 1];
+@@ -291,7 +292,7 @@ dohelp(struct Client *sptr, const char *
+ sendhelpfile(sptr, path, topic);
+ }
+
+-int m_help(struct Client* cptr, struct Client* sptr, int parc, char* parv[])
++void m_help(struct Client* cptr, struct Client* sptr, int parc, char* parv[])
+ {
+ static time_t last_used = 0;
+
diff --git a/irc/nefarious/pkg-plist b/irc/nefarious/pkg-plist
index 688c232eb55e..6ffe5f4fa78e 100644
--- a/irc/nefarious/pkg-plist
+++ b/irc/nefarious/pkg-plist
@@ -1,3 +1,4 @@
+man/man8/ircd.8.gz
%%INSTALL_PREFIX%%/bin/ircd
%%INSTALL_PREFIX%%/bin/chkconf
%%INSTALL_PREFIX%%/lib/example.conf