aboutsummaryrefslogtreecommitdiff
path: root/irc/ngircd/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-09-16 15:36:13 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-09-16 15:36:13 +0000
commitcf2958eeb67737514e6ee965cf0639a63235e30a (patch)
treeca1d1a39c762c60ed7455a1b589a48286383c9c3 /irc/ngircd/Makefile
parent920ac3ebac58b22f137921a19b91213e225ab54e (diff)
downloadports-cf2958eeb67737514e6ee965cf0639a63235e30a.tar.gz
ports-cf2958eeb67737514e6ee965cf0639a63235e30a.zip
Notes
Diffstat (limited to 'irc/ngircd/Makefile')
-rw-r--r--irc/ngircd/Makefile49
1 files changed, 25 insertions, 24 deletions
diff --git a/irc/ngircd/Makefile b/irc/ngircd/Makefile
index b558103eedb5..e0461311aa39 100644
--- a/irc/ngircd/Makefile
+++ b/irc/ngircd/Makefile
@@ -26,58 +26,59 @@ CPPFLAGS+= -I${LOCALBASE}/include
MAN5= ngircd.conf.5
MAN8= ngircd.8
-OPTIONS= TCP_WRAPPERS "Enable TCP wrappers support" on \
- SYSLOG "Enable SYSLOG support" on \
- ZLIB "Enable ZLIB compression" on \
- IPV6 "Enable IPV6" on \
- OPENSSL "Enable OpenSSL support" off \
- GNUTLS "Enable GnuTLS support" off \
- IRCPLUS "Enable IRC+ protocol" on \
- IDENT "Enable IDENT (AUTH) protocol support" off \
- SNIFFER "Enable IRC traffic sniffer" off \
- DEBUG "Show additional debug output" off
-
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE=TCP_WRAPPERS SYSLOG ZLIB IPV6 OPENSSL GNUTLS IRCPLUS IDENT SNIFFER DEBUG
+OPTIONS_DEFAULT=TCP_WRAPPERS SYSLOG ZLIB IPV6 IRCPLUS
+NO_OPTIONS_SORT=yes
+TCP_WRAPPERS_DESC=Enable TCP wrappers support
+SYSLOG_DESC=Enable syslog() support
+ZLIB_DESC=Enable ZLIB compression
+IRCPLUS_DESC=Enable IRC+ protocol
+IDENT_DESC=Enable IDENT (AUTH) protocol support
+SNIFFER_DESC=Enable IRC traffic sniffer
+DEBUG_DESC=Show additional debug output
+
+.include <bsd.port.options.mk>
.if exists(/usr/include/tcpd.h) && !defined(WITHOUT_TCP_WRAPPERS)
CONFIGURE_ARGS+= --with-tcp-wrappers
.endif
-.if defined(WITHOUT_SYSLOG)
+.if empty(PORT_OPTIONS:MSYSLOG)
CONFIGURE_ARGS+= --without-syslog
.endif
-.if defined(WITHOUT_ZLIB)
+.if empty(PORT_OPTIONS:MZLIB)
CONFIGURE_ARGS+= --without-zlib
.endif
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.endif
-.if defined(WITH_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
CONFIGURE_ARGS+= --with-openssl
+USE_OPENSSL=yes
.endif
-.if defined(WITH_GNUTLS)
+.if ${PORT_OPTIONS:MGNUTLS}
CONFIGURE_ARGS+= --with-gnutls
-USE_OPENSSL=yes
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
.endif
-.if defined(WITHOUT_IRCPLUS)
+.if empty(PORT_OPTIONS:MIRCPLUS)
CONFIGURE_ARGS+= --disable-ircplus
.endif
-.if defined(WITH_IDENT)
-LIB_DEPENDS+= ident.0:${PORTSDIR}/security/libident
+.if ${PORT_OPTIONS:MIDENT}
+LIB_DEPENDS+= ident:${PORTSDIR}/security/libident
CONFIGURE_ARGS+= --with-ident
.endif
-.if defined(WITH_SNIFFER)
+.if ${PORT_OPTIONS:MSNIFFER}
CONFIGURE_ARGS+= --enable-sniffer
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
.endif
@@ -85,4 +86,4 @@ CONFIGURE_ARGS+= --enable-debug
MAKE_ARGS+= NOPORTDOCS=yes
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>