aboutsummaryrefslogtreecommitdiff
path: root/irc/ngircd
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-02-13 16:56:11 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-02-13 16:56:11 +0000
commitd403e8a3309d0fcf54a770184564407a95e90ad3 (patch)
treed09673557ff9e66a4fe92ac9f542ec8671f70027 /irc/ngircd
parent5fa7679490f51392f48e1ea2c595a22fd0947357 (diff)
downloadports-d403e8a3309d0fcf54a770184564407a95e90ad3.tar.gz
ports-d403e8a3309d0fcf54a770184564407a95e90ad3.zip
Notes
Diffstat (limited to 'irc/ngircd')
-rw-r--r--irc/ngircd/Makefile54
-rw-r--r--irc/ngircd/files/ngircd.in33
2 files changed, 61 insertions, 26 deletions
diff --git a/irc/ngircd/Makefile b/irc/ngircd/Makefile
index d07c86c95a81..e81c5da4eb3e 100644
--- a/irc/ngircd/Makefile
+++ b/irc/ngircd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ngircd
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://download.berlios.de/ngircd/ \
ftp://ftp.berlios.de/pub/ngircd/
@@ -14,22 +15,27 @@ MASTER_SITES= http://download.berlios.de/ngircd/ \
MAINTAINER= laszlof@vonostingroup.com
COMMENT= Free open source daemon for Internet Relay Chat (IRC)
+USE_RC_SUBR= ngircd
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
MAN5= ngircd.conf.5
MAN8= ngircd.8
-.if exists(/usr/include/tcpd.h)
-WITH_TCP_WRAPPERS= yes
-CONFIGURE_ARGS+= --with-tcp-wrappers
-.endif
+OPTIONS= TCP_WRAPPERS "Enable TCP wrappers support" on \
+ SYSLOG "Enable SYSLOG support" on \
+ ZLIB "Enable ZLIB compression" on \
+ IRCPLUS "Enable IRC+ protocol" on \
+ IDENT "Enable IDENT (AUTH) protocol support" off \
+ SNIFFER "Enable IRC traffic sniffer" off \
+ DEBUG "Show additional debug output" off
-.if defined(WITH_IDENT)
-LIB_DEPENDS+= ident.0:${PORTSDIR}/security/libident
-CONFIGURE_ARGS+= --with-ident
+.include <bsd.port.pre.mk>
+
+.if exists(/usr/include/tcpd.h) && !defined(WITHOUT_TCP_WRAPPERS)
+CONFIGURE_ARGS+= --with-tcp-wrappers
.endif
.if defined(WITHOUT_SYSLOG)
@@ -40,31 +46,27 @@ CONFIGURE_ARGS+= --without-syslog
CONFIGURE_ARGS+= --without-zlib
.endif
-pre-configure:
- @${ECHO_MSG} ""
-.if defined(WITH_TCP_WRAPPERS)
- @${ECHO_MSG} "Enable TCP wrappers support"
- @${ECHO_MSG} ""
+.if defined(WITHOUT_IRCPLUS)
+CONFIGURE_ARGS+= --disable-ircplus
.endif
+
.if defined(WITH_IDENT)
- @${ECHO_MSG} "Enable ident support"
- @${ECHO_MSG} ""
+LIB_DEPENDS+= ident.0:${PORTSDIR}/security/libident
+CONFIGURE_ARGS+= --with-ident
.endif
-.if defined(WITHOUT_SYSLOG)
- @${ECHO_MSG} "Disable syslog support"
- @${ECHO_MSG} ""
+
+.if defined(WITH_SNIFFER)
+CONFIGURE_ARGS+= --enable-sniffer
.endif
-.if defined(WITHOUT_ZLIB)
- @${ECHO_MSG} "Disable zlib suppot"
- @${ECHO_MSG} ""
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
.endif
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in README
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/irc/ngircd/files/ngircd.in b/irc/ngircd/files/ngircd.in
new file mode 100644
index 000000000000..8dfb916b0de4
--- /dev/null
+++ b/irc/ngircd/files/ngircd.in
@@ -0,0 +1,33 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: ngircd
+# REQUIRE: DAEMON
+#
+# Add the following lines to /etc/rc.conf to run ngircd:
+#
+# ngircd_enable (bool): Set it to "YES" to enable ngircd.
+# Default is "NO".
+# ngircd_conf (file): Set local of config file.
+# Default is "%%PREFIX%%/etc/ngircd.conf".
+# ngircd_flags (flags): Set extra flags here. More options in ngircd(1)
+# Default is empty "".
+#
+
+. %%RC_SUBR%%
+
+name="ngircd"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${ngircd_enable="NO"}
+: ${ngircd_conf="%%PREFIX%%/etc/ngircd.conf"}
+: ${ngircd_flags=""}
+
+required_files="${ngircd_conf}"
+command=%%PREFIX%%/sbin/ngircd
+command_args="-f ${ngircd_conf} ${ngircd_flags}"
+
+run_rc_command "$1"