aboutsummaryrefslogtreecommitdiff
path: root/irc/p5-AnyEvent-IRC
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-11-05 06:49:05 +0000
committerWen Heping <wen@FreeBSD.org>2009-11-05 06:49:05 +0000
commit814eb146062fd383abb648dbcb8b7f8ee6e412c1 (patch)
tree49970ada8e482e6cdf6464e27b275e8ebd2e1b8a /irc/p5-AnyEvent-IRC
parent24e6f6321d984b522c9928ca443f15f9b4b101ca (diff)
downloadports-814eb146062fd383abb648dbcb8b7f8ee6e412c1.tar.gz
ports-814eb146062fd383abb648dbcb8b7f8ee6e412c1.zip
Notes
Diffstat (limited to 'irc/p5-AnyEvent-IRC')
-rw-r--r--irc/p5-AnyEvent-IRC/Makefile28
-rw-r--r--irc/p5-AnyEvent-IRC/distinfo3
-rw-r--r--irc/p5-AnyEvent-IRC/pkg-descr3
-rw-r--r--irc/p5-AnyEvent-IRC/pkg-plist9
4 files changed, 43 insertions, 0 deletions
diff --git a/irc/p5-AnyEvent-IRC/Makefile b/irc/p5-AnyEvent-IRC/Makefile
new file mode 100644
index 000000000000..4c4025b2f5b5
--- /dev/null
+++ b/irc/p5-AnyEvent-IRC/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-AnyEvent-IRC
+# Date created: 05 Nov, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyEvent-IRC
+PORTVERSION= 0.95
+CATEGORIES= irc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= An event system independend IRC protocol module
+
+BUILD_DEPENDS= p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-Object-Event>=0.7:${PORTSDIR}/devel/p5-Object-Event
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= AnyEvent::IRC::Client.3 \
+ AnyEvent::IRC::Connection.3 \
+ AnyEvent::IRC.3 \
+ AnyEvent::IRC::Util.3
+
+.include <bsd.port.mk>
diff --git a/irc/p5-AnyEvent-IRC/distinfo b/irc/p5-AnyEvent-IRC/distinfo
new file mode 100644
index 000000000000..0ddf4a024f69
--- /dev/null
+++ b/irc/p5-AnyEvent-IRC/distinfo
@@ -0,0 +1,3 @@
+MD5 (AnyEvent-IRC-0.95.tar.gz) = 3b5151a91e2c7404560d63194a34388b
+SHA256 (AnyEvent-IRC-0.95.tar.gz) = d05724619f3073d203e376d7ad8f70c230685889ca4812d2b1101f9ba328fd77
+SIZE (AnyEvent-IRC-0.95.tar.gz) = 28510
diff --git a/irc/p5-AnyEvent-IRC/pkg-descr b/irc/p5-AnyEvent-IRC/pkg-descr
new file mode 100644
index 000000000000..e54504418022
--- /dev/null
+++ b/irc/p5-AnyEvent-IRC/pkg-descr
@@ -0,0 +1,3 @@
+AnyEvent::IRC is an event system independend IRC protocol module.
+
+WWW: http://search.cpan.org/dist/AnyEvent-IRC
diff --git a/irc/p5-AnyEvent-IRC/pkg-plist b/irc/p5-AnyEvent-IRC/pkg-plist
new file mode 100644
index 000000000000..13a765f2d88b
--- /dev/null
+++ b/irc/p5-AnyEvent-IRC/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/AnyEvent/IRC.pm
+%%SITE_PERL%%/AnyEvent/IRC/Client.pm
+%%SITE_PERL%%/AnyEvent/IRC/Connection.pm
+%%SITE_PERL%%/AnyEvent/IRC/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/IRC/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/IRC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent
+@dirrm %%SITE_PERL%%/AnyEvent/IRC
+@dirrmtry %%SITE_PERL%%/AnyEvent