aboutsummaryrefslogtreecommitdiff
path: root/irc/p5-POE-Component-IRC-Plugin-QueryDNS
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-20 22:15:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-20 22:15:45 +0000
commit6ee10a6302f6e1426f127e5c4584aa6938fbc0cf (patch)
tree6875a96566fcbc37f72685daaaacfe49cc93ece0 /irc/p5-POE-Component-IRC-Plugin-QueryDNS
parent5b5db960b8bdafcabac58cc508beb944d5938963 (diff)
downloadports-6ee10a6302f6e1426f127e5c4584aa6938fbc0cf.tar.gz
ports-6ee10a6302f6e1426f127e5c4584aa6938fbc0cf.zip
POE::Component::IRC::Plugin::QueryDNS is a POE::Component::IRC plugin
that provides DNS query facilities to the channels it occupies and via private messaging. It uses POE::Component::Client::DNS to do non-blocking DNS queries. By default the plugin attempts to use POE::Component::IRC's internal PoCo-Client-DNS resolver object, but will spawn its own copy. You can supply your own resolver object via the constructor. WWW: http://search.cpan.org/dist/POE-Component-IRC-Plugin-QueryDNS/
Notes
Notes: svn path=/head/; revision=215417
Diffstat (limited to 'irc/p5-POE-Component-IRC-Plugin-QueryDNS')
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile35
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNS/distinfo3
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-descr10
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-plist13
4 files changed, 61 insertions, 0 deletions
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile
new file mode 100644
index 000000000000..83b561756d83
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-POE-Component-IRC-Plugin-QueryDNS
+# Date created: 20.06.2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-IRC-Plugin-QueryDNS
+PORTVERSION= 0.06
+CATEGORIES= irc perl5 devel
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A POE::Component::IRC plugin for IRC based DNS queries
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
+ p5-POE-Component-Client-DNS>=1.00:${PORTSDIR}/dns/p5-POE-Component-Client-DNS
+RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
+ p5-POE-Component-Client-DNS>=1.00:${PORTSDIR}/dns/p5-POE-Component-Client-DNS
+
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::IRC::Plugin::QueryDNS.3
+
+post-install:
+.ifndef(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/distinfo b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/distinfo
new file mode 100644
index 000000000000..ced3b1798f31
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-IRC-Plugin-QueryDNS-0.06.tar.gz) = 68e03a0e2af03a2b0cbd766ad5988f9a
+SHA256 (POE-Component-IRC-Plugin-QueryDNS-0.06.tar.gz) = a41455b58ad4601f7530efe92286d8b8d140324f2b20976fd43bedf93318cafe
+SIZE (POE-Component-IRC-Plugin-QueryDNS-0.06.tar.gz) = 22004
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-descr b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-descr
new file mode 100644
index 000000000000..cbe16ee71289
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-descr
@@ -0,0 +1,10 @@
+POE::Component::IRC::Plugin::QueryDNS is a POE::Component::IRC plugin
+that provides DNS query facilities to the channels it occupies and via
+private messaging.
+
+It uses POE::Component::Client::DNS to do non-blocking DNS queries. By
+default the plugin attempts to use POE::Component::IRC's internal
+PoCo-Client-DNS resolver object, but will spawn its own copy. You can
+supply your own resolver object via the constructor.
+
+WWW: http://search.cpan.org/dist/POE-Component-IRC-Plugin-QueryDNS/
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-plist
new file mode 100644
index 000000000000..ffd32ac3ca56
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNS/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/POE/Component/IRC/Plugin/QueryDNS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/QueryDNS/.packlist
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/QueryDNS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE