aboutsummaryrefslogtreecommitdiff
path: root/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-20 22:12:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-20 22:12:18 +0000
commitdf1cac78453b8d7a47d43182e42406d234554f5c (patch)
treef663173a5efb7c28b4c00fc4fcd6fd8edb45c7dc /irc/p5-POE-Component-IRC-Plugin-QueryDNSBL
parent564d3c266b93e55f7a8bf09672c4be6cb26c4c32 (diff)
downloadports-df1cac78453b8d7a47d43182e42406d234554f5c.tar.gz
ports-df1cac78453b8d7a47d43182e42406d234554f5c.zip
Notes
Diffstat (limited to 'irc/p5-POE-Component-IRC-Plugin-QueryDNSBL')
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile35
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/distinfo3
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-descr10
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-plist13
4 files changed, 61 insertions, 0 deletions
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile
new file mode 100644
index 000000000000..faf4def1f7a0
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-POE-Component-IRC-Plugin-QueryDNSBL
+# Date created: 20.06.2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-IRC-Plugin-QueryDNSBL
+PORTVERSION= 0.06
+CATEGORIES= irc perl5 devel
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A POE::Component::IRC plugin for IRC based DNSBL queries
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
+ p5-POE-Component-Client-DNS>=1.00:${PORTSDIR}/dns/p5-POE-Component-Client-DNS
+RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
+ p5-POE-Component-Client-DNS>=1.00:${PORTSDIR}/dns/p5-POE-Component-Client-DNS
+
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::IRC::Plugin::QueryDNSBL.3
+
+post-install:
+.ifndef(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/distinfo b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/distinfo
new file mode 100644
index 000000000000..ccf0bf90efe0
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-IRC-Plugin-QueryDNSBL-0.06.tar.gz) = 7391f3ced177431b4cdc54cc1cdcf432
+SHA256 (POE-Component-IRC-Plugin-QueryDNSBL-0.06.tar.gz) = d7e1d5ffa78b7bdab465d2b0f045e544bb4871ba4df3dc50d39e477410470b5f
+SIZE (POE-Component-IRC-Plugin-QueryDNSBL-0.06.tar.gz) = 21365
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-descr b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-descr
new file mode 100644
index 000000000000..eebadb09a90f
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-descr
@@ -0,0 +1,10 @@
+POE::Component::IRC::Plugin::QueryDNS is a POE::Component::IRC plugin
+that provides DNSBL query facilities to the channels it occupies and via
+private messaging.
+
+It uses POE::Component::Client::DNSBL to do non-blocking DNSBL queries.
+By default the plugin attempts to use POE::Component::IRC's internal
+PoCo-Client-DNS resolver object, but will spawn its own copy. You can
+supply your own resolver object via the constructor
+
+WWW: http://search.cpan.org/dist/POE-Component-IRC-Plugin-QueryDNSBL/
diff --git a/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-plist
new file mode 100644
index 000000000000..0fc61ebe531c
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-QueryDNSBL/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/POE/Component/IRC/Plugin/QueryDNSBL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/QueryDNSBL/.packlist
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/QueryDNSBL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE