aboutsummaryrefslogtreecommitdiff
path: root/irc/p5-POE-Component-IRC/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-18 23:07:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-18 23:07:01 +0000
commitef04b7f3ae07d0c1b72066f1524d35b856ee2c78 (patch)
tree27e91cf26a53df32847c864d0f62698b448c8b71 /irc/p5-POE-Component-IRC/Makefile
parent5c0d042ee77e26820e035c586dd6eb263d83485b (diff)
downloadports-ef04b7f3ae07d0c1b72066f1524d35b856ee2c78.tar.gz
ports-ef04b7f3ae07d0c1b72066f1524d35b856ee2c78.zip
Notes
Diffstat (limited to 'irc/p5-POE-Component-IRC/Makefile')
-rw-r--r--irc/p5-POE-Component-IRC/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/irc/p5-POE-Component-IRC/Makefile b/irc/p5-POE-Component-IRC/Makefile
new file mode 100644
index 000000000000..2760e15a7caf
--- /dev/null
+++ b/irc/p5-POE-Component-IRC/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: POE::Component::IRC
+# Date created: Aug 19, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-IRC
+PORTVERSION= 1.7
+CATEGORIES= irc devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= POE::Component::Filter-CTCP.3 \
+ POE::Component::IRC.3 \
+ POE::Component::Filter-IRC.3
+
+.include <bsd.port.mk>