aboutsummaryrefslogtreecommitdiff
path: root/irc/pircbot/Makefile
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-04-02 23:08:49 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-04-02 23:08:49 +0000
commitb693b7e99080b4c9dfa2208cad470245a507087b (patch)
tree34708dde48e6da03f360cf1cd71c358ac15b9b7c /irc/pircbot/Makefile
parent02ef56eaeae50f9f3b86275325e72ae68833965a (diff)
Notes
Diffstat (limited to 'irc/pircbot/Makefile')
-rw-r--r--irc/pircbot/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/irc/pircbot/Makefile b/irc/pircbot/Makefile
index 5834b023dcc6..c4a309688654 100644
--- a/irc/pircbot/Makefile
+++ b/irc/pircbot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pircbot
-PORTVERSION= 1.4.2
+PORTVERSION= 1.4.4
CATEGORIES= irc java
MASTER_SITES= http://www.jibble.org/files/ \
ftp://ftp.i-scream.org/pub/www.jibble.org/files/ \
@@ -18,11 +18,11 @@ COMMENT= PircBot Java IRC Bot Framework
USE_ZIP= yes
NO_BUILD= yes
-USE_JAVA= 1.1+
+USE_JAVA= yes
do-install:
${INSTALL_DATA} ${WRKSRC}/pircbot.jar ${JAVAJARDIR}
-.if !defined(NOPORTDOCS)
+.ifndef(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
(cd ${WRKSRC}/javadocs && ${TAR} -cf - . | ${TAR} -xf - -C ${DOCSDIR})
.endif
@@ -32,7 +32,7 @@ post-install:
@${ECHO_MSG} " To use pircbot add ${JAVAJARDIR}/pircbot.jar to"
@${ECHO_MSG} " your classpath. A short tutorial can be found here:"
@${ECHO_MSG} " http://www.jibble.org/pircbot.php"
-.if !defined(NOPORTDOCS)
+.ifndef(NOPORTDOCS)
@${ECHO_MSG} " pircbot javadoc documentation has also been installed in:"
@${ECHO_MSG} " ${DOCSDIR}"
.endif